You are not logged in.

#1 2024-04-02 17:08:55

caracole
Member
Registered: 2024-04-02
Posts: 2

Strange beep when adjusting volume in pavucontrol

Hi smile

I simply installed pipewire and wireplumber on a new Arch and everything works perfectly: I can play music, use youtube, record my voice etc....
The only "problem" is that it beeps (like a bubble sound) every time I adjust the volume of an output device using pavucontrol. It doesn't seem to be a bug but rather a feature, and I just want to disable it.
Indeed, I can change the volume with wpctl/pactl and there is no beep.
My pipewire version is 1.0.4 and wireplumber 0.5.1
I have the kernel parameter snd-intel-dspcfg=3 (=1 doesn't work) and I boot Arch with EFISTUB.

If needed :

sudo dmesg | grep -E "snd|sof"
[    0.000000] Command line: root=UUID=4da18493-b23a-43ed-99ab-5b33543bb8b2 rw loglevel=3 quiet snd-intel-dspcfg.dsp_driver=3 ignore_dmi=1 nvidia_drm.modeset=1 initrd=\EFI\ArchLinux\initramfs-linux.img
[    0.038014] Kernel command line: root=UUID=4da18493-b23a-43ed-99ab-5b33543bb8b2 rw loglevel=3 quiet snd-intel-dspcfg.dsp_driver=3 ignore_dmi=1 nvidia_drm.modeset=1 initrd=\EFI\ArchLinux\initramfs-linux.img
[    0.040066] software IO TLB: area num 16.
[    0.353883] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.353884] software IO TLB: mapped [mem 0x000000004c717000-0x0000000050717000] (64MB)
[    0.579008] integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
[    0.579018] integrity: Loaded X.509 cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
[    5.158833] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[    5.158970] snd_hda_intel 0000:01:00.1: Disabling MSI
[    5.158975] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    5.376740] sof-audio-pci-intel-cnl 0000:00:1f.3: enabling device (0000 -> 0002)
[    5.376935] sof-audio-pci-intel-cnl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
[    5.381962] sof-audio-pci-intel-cnl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    5.388625] sof-audio-pci-intel-cnl 0000:00:1f.3: use msi interrupt mode
[    5.425299] sof-audio-pci-intel-cnl 0000:00:1f.3: hda codecs found, mask 5
[    5.425302] sof-audio-pci-intel-cnl 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    5.425304] sof-audio-pci-intel-cnl 0000:00:1f.3: DMICs detected in NHLT tables: 2
[    5.428089] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware paths/files for ipc type 0:
[    5.428091] sof-audio-pci-intel-cnl 0000:00:1f.3:  Firmware file:     intel/sof/sof-cml.ri
[    5.428091] sof-audio-pci-intel-cnl 0000:00:1f.3:  Topology file:     intel/sof-tplg/sof-hda-generic-2ch.tplg
[    5.429430] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware info: version 2:2:0-57864
[    5.429431] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:23:0
[    5.429433] sof-audio-pci-intel-cnl 0000:00:1f.3: unknown sof_ext_man header type 3 size 0x30
[    5.560412] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware info: version 2:2:0-57864
[    5.560415] sof-audio-pci-intel-cnl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:23:0
[    5.569649] sof-audio-pci-intel-cnl 0000:00:1f.3: Topology: ABI 3:22:1 Kernel ABI 3:23:0
[    5.588240] snd_hda_codec_realtek ehdaudio0D0: autoconfig for ALC3254: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    5.588243] snd_hda_codec_realtek ehdaudio0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.588244] snd_hda_codec_realtek ehdaudio0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    5.588246] snd_hda_codec_realtek ehdaudio0D0:    mono: mono_out=0x0
[    5.588246] snd_hda_codec_realtek ehdaudio0D0:    inputs:
[    5.588247] snd_hda_codec_realtek ehdaudio0D0:      Headset Mic=0x19
[    5.588248] snd_hda_codec_realtek ehdaudio0D0:      Headphone Mic=0x1b
[    6.270424] input: sof-hda-dsp Headphone Mic as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input23
[    6.270452] input: sof-hda-dsp HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input24
[    6.270476] input: sof-hda-dsp HDMI/DP,pcm=4 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input25
[    6.270497] input: sof-hda-dsp HDMI/DP,pcm=5 as /devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card1/input26

If there is nothing to do, I will just find an alternative to pavucontrol roll

Offline

#2 2024-04-02 21:59:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,900

Re: Strange beep when adjusting volume in pavucontrol

Either mute  the notification sounds directly in pavucontrol (there was a bug in wireplumber 0.5 that didn't respect this properly, should be fixed in 0.5.1) or disable event sounds for gtk applications: https://bbs.archlinux.org/viewtopic.php … 3#p1945083

Offline

#3 2024-04-03 14:03:48

caracole
Member
Registered: 2024-04-02
Posts: 2

Re: Strange beep when adjusting volume in pavucontrol

Thank you ! I did not think that it was related to gtk

Offline

Board footer

Powered by FluxBB