You are not logged in.

#1 2024-03-13 06:03:01

Pyrophorus2
Member
Registered: 2023-04-11
Posts: 15

Errors during upgrading/updating

I've been trying to upgrade my laptop for sometime now.
Had quite a few troubles, and they only seem to have increased

error: libx11: signature from "Laurent Carlier <lordheavym@gmail.com>" is marginal trust
:: File /var/cache/pacman/pkg/libx11-1.8.7-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: vulkan-icd-loader: signature from "Laurent Carlier <lordheavym@gmail.com>" is marginal trust
:: File /var/cache/pacman/pkg/vulkan-icd-loader-1.3.279-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: vulkan-headers: signature from "Laurent Carlier <lordheavym@gmail.com>" is marginal trust
:: File /var/cache/pacman/pkg/vulkan-headers-1:1.3.279-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: plasma-activities: signature from "Tomaz Canabrava <tcanabrava@archlinux.org>" is marginal trust
:: File /var/cache/pacman/pkg/plasma-activities-6.0.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: libplasma: signature from "Tomaz Canabrava <tcanabrava@archlinux.org>" is marginal trust
:: File /var/cache/pacman/pkg/libplasma-6.0.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: bluedevil: signature from "Tomaz Canabrava <tcanabrava@archlinux.org>" is marginal trust
:: File /var/cache/pacman/pkg/bluedevil-1:6.0.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: rhash: signature from "Johannes Löthberg <johannes@kyriasis.com>" is marginal trust
:: File /var/cache/pacman/pkg/rhash-1.4.4-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: libxpm: signature from "Laurent Carlier <lordheavym@gmail.com>" is marginal trust
:: File /var/cache/pacman/pkg/libxpm-3.5.17-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: libkscreen: signature from "Tomaz Canabrava <tcanabrava@archlinux.org>" is marginal trust
:: File /var/cache/pacman/pkg/libkscreen-6.0.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)

Offline

#2 2024-03-13 06:08:00

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,774

Re: Errors during upgrading/updating

Update archlinux-keyring first, then try updating the system again.

Offline

#3 2024-03-21 05:01:21

Pyrophorus2
Member
Registered: 2023-04-11
Posts: 15

Re: Errors during upgrading/updating

That did help, but now I'm getting this.

error: failed to commit transaction (conflicting files)
luajit: /usr/bin/luajit exists in filesystem
luajit: /usr/include/luajit-2.1/lauxlib.h exists in filesystem
luajit: /usr/include/luajit-2.1/lua.h exists in filesystem
luajit: /usr/include/luajit-2.1/lua.hpp exists in filesystem
luajit: /usr/include/luajit-2.1/luaconf.h exists in filesystem
luajit: /usr/include/luajit-2.1/luajit.h exists in filesystem
luajit: /usr/include/luajit-2.1/lualib.h exists in filesystem
luajit: /usr/lib/libluajit-5.1.so exists in filesystem
luajit: /usr/lib/libluajit-5.1.so.2 exists in filesystem
luajit: /usr/lib/pkgconfig/luajit.pc exists in filesystem
luajit: /usr/share/licenses/luajit/COPYRIGHT exists in filesystem
luajit: /usr/share/man/man1/luajit.1.gz exists in filesystem
Errors occurred, no packages were upgraded.
 -> error installing repo packages
error installing repo packages

Offline

#4 2024-03-21 05:14:38

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,557

Re: Errors during upgrading/updating

Offline

#5 2024-04-03 21:45:12

Pyrophorus2
Member
Registered: 2023-04-11
Posts: 15

Re: Errors during upgrading/updating

Overwrite helped quite a bit, but I got a debug error, and now yay is giving me:

yay: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory

Offline

#6 2024-04-03 21:47:40

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,774

Re: Errors during upgrading/updating

You are responsible for rebuilding AUR packages when they need to be.

Offline

Board footer

Powered by FluxBB