You are not logged in.

#1 2024-03-29 21:27:29

Saeverix
Member
Registered: 2024-03-29
Posts: 5

Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

Ever since I am using Arch Linux, I have been annoyed by the spinner/loader that is displayed as soon as the system starts.
It's always in the center of the screen, and it remains visible until you boot into Arch. I can also make it disappear by clearing the NVRAM on the MacBook, but it's back again after a second reboot.

I have never had this problem with other distros like Fedora or Ubuntu.
Yesterday I did a clean install of Arch + Gnome using "archinstall", hoping the problem would have been solved. But sadly it's still there.
I checked the systemd-boot settings and entries, but I could not discover any strange settings.

I have attached a GIF with a short video of the spinner. Hopefully somebody with a Mac sees this, and can help me solve the issue.

B83227F9-4BE4-4CED-98BA-170B79F58457.gif

Offline

#2 2024-03-30 00:00:42

zggzcgy
Member
From: CN
Registered: 2022-08-27
Posts: 9

Re: Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

Have you tried modifying time=0 in the $esp/loader/loader.conf file to turn off the display menu? more info

timeout  0

Offline

#3 2024-03-30 07:30:23

Saeverix
Member
Registered: 2024-03-29
Posts: 5

Re: Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

zggzcgy wrote:

Have you tried modifying time=0 in the $esp/loader/loader.conf file to turn off the display menu? more info

timeout  0

I just tried that, and even though the menu is gone the spinner is still there for 2-3 seconds.

I am fairly certain the spinner is from the MacBook UEFI, which now displays because some strange default setting in Arch.

Offline

#4 2024-03-30 10:37:45

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,771
Website

Re: Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

Try this kernel parameter:

bgrt_disable=1

Offline

#5 2024-03-30 20:27:12

Saeverix
Member
Registered: 2024-03-29
Posts: 5

Re: Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

Head_on_a_Stick wrote:

Try this kernel parameter:

bgrt_disable=1

Thanks for the suggestion. I added the parameter to the Arch configuration under "/boot/loader/entries", and cleared the Mac NVRAM (just to make site is had no leftover settings from before).
Sadly it made no difference, after a second reboot (after clearing the NVRAM) the spinner was back sad.

Offline

#6 2024-03-30 20:36:14

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,771
Website

Re: Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

Does Plymouth make it go away? I presume Fedora & Ubuntu use that.

Offline

#7 2024-03-30 20:54:06

Saeverix
Member
Registered: 2024-03-29
Posts: 5

Re: Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

That might be worth a shot, I will try and let you know.

Just tried it, short answer: It did not work.

Long answer: I installed Plymouth, added quiet and splash to the kernel parameters, added the mkinitcpio hook. Finally I set the theme to "spinner" using "plymouth-set-default-theme -R spinner" (which also runs mkinitcpio).
Now when it boots, it first shows the Mac UEFI Spinner for 2-3 seconds and then Plymouth starts.

Last edited by Saeverix (2024-03-30 22:06:42)

Offline

#8 2024-04-04 08:51:52

Saeverix
Member
Registered: 2024-03-29
Posts: 5

Re: Annoying spinner/loader on MacBook Pro 2012 + systemd-boot

Anyone else with a MacBook who solved this? Or anyone else with some things we can try?

Offline

Board footer

Powered by FluxBB