You are not logged in.

#1 2024-04-06 17:22:10

iceddog
Member
Registered: 2024-04-06
Posts: 4

[SOLVED] EAC troubles after system update

So I did a bad and recently did a system update forgetting to make a recent enough backup to rollback and although nothing that important broke I noticed that my EAC games seemingly don't want to launch anymore. I am not sure or able to identify what package might be causing this issue since I already checked to see if it was a vulkan-radeon issue or if I might have needed to switch over to glibc-eac from the AUR but neither seemed to fix it.

When I started to actually investigate my proton logs I could not find anything that seems super problematic just these 3 lines

46251.644:0124:0188:err:kerberos:kerberos_LsaApInitializePackage no Kerberos support, expect problems
46251.648:0124:0188:ntlm:ntlm_LsaApInitializePackage no NTLM support, expect problems
46251.654:0124:0140:err:msvcrt:_wassert (L"!status && \"vkCreateGraphicsPipelines\"",L"../src-wine/dlls/winevulkan/loader_thunks.c",2827)


I also tried looking back into my pacman log to see if I could try to figure out something that might have caused it but there have been too many packages upgraded in a short amount of time for me to cut it down

Also for reference the main game I was trying to launch was elden ring's online mode

Last edited by iceddog (2024-04-07 21:54:50)

Offline

#2 2024-04-06 19:11:19

just4arch
Member
Registered: 2023-01-07
Posts: 91

Re: [SOLVED] EAC troubles after system update

Offline

#3 2024-04-06 22:11:22

iceddog
Member
Registered: 2024-04-06
Posts: 4

Re: [SOLVED] EAC troubles after system update

I have taken a look into that but glibc-eac has not seemed to fix the issue either maybe I messed something else up neutral

Offline

#4 2024-04-07 20:38:06

iceddog
Member
Registered: 2024-04-06
Posts: 4

Re: [SOLVED] EAC troubles after system update

Just to add to how strange this situation is I was able to get a successful EAC launch 1 time after uninstalling and reinstalling the game. I was also using this command to see it in terminal.

steam steam://rungameid/{1245620}

Ever since that 1 successful run I have not been able to recreate it and I don't want to reinstall 50gb for a test sad

Offline

#5 2024-04-07 21:02:24

iceddog
Member
Registered: 2024-04-06
Posts: 4

Re: [SOLVED] EAC troubles after system update

I found the culprit! I don't know the technical explanation, but the packages amdvlk and lib32-amdvlk were the issue. When I swapped them out for vulkan-radeon and lib32-vulkan-radeon with a reboot, EAC was able to properly load. smile

Offline

Board footer

Powered by FluxBB