You are not logged in.

#1 2024-04-01 05:46:06

joca
Member
Registered: 2024-04-01
Posts: 4

Window resizing broken in archlinux vmware workstation guests

i ran a system upgrade tonight and afterwards running vmware workstation 17.5.1 on Archlinux host I am unable to resize an archlinux guest window.  If I go to full-screen mode It also does not auto-resize, but I can use xrandr to change to full windows resolution and that works.  I have reverted the system upgrade back to the last time I upgrade (which was on 03/22/20240 and window resizing is working again.  Below I have listed all the packages that got upgraded tonight when this feature broke.  I thought the issue may be in open-vm-tools and I downgraded just that package but that did not solve my issue so I'm not sure if its a dependency or not.  i did go through the dependencies on https://archlinux.org/packages/extra/x8 … -vm-tools/ but downgrading those that were upgraded on my list below did not help (I may have missed a step other than just pacman -U the old version from the pacman cache).  I'm not sure if this is the correct place to report this and am happy to move that to the correct place if someone could point me to it.  Thanks !

[2024-03-31T21:40:15-0700] [PACMAN] starting full system upgrade
[2024-03-31T21:40:32-0700] [ALPM] upgraded adwaita-cursors (45.0-1 -> 46.0-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libsysprof-capture (45.2-1 -> 46.0-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded iana-etc (20231228-1 -> 20240222-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded bzip2 (1.0.8-5 -> 1.0.8-6)
[2024-03-31T21:40:32-0700] [ALPM] upgraded pcre2 (10.42-2 -> 10.43-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded sqlite (3.45.1-1 -> 3.45.2-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded util-linux-libs (2.39.3-2 -> 2.40-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded glib2 (2.78.4-1 -> 2.80.0-2)
[2024-03-31T21:40:32-0700] [ALPM] upgraded xorgproto (2023.2-1 -> 2024.1-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libx11 (1.8.7-1 -> 1.8.8-2)
[2024-03-31T21:40:32-0700] [ALPM] upgraded harfbuzz (8.3.0-2 -> 8.4.0-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded expat (2.6.1-1 -> 2.6.2-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded cairo (1.18.0-1 -> 1.18.0-2)
[2024-03-31T21:40:32-0700] [ALPM] upgraded icu (74.2-1 -> 74.2-2)
[2024-03-31T21:40:32-0700] [ALPM] upgraded xz (5.6.0-1 -> 5.6.1-2)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libxml2 (2.12.5-1 -> 2.12.6-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded pango (1:1.52.0-1 -> 1:1.52.2-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded lz4 (1:1.9.4-2 -> 1:1.9.4-3)
[2024-03-31T21:40:32-0700] [ALPM] upgraded librsvg (2:2.57.1-1 -> 2:2.58.0-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded gtk-update-icon-cache (1:4.12.5-1 -> 1:4.14.1-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded adwaita-icon-theme (45.0-1 -> 46.0-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded aom (3.8.1-1 -> 3.8.2-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libldap (2.6.6-2 -> 2.6.7-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded e2fsprogs (1.47.0-1 -> 1.47.0-2)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libverto (0.3.2-4 -> 0.3.2-5)
[2024-03-31T21:40:32-0700] [ALPM] upgraded audit (4.0-1 -> 4.0.1-2)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libcap (2.69-3 -> 2.69-4)
[2024-03-31T21:40:32-0700] [ALPM] upgraded coreutils (9.4-3 -> 9.5-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded ca-certificates-mozilla (3.98-1 -> 3.99-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libunistring (1.1-2 -> 1.2-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded curl (8.6.0-3 -> 8.7.1-3)
[2024-03-31T21:40:32-0700] [ALPM] upgraded gnutls (3.8.3-1 -> 3.8.4-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded libassuan (2.5.6-1 -> 2.5.7-1)
[2024-03-31T21:40:32-0700] [ALPM] upgraded pinentry (1.2.1-3 -> 1.3.0-1)
[2024-03-31T21:40:33-0700] [ALPM] upgraded gnupg (2.4.4-1 -> 2.4.5-1)
[2024-03-31T21:40:33-0700] [ALPM] upgraded pacman (6.0.2-9 -> 6.1.0-3)
[2024-03-31T21:40:33-0700] [ALPM] upgraded archlinux-keyring (20240208-1 -> 20240313-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded gsettings-desktop-schemas (45.0-1 -> 46.0-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded cryptsetup (2.7.0-3 -> 2.7.1-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded shadow (4.14.6-1 -> 4.15.1-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded util-linux (2.39.3-2 -> 2.40-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded kmod (31-1 -> 32-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded libxkbcommon (1.6.0-1 -> 1.7.0-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded at-spi2-core (2.50.1-1 -> 2.52.0-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded c-ares (1.27.0-1 -> 1.28.1-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded nss (3.98-1 -> 3.99-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded libpciaccess (0.18-1 -> 0.18.1-1)
[2024-03-31T21:40:34-0700] [ALPM] upgraded libunwind (1.7.2-1 -> 1.8.1-1)
[2024-03-31T21:40:35-0700] [ALPM] upgraded llvm-libs (16.0.6-1 -> 17.0.6-2)
[2024-03-31T21:40:35-0700] [ALPM] upgraded mesa (1:24.0.2-1 -> 1:24.0.3-2)
[2024-03-31T21:40:35-0700] [ALPM] upgraded libva (2.20.0-1 -> 2.21.0-1)
[2024-03-31T21:40:35-0700] [ALPM] upgraded dav1d (1.4.0-1 -> 1.4.1-1)
[2024-03-31T21:40:35-0700] [ALPM] upgraded libcloudproviders (0.3.5-1 -> 0.3.6-1)
[2024-03-31T21:40:35-0700] [ALPM] upgraded glib-networking (1:2.78.1-1 -> 1:2.80.0-1)
[2024-03-31T21:40:35-0700] [ALPM] upgraded tracker3 (3.6.0-3 -> 3.7.1-1)
[2024-03-31T21:40:35-0700] [ALPM] upgraded libxmu (1.1.4-1 -> 1.2.0-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded chromium (122.0.6261.111-1 -> 123.0.6312.86-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded http-parser (2.9.4-1 -> 2.9.4-2)
[2024-03-31T21:40:36-0700] [ALPM] upgraded eza (0.18.6-1 -> 0.18.9-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded fakeroot (1.33-2 -> 1.34-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded libdeflate (1.19-1 -> 1.20-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded openexr (3.2.2-1 -> 3.2.4-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded libjxl (0.10.1-1 -> 0.10.2-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded libopenmpt (0.7.4-1 -> 0.7.6-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded svt-av1 (1.8.0-1 -> 2.0.0-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded vapoursynth (R65-1 -> R66-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded libdovi (3.2.0-2 -> 3.3.0-1)
[2024-03-31T21:40:36-0700] [ALPM] upgraded ffmpeg (2:6.1.1-6 -> 2:6.1.1-7)
[2024-03-31T21:40:37-0700] [ALPM] upgraded firefox (123.0.1-1 -> 124.0.1-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded glibmm (2.66.6-1 -> 2.66.7-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded grub (2:2.12-1 -> 2:2.12-2)
[2024-03-31T21:40:37-0700] [ALPM] upgraded gtkmm3 (3.24.8-1 -> 3.24.9-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libmnl (1.0.5-1 -> 1.0.5-2)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libnfnetlink (1.0.2-1 -> 1.0.2-2)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libnetfilter_conntrack (1.0.9-1 -> 1.0.9-2)
[2024-03-31T21:40:37-0700] [ALPM] upgraded iproute2 (6.7.0-1 -> 6.8.0-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libdnet (1.17.0-1 -> 1.18.0-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libmspack (1:0.11alpha-1 -> 1:1.11-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libngtcp2 (1.3.0-1 -> 1.4.0-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded unibilium (2.1.1-1 -> 2.1.1-2)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libtermkey (0.22-2 -> 0.22-3)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libxaw (1.0.15-1 -> 1.0.16-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded libxkbcommon-x11 (1.6.0-1 -> 1.7.0-1)
[2024-03-31T21:40:37-0700] [ALPM] upgraded mkinitcpio (38-4 -> 38.1-1)
[2024-03-31T21:40:38-0700] [ALPM] upgraded linux (6.7.8.arch1-1 -> 6.8.2.arch2-1)
[2024-03-31T21:40:38-0700] [ALPM] upgraded linux-firmware-whence (20240220.97b693d2-1 -> 20240312.3b128b60-1)
[2024-03-31T21:40:38-0700] [ALPM] upgraded linux-firmware (20240220.97b693d2-1 -> 20240312.3b128b60-1)
[2024-03-31T21:40:38-0700] [ALPM] upgraded lsof (4.99.3-1 -> 4.99.3-2)
[2024-03-31T21:40:38-0700] [ALPM] upgraded tree-sitter (0.20.10-2 -> 0.22.2-1)
[2024-03-31T21:40:38-0700] [ALPM] upgraded neovim (0.9.5-2 -> 0.9.5-4)
[2024-03-31T21:40:38-0700] [ALPM] upgraded nodejs (21.7.0-1 -> 21.7.1-1)
[2024-03-31T21:40:39-0700] [ALPM] upgraded node-gyp (10.0.1-1 -> 10.1.0-1)
[2024-03-31T21:40:39-0700] [ALPM] upgraded procps-ng (4.0.4-2 -> 4.0.4-3)
[2024-03-31T21:40:39-0700] [ALPM] upgraded open-vm-tools (6:12.3.5-1 -> 6:12.4.0-1)
[2024-03-31T21:40:39-0700] [ALPM] upgraded openssh (9.6p1-3 -> 9.7p1-1)
[2024-03-31T21:40:39-0700] [ALPM] upgraded pkgconf (2.1.0-2 -> 2.1.1-1)
[2024-03-31T21:40:39-0700] [ALPM] upgraded psmisc (23.6-1 -> 23.7-1)
[2024-03-31T21:40:39-0700] [ALPM] upgraded wget (1.21.4-1 -> 1.24.5-1)
[2024-03-31T21:40:39-0700] [ALPM] upgraded xf86-video-vmware (13.4.0-1 -> 13.4.0-2)
[2024-03-31T21:40:39-0700] [ALPM] upgraded xorg-server-common (21.1.11-1 -> 21.1.11-2)
[2024-03-31T21:40:39-0700] [ALPM] upgraded xorg-server (21.1.11-1 -> 21.1.11-2)
[2024-03-31T21:40:57-0700] [PACMAN] starting full system upgrade
[2024-03-31T21:43:09-0700] [ALPM] upgraded yay (12.3.1-1 -> 12.3.5-1)
[2024-03-31T21:43:09-0700] [ALPM] upgraded yay-debug (12.3.1-1 -> 12.3.5-1)
[2024-03-31T21:43:09-0700] [ALPM] upgraded brave-bin (1:1.63.169-1 -> 1:1.64.113-1)
[2024-03-31T21:43:09-0700] [ALPM] upgraded librewolf-bin (123.0-1 -> 124.0.1-1)
[2024-03-31T21:43:09-0700] [ALPM] upgraded librewolf-bin-debug (123.0-1 -> 124.0.1-1)

Offline

#2 2024-04-01 09:00:09

seth
Member
Registered: 2012-09-03
Posts: 54,177

Re: Window resizing broken in archlinux vmware workstation guests

It's a completely wild guess, but there's an input bug in libx11, xf86-video-vmware depends on it - I'd try those two first…

Offline

#3 2024-04-01 09:25:09

joca
Member
Registered: 2024-04-01
Posts: 4

Re: Window resizing broken in archlinux vmware workstation guests

seth wrote:

It's a completely wild guess, but there's an input bug in libx11, xf86-video-vmware depends on it - I'd try those two first…

This was a pretty good guess.  I downgraded just xf86-video-vmware and that solved the window resizing bug.  I'm not able to open an issue on https://gitlab.archlinux.org/archlinux/ … deo-vmware due to an inability to register an account unfortunately.  Commits on https://gitlab.freedesktop.org/xorg/dri … deo-vmware are also pretty old.  If anyone is able to help open an issue so the package maintainer for archlinux is able to roll back the changes that would be helpful.

Offline

#4 2024-04-01 12:54:51

seth
Member
Registered: 2012-09-03
Posts: 54,177

Re: Window resizing broken in archlinux vmware workstation guests

xf86-video-vmware is actually a natural contender, the off-putting aspect is

[2024-03-31T21:40:39-0700] [ALPM] upgraded xf86-video-vmware (13.4.0-1 -> 13.4.0-2)

it's just supposed to be a rebuild.

Unfortunately I'm too stupid to use the new bugtracker as well (further down you get to read by how much I underestimated the idiocy of that "2FA" system wink)

Offline

#5 2024-04-08 03:26:47

b4283
Member
Registered: 2008-11-26
Posts: 123

Re: Window resizing broken in archlinux vmware workstation guests

I can confirm this issue and can reproduce consistently.  Note there were other problems for me: window rendering for emacs were broken.  If anyone is curious, try to open up a Emacs window and enter Dired mode through "C-x d <RET>" and use the arrow keys to move the cursor around to see if the cursor movements were problematic.

I have reviewed the commits between 13.4.0-1 and 13.4.0-2, but unfortunately nothing significant has changed.  (https://gitlab.archlinux.org/archlinux/ … mmits/main).   I don't think the upstream has changed as well -- It appears to be the same tarball.  Initially my thoughts were some ABI incompatibilities caused this, but rebuilding the package does not help.

I extracted the rev-1 and rev-2 pkg.tar.zst files and tried to hex compare the binaries between two directories, but it's too hard for me to spot anything.  The binary sizes are different.  If there's anything guys want me to do on my machine, I can.  So far downgrading it to 13.4.0-1 is the only way to resolve the problems.

Offline

#6 2024-04-08 06:46:47

seth
Member
Registered: 2012-09-03
Posts: 54,177

Re: Window resizing broken in archlinux vmware workstation guests

https://gitlab.archlinux.org/archlinux/ … 7b18a575a1 seems to just have changed linker flags and package deps.
libx11 has meanwhile been updated to 1.8.9 and interim 1.8.3 contained a patch to at least fix the XIM related issues.

b/c of the rendering issues - what are you running inside the VM? Gnome?
Cause there're plenty of "rendering broken" and "can't resize windows" or "windows become click through" threads about the 46 release.

Offline

#7 2024-04-08 19:34:33

seth
Member
Registered: 2012-09-03
Posts: 54,177

Offline

#8 2024-04-09 01:06:51

b4283
Member
Registered: 2008-11-26
Posts: 123

Re: Window resizing broken in archlinux vmware workstation guests

Thanks @seth.  The rel-3 version fixed all my issues.

**EDIT**: I'm running a XFCE4 environment.  That issue is fixed, too.

An extra comma in the linker flag is wild.  Hope I had spotted that earlier.

Last edited by b4283 (2024-04-09 01:08:03)

Offline

#9 2024-04-09 06:30:11

seth
Member
Registered: 2012-09-03
Posts: 54,177

Re: Window resizing broken in archlinux vmware workstation guests

I didn't see it either - just looked at it, "nah, that's just a rebuild, does nothing" and moved on.
… and this is how we ended up w/ the xz situation …

Luckily andytr isn't any malicious - just slightly fat-fingered tongue

Offline

Board footer

Powered by FluxBB