You are not logged in.

#26 2024-04-08 19:44:51

Itms
Member
Registered: 2023-11-25
Posts: 17

Re: [SOLVED] libata errors when accessing the SSD on a Surface Pro 2

seth wrote:

You could also disable DMA

Without DMA, the errors are less frequent so I could power through an installation to disk. The resulting system is very difficult to use due to permanent freezes, but it should be easier to test stuff on it now.

Here is a system journal from the installed system: http://0x0.st/XiYL.txt

Offline

#27 2024-04-08 21:50:36

seth
Member
Registered: 2012-09-03
Posts: 52,545

Re: [SOLVED] libata errors when accessing the SSD on a Surface Pro 2

I don't think the ALPM is related to my issue: to my knowledge there is no power saving daemon running in the live environment.

https://wiki.archlinux.org/title/Power_ … Management

tail /sys/class/scsi_host/host*/link_power_management_policy

https://man.archlinux.org/man/core/hdparm/hdparm.8.en#B

hdparm -B /dev/sda
hdparm -B 254 /dev/sda # or 255, see manpage

If the drive/connection isn't physically damaged, this has to be some power setting.

Offline

#28 2024-04-09 08:06:37

Itms
Member
Registered: 2023-11-25
Posts: 17

Re: [SOLVED] libata errors when accessing the SSD on a Surface Pro 2

Oof, ALPM was indeed the issue. I am so sorry to have overlooked it when you first suggested it.

tail /sys/class/scsi_host/host*/link_power_management_policy

returned

med_power_with_dipm

which I thought was recommended but not the default (in the wiki page you linked).

Setting it to

medium_power

fixes the issue yikes

EDIT: I had to add the udev rule file for persistent config to the FILES array of /etc/mkinitcpio.conf, and then rebuild my initramfs, or else the config setting was activated too late in the boot process, causing disk errors to considerably slow down the system boot.

Thanks so much for your help.

Last edited by Itms (2024-04-09 08:33:32)

Offline

#29 2024-04-09 08:25:30

seth
Member
Registered: 2012-09-03
Posts: 52,545

Re: [SOLVED] libata errors when accessing the SSD on a Surface Pro 2

Dos it help to regenerate the initramfs to include the udev rules there?

Offline

#30 2024-04-09 08:34:50

Itms
Member
Registered: 2023-11-25
Posts: 17

Re: [SOLVED] libata errors when accessing the SSD on a Surface Pro 2

seth wrote:

Dos it help to regenerate the initramfs to include the udev rules there?

Ah, your message crossed my edit. Regenerating the initramfs was not enough, I had to add the rules file to mkinitcpio.conf, it was not picked up by default.

Offline

Board footer

Powered by FluxBB