You are not logged in.

#1 2024-04-12 02:24:51

monr0e
Member
Registered: 2024-04-12
Posts: 4

libpthread woes with older PKGBUILDs

I'm trying to build a version of kodi-standalone-service that ships with Kodi 20.2, because a number of addons that I favour are not ported to v21.

During the build, cmake falls over:

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find Threads (missing: Threads_FOUND)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindThreads.cmake:226 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:129 (find_package)

I've learned that it may be possible to get around this with some cmake flags added to the CMakeLists file in xmbc's build folder, but I can't make this stick because makepkg wipes and recreates the build directory when it is run. Can I avoid makepkg recreating the build dir, and instead flag it to rely on whatever is already there?

Alternatively, is there something I can do about libpthread to fix this properly? I have already installed the libpthread-stubs package, although it is also out of date.

Offline

#2 2024-04-12 04:41:09

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,729
Website

Re: libpthread woes with older PKGBUILDs

monr0e wrote:

Can I avoid makepkg recreating the build dir, and instead flag it to rely on whatever is already there?

Yes.  There's a flag specifically for this - read the man page.


"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Offline

Board footer

Powered by FluxBB