You are not logged in.

#1 2024-04-19 14:55:04

0liver
Member
Registered: 2014-05-20
Posts: 42

boot partition almost full

5 years ago when i made a new installation, i created a boot VFAT partition with 100 MB.
According to an installation guide this seemed big enough. Here is the layout:

https://photos.app.goo.gl/GR16ukC9yGrMXYUg8

After todays system upgrade only 2MB free space is left for the boot partition. I suspect this will be unsufficient for the next upgrade.

The remainder of the disk is a 1TB LVM partition. I consider it too much a challenge to fiddle with pvmove/pvresize and relocate the LVM partition to get some space to enlarge the boot partition.

I admit to not understand why the loader images grow with each upgrade. Is there any way to get smaller images? (or in worst case suppress the generation of the fallback img.)

Any help is appreciated!

Offline

#2 2024-04-19 15:30:22

seth
Member
Registered: 2012-09-03
Posts: 53,182

Re: boot partition almost full

a) remove the kms hook from mkinitcpio.conf to prevent the GPU firmwares from being embedded into the initramfs
b) disable the fallback initramfs (this is certainly no problem if you've some live distro that you can boot from if need be), see /etc/mkinitcpio.d/linux*

Offline

#3 2024-04-19 16:32:25

0liver
Member
Registered: 2014-05-20
Posts: 42

Re: boot partition almost full

thank you!
i don't have kms in hooks, only these:

HOOKS=(base udev autodetect microcode modconf block keymap encrypt lvm2 resume filesystems keyboard fsck)

and in /etc/mkinitcpio.d/linux.preset i have

# mkinitcpio preset file for the 'linux' package

ALL_kver="/boot/vmlinuz-linux"

PRESETS=('default' 'fallback')

default_image="/boot/initramfs-linux.img"

fallback_image="/boot/initramfs-linux-fallback.img"
fallback_options="-S autodetect"

without fallback img, should this be this way? :

# mkinitcpio preset file for the 'linux' package

ALL_kver="/boot/vmlinuz-linux"

#PRESETS=('default' 'fallback')
PRESETS=('default')

default_image="/boot/initramfs-linux.img"

#fallback_image="/boot/initramfs-linux-fallback.img"
#fallback_options="-S autodetect"

Offline

#4 2024-04-19 16:42:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,093

Re: boot partition almost full

Yep -- and manually remove the unnecessary fallback initramfs.

Offline

#5 2024-04-22 15:04:24

MS-DTYP
Member
Registered: 2020-05-01
Posts: 28

Re: boot partition almost full

If you use GRUB2, you can just move your /boot to the LVM partition and create the /efi partition with GRUB2.

Offline

#6 2024-04-28 13:48:04

whitesnow
Member
Registered: 2015-01-04
Posts: 54

Re: boot partition almost full

Just a Question:

Why exactly is it, that the firmware now gets included into each initramfs image, instead like before being only once in the boot partition?

Offline

#7 2024-04-28 13:57:36

seth
Member
Registered: 2012-09-03
Posts: 53,182

Re: boot partition almost full

Are you asking about the CPU µcode and the microcode hook (afaik the GPU firmware, topic of this thread, has never been put on the boot partition what changed is nouveau support for GSP, https://bbs.archlinux.org/viewtopic.php … 5#p2154175 )

Offline

#8 2024-04-28 16:02:34

whitesnow
Member
Registered: 2015-01-04
Posts: 54

Re: boot partition almost full

Offline

#9 2024-04-28 16:26:04

seth
Member
Registered: 2012-09-03
Posts: 53,182

Re: boot partition almost full

My best guess for the motivation would be that it's probably UKI related, otherwise it doesn't matter and you don't have to use the microcode hook at all.
https://wiki.archlinux.org/title/Microc … n_one_file

This method is preferred over #Microcode in a separate initramfs file since no additional boot parameter configuration is necessary.

Offline

Board footer

Powered by FluxBB