You are not logged in.

#1 2024-04-28 05:30:35

ChenWangStar
Member
Registered: 2024-02-24
Posts: 3

After bios_grub is enabled, os-prober does not seem to be enabled

My computer equipment is relatively old, can only use BIOS boot mode. And I have two hard drives, one in MBR format, and I installed Windows 10 on that hard drive. The second is the GPT format. I originally wanted to use bios_grub to install Arch Linux on it, but when I finished following the official Arch Linux installation guide, I didn't see Windows10 in the boot option.

I ran the os-prober command, but it didn't produce any output. I also removed the GRUB_DISABLE_OS_PROBER=false comment, but after the restart, I still did not see the startup item of Windows10.I don't want to change my GPT hard drive to MBR because MBR only supports 4 primary partitions.

When I used the Manjaro system before, I used the Calamares installer to install the Manjaro system on my GPT format hard disk.

But for various reasons, I wanted to switch to Arch linux. I read a lot of articles, but I still can't display my Windows 10 startup entry..

Offline

#2 2024-04-28 08:04:36

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,899
Website

Re: After bios_grub is enabled, os-prober does not seem to be enabled


Mr Green

Offline

#3 2024-04-30 15:47:48

ChenWangStar
Member
Registered: 2024-02-24
Posts: 3

Re: After bios_grub is enabled, os-prober does not seem to be enabled

I have tried to use this method to fix it before, but it doesn't seem to have any effect.

Offline

#4 2024-04-30 15:50:07

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,703

Re: After bios_grub is enabled, os-prober does not seem to be enabled

What, exactly, did you try from that link?

Online

#5 2024-05-03 02:41:58

ChenWangStar
Member
Registered: 2024-02-24
Posts: 3

Re: After bios_grub is enabled, os-prober does not seem to be enabled

Uh., I seem to have discovered why it didn't work before. My previous system was installed from a PE environment, but it seems that no boot was provided during the installation process, causing os-prober to be unable to find it. A few days ago, I reinstalled the Windows 10 system. So it has a boot partition, and after mounting the boot partition, os-prober works normally.

Anyway, I sincerely thank you

Offline

Board footer

Powered by FluxBB