You are not logged in.

#1 2024-05-09 00:07:07

xsmith
Member
Registered: 2024-04-17
Posts: 3

Unable to automatically mount bcachefs filesystem on boot

I installed Arch Linux to a bcachefs filesystem made of multiple disks. Even though I have added the filesystem to my fstab, it does not automatically mount on boot. I am able to manually mount the filesystem with the command:

mount -t bcachefs /dev/nvme0n1p3:/dev/sda1:/dev/sdb1:/dev/sdc1:/dev/sdd1 new_root

After which I am able to exit and, the system boots and operates as normal.

The relevant line in the fstab file is:
`/dev/nvme0n1p3:/dev/sda1:/dev/sdb1:/dev/sdc1:/dev/sdd1  /               bcachefs        rw,relatime,metadata_replicas=2,data_replicas=2,foreground_target=ssd,background_target=hdd,promote_target=ssd      0 0`

How can I fix my system so that it automatically mounts the root filesystem and boots as normal without manual intervention?

Offline

#2 2024-05-09 00:43:46

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,791

Re: Unable to automatically mount bcachefs filesystem on boot

fstab makes no difference here, this is happening in early userspace well before fstab is accessible. The initramfs gets it's information on what to mount from the root= parameter on the kernel command line, that's what you need to be using but I have no idea if it'll support that.

Offline

#3 2024-05-09 06:04:15

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,856
Website

Re: Unable to automatically mount bcachefs filesystem on boot

xsmith wrote:

How can I fix my system so that it automatically mounts the root filesystem and boots as normal without manual intervention?

https://wiki.archlinux.org/title/Bcache … vice_fstab


Juri divino omnia sunt communia

Offline

#4 2024-07-19 09:13:11

Halano
Member
From: Egypt
Registered: 2023-02-07
Posts: 19
Website

Re: Unable to automatically mount bcachefs filesystem on boot

/dev/nvme0n1p3:/dev/sda1:/dev/sdb1:/dev/sdc1:/dev/sdd1  /   bcachefs  rw,relatime,metadata_replicas=2,data_replicas=2,foreground_target=ssd,background_target=hdd,promote_target=ssd  0 0

What you did is messy I suggest you use UUID ,here auto mount ext4 on my system ig bcachefs would be similar

UUID=b57d4666-6be0-4708-afce-073363ef7681 /mnt/base ext4 defaults 0 0

HalanoSiblee The Smart Moth

Offline

Board footer

Powered by FluxBB