You are not logged in.

#1 2024-05-11 15:57:07

glitsj16
Member
Registered: 2015-04-26
Posts: 122

[Solved] Build parrot without dropping nodejs-lts-hydrogen depends

Today I tried to build parrot from the AUR. It depends on nodejs (via node-gyp and yarn). So far nothing irregular. I got stuck very early on in makepkg, due to having 2 packages installed from the official repo:   

Both depend on nodejs-lts-hydrogen.   

$ pacman -Qi bitwarden-cli | grep nodejs
Depends On      : nodejs-lts-hydrogen
web-ext
$ pacman -Qi web-ext | grep nodejs
Provides        : nodejs-web-ext
Depends On      : nodejs>=16.0.0  nodejs<20
Conflicts With  : nodejs-web-ext
Replaces        : nodejs-web-ext

$ pacman -Q nodejs-lts-hydrogen
nodejs-lts-hydrogen 18.18.2-2

How does one deal with such a dependency conflict (if at all possible)? Obviously I don't want to uninstall bitwarden-cli and web-ext.

TIA

Last edited by glitsj16 (2024-05-11 16:20:28)

Offline

#2 2024-05-11 16:08:24

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,661

Re: [Solved] Build parrot without dropping nodejs-lts-hydrogen depends

Offline

#3 2024-05-11 16:18:37

glitsj16
Member
Registered: 2015-04-26
Posts: 122

Re: [Solved] Build parrot without dropping nodejs-lts-hydrogen depends

@Scimmia   
Oh man, I didn't think about that option. Thank you.

Offline

Board footer

Powered by FluxBB