You are not logged in.

#1 2024-05-15 16:45:00

Marvix
Member
Registered: 2013-10-08
Posts: 148

volumeicon doesn't start on startup

Hello there, community!

I use bare Openbox with titn2 for my panel with volueicon as volume manager. For at least a year, volumeicon doesn't start on start up and I have to call it from the terminal. It my occur when I moved to pipewire.

I checked the with journalctl -xe and jouranlctl -r with results. I tried to reinstall, without success.

I noticed when I log out and log again, volumeicon appears in the tray.

I've checked the ~/.config/openbox/autostart, as shown below, and I don't find anything suspicious.

#
# These things are run when an Openbox X Session is started.
# You may place a similar script in $HOME/.config/openbox/autostart
# to run user-specific things.
#
# If you want to use GNOME config tools...
#
#if test -x /usr/lib/openbox/gnome-settings-daemon >/dev/null; then
#  /usr/lib/openbox/gnome-settings-daemon &
#elif which gnome-settings-daemon >/dev/null 2>&1; then
#  gnome-settings-daemon &
#fi

## Autostart File ##

# Disable beep sound on boot
xset b off
xset b 0 0 0

# Screen settings
# Laptop screen of, desktop screen on
## xrandr
xrandr --output HDMI1 --mode 1920x1080 --pos 0x0 --rotate normal --output LVDS1 --off --output VIRTUAL1 --off --output DP1 --off --output VGA1 --off

## Disable touchpad
#/usr/bin/synclient TouchpadOff=1

## Numpad on boot
numlockx

# Keyboard layout in english and greek with left windows key
setxkbmap -layout "us,el" -option "grp:lwin_toggle" &

## Background wallpaper
nitrogen --restore &

## LXPanel
#lxpanel &

## Tint Panel
tint2 &

sleep 2

##  Volume Icon
volumeicon &

sleep 1

## Network Manager Applet
nm-applet &

sleep 1

## Power Manager
xfce4-power-manager &

sleep 1

xxkb &

sleep 1

## Redshift (for eye strain prevention)
redshift-gtk &

## Compositor
# picom -f

## Keyboard indicator
xxkdb &

sleep 1

## Polkit - Gnome
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1

I searched for other topics, where I found many relevant, but anything I tried, didn't work for me.

What can/shall I do?

Last edited by Marvix (2024-05-15 22:48:38)

Offline

#2 2024-05-15 22:27:50

mesaprotector
Member
Registered: 2024-03-03
Posts: 64

Re: volumeicon doesn't start on startup

Volumeicon has some issues with pipewire; if it tries to load before pipewire-pulse is fully loaded, it won't work. I recommend running a script at login that will put a delay and avoid attempting to load volumeicon until the WM is already running. Here is what I use:

[asuka@Marojejy bin]$ cat ~/.local/bin/volumeicon.sh

#!/bin/bash
sleep 5 &&
volumeicon

You can make the delay longer if it doesn't always work with 5 seconds. This script is the second to last line in my .xinitrc, just before exec openbox.

Last edited by mesaprotector (2024-05-15 22:32:29)

Offline

#3 2024-05-15 23:06:01

Marvix
Member
Registered: 2013-10-08
Posts: 148

Re: volumeicon doesn't start on startup

I set it to 10 seconds, but it persists.

I forgot to mention, volumeicon appears muted for some seconds on tint2 at the startup, and then collapses and disappears.

Offline

#4 2024-05-16 06:11:03

mesaprotector
Member
Registered: 2024-03-03
Posts: 64

Re: volumeicon doesn't start on startup

What happens if you try using .xinitrc with startx instead of autostart? It does seem like it isn't loading the audio source correctly. If you still want to try autostart, try having a sound file play - any file - before starting volumeicon, and see if that fixes it.

Offline

#5 2024-05-18 23:33:15

dichead
Member
Registered: 2003-05-29
Posts: 5

Re: volumeicon doesn't start on startup

I tried using volumeicon with openbox before and had the same issue. Firing up pipewire with systemd on login fixed it for me.

Try this

systemctl --user enable pipewire

then add volumeicon back into your autostart file and logout.

Last edited by dichead (2024-05-18 23:37:11)

Offline

Board footer

Powered by FluxBB