You are not logged in.

#1 2024-05-10 03:41:13

yunk
Member
Registered: 2024-05-10
Posts: 5

Monitor does not detect input if I turn on computer first

Hi there,

I have an issue where turning on my PC first causes my monitor to be unable to detect the displayport output until I enter my password. If I turn on the monitor first, there's no issue.

I use greetd with tuigreet for my login manager.

Please let me know what other info I can provide. Thanks!

Offline

#2 2024-05-10 19:41:25

seth
Member
Registered: 2012-09-03
Posts: 53,068

Re: Monitor does not detect input if I turn on computer first

I use greetd with tuigreet for my login manager.

There's not gonna be any mode switch and the powered off monitor will likely not show up.
You can enforce it to be assumed present w/ a specific resolution, https://wiki.archlinux.org/title/Kernel … cing_modes
Ideally powering it on will then just have the framebuffer signal be pumped there and you can see it when powering on the monitor.

If not or if you don't want I'd try to switch the VT ctrl+alt+f2) forth and back and see whether that triggers a mode switch.
Or whether you can generate one w/ fbset.

Offline

#3 2024-05-11 04:02:54

yunk
Member
Registered: 2024-05-10
Posts: 5

Re: Monitor does not detect input if I turn on computer first

Dang, no luck. I tried to follow those steps and ended up trying to add

video=DP-3:3440x1440@60

and then

video=DP-3:e

to my options string in

/boot/loaders/entries/xxx_linux.conf

Logging in causes the monitor to figure itself out and all is good from there. I'd just like to be able to see my login screen on mornings when I turn things on in reverse order (most mornings*)

Thank you for your suggestion!

Last edited by yunk (2024-05-11 04:06:50)

Offline

#4 2024-05-11 07:17:00

seth
Member
Registered: 2012-09-03
Posts: 53,068

Re: Monitor does not detect input if I turn on computer first

Did you ensure "cat /proc/cmdline" that the parameters got applied?
Is DP-3 the correct output name (/sys/class/drm)?
Try to add "initcall_blacklist=simpledrm_platform_driver_init" to the kernel paramters to make sure the simpledrm device doesn't get in the way.

Have you tried whether
a) switching the VT
b) running fbset before the DM
activates the output?
(nb you've to use a mode from /etc/fb.modes - try "1024x768-60")

Offline

#5 2024-05-13 01:45:11

yunk
Member
Registered: 2024-05-10
Posts: 5

Re: Monitor does not detect input if I turn on computer first

Thank you for the suggestions, still no joy. I switched over to trying DP-4 since "xrandr" shows:

Screen 0: minimum 8 x 8, current 3440 x 1440, maximum 32767 x 32767
DVI-D-0 disconnected primary (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 connected 3440x1440+0+0 (normal left inverted right x axis y axis) 800mm x 345mm
   3440x1440     60.00*+ 144.00   100.00    50.00    30.00  
   3840x2160     59.94    50.00  
   2560x1440     60.00  
   1920x1200     59.88  
   1920x1080    119.88    60.00    59.94    50.00  
   1720x1440     60.00  
   1680x1050     59.95  
   1600x1200     60.00  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.95    59.94    59.93  
DP-5 disconnected (normal left inverted right x axis y axis)

"cat /proc/cmdline" seems to be showing the right thing, it gives:

initrd=\amd-ucode.img initrd=\initramfs-linux.img root=PARTUUID=56198226-af85-4966-9909-b9b0563c319e zswap.enabled=0 rootflags=subvol=@ rw rootfstype=btrfs nvidia_drm.modeset=1 quiet initcall_blacklist=simpledrm_platform_driver_init video=DP-4:3440x1440@60

"ls /sys/class/drm" surprised me, as I don't see DP-4 as an option in there. It gives:

card0  card0-DP-1  card0-DP-2  card0-DP-3  card0-DVI-D-1  card0-HDMI-A-1  renderD128  version

a) Switching VT doesn't seem to have any effect
b) I don't currently have fbset configured. I tried installing it, and got the following when trying to run it at all: "open /dev/fb0: No such file or directory"

Offline

#6 2024-05-13 16:08:26

seth
Member
Registered: 2012-09-03
Posts: 53,068

Re: Monitor does not detect input if I turn on computer first

for OUT in /sys/class/drm/card*; do echo $OUT; edid-decode $OUT/edid; echo "================="; done

You'll need https://aur.archlinux.org/packages/edid-decode-git

This should tell you which device there is the right one and the names there are relevant, not the xrandr ones.

Offline

#7 2024-05-17 04:01:10

yunk
Member
Registered: 2024-05-10
Posts: 5

Re: Monitor does not detect input if I turn on computer first

Okay, that showed that it's DP-3 (not DP-4)

/sys/class/drm/card0-DP-3

I tried changing my kernel params to use that with

/sys/class/drm/card0-DP-3

Still no luck.

Offline

#8 2024-05-17 06:09:34

seth
Member
Registered: 2012-09-03
Posts: 53,068

Re: Monitor does not detect input if I turn on computer first

You somewhat tested that in #3, but the ouptut count seems unstable?
And try a VESA mode: "video=DP-3:1024x768@60e video=DP-4:1024x768@60e"

https://wiki.archlinux.org/title/Getty# … al_console
https://wiki.archlinux.org/title/Xinit# … X_at_login
Autostart/activate https://wiki.archlinux.org/title/Session_lock

Offline

#9 2024-05-23 07:05:21

yunk
Member
Registered: 2024-05-10
Posts: 5

Re: Monitor does not detect input if I turn on computer first

seth wrote:

You somewhat tested that in #3, but the ouptut count seems unstable?
And try a VESA mode: "video=DP-3:1024x768@60e video=DP-4:1024x768@60e"

Alright, tried that in my params but still no output. It looks like so:

options root=PARTUUID=56198226-af85-4966-9909-b9b0563c319e zswap.enabled=0 rootflags=subvol=@ rw rootfstype=btrfs nvidia_drm.modeset=1 quiet initcall_blacklist=simpledrm_platform_driver_init video=DP-3:1024x768@60e video=DP-4:1024x768@60e

Offline

Board footer

Powered by FluxBB