You are not logged in.

#1 2024-05-29 01:18:02

Yukiko
Member
Registered: 2024-05-29
Posts: 2

I installed KDevelop (and FDM from flathub) and they cannot started

I used pacman to install it, but I can't start it, the output of

journalctl -xe

is below:

5月 29 09:00:59 myhome plasmashell[2067]: [2:2:0529/090059.856370:ERROR:interface_endpoint_client.cc(722)] Message 0 rejected by interface blink.mojom.WidgetHost
5月 29 09:01:06 myhome plasmashell[1066]: qt.gui.imageio: libpng warning: iCCP: known incorrect sRGB profile
5月 29 09:01:10 myhome systemd[877]: Started KDevelop - 集成开发环境.
░░ Subject: UNIT 单元已结束启动
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ UNIT 单元已结束启动。
░░ 
░░ 启动结果为“done”。
5月 29 09:01:10 myhome plasmashell[4168]: /usr/bin/kdevelop: error while loading shared libraries: libicui18n.so.75: cannot open shared object file: No such file or directory
5月 29 09:01:10 myhome plasmashell[1066]: kf.kio.gui: "<html>命令 <tt></tt> 无法找到。</html>"
5月 29 09:01:13 myhome pipewire[974]: mod.client-node: 0x5c2c8336b460: unknown peer 0x5c2c83329ac0 fd:46

Another question is when I installed FDM from flathub, it cannot be started too, and here is the output:

5月 29 09:04:52 myhome systemd[877]: Started app-flatpak-org.freedownloadmanager.Manager-4917.scope.
░░ Subject: UNIT 单元已结束启动
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ UNIT 单元已结束启动。
░░ 
░░ 启动结果为“done”。
5月 29 09:04:52 myhome DiscoverNotifier[4933]: /app/extra/opt/freedownloadmanager/fdm: error while loading shared libraries: libgssapi_krb5.so.2: cannot open shared object file: No such file or directory
5月 29 09:04:52 myhome plasma-discover[1938]: kf.kio.gui: "<html>命令 <tt></tt> 无法找到。</html>"

I have checked the libgssapi_krb5.so.2, it doesn't exist in "/var/lib/flatpak/app/org.freedownloadmanager.Manager/x86_64/stable/345dd1461ec1a2ab788c46a9e8812de67aaa298c15a41082c3c186fba9003453/files/lib/" so I copied one from other application to that place, but not worked.

Offline

#2 2024-05-29 02:00:23

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,690

Re: I installed KDevelop (and FDM from flathub) and they cannot started

You did a partial update. You cannot just update part of your system, or install packages that are newer than the rest of your system. Fully update everything and it should work.

Online

#3 2024-05-31 01:08:09

Yukiko
Member
Registered: 2024-05-29
Posts: 2

Re: I installed KDevelop (and FDM from flathub) and they cannot started

Scimmia wrote:

You did a partial update. You cannot just update part of your system, or install packages that are newer than the rest of your system. Fully update everything and it should work.

Just excute sudo pacman -Syuu, then reboot, not works, same output(for FDM), but KDevelop is working properly now

Last edited by Yukiko (2024-05-31 01:09:19)

Offline

Board footer

Powered by FluxBB