You are not logged in.

#1 2024-06-01 16:17:20

geopardo
Member
From: Europe
Registered: 2021-03-23
Posts: 125

[SOLVED] nvidia modules not found.

==> ERROR: module not found: `nvidia'
==> ERROR: module not found: `nvidia_modeset'
==> ERROR: module not found: `nvidia_uvm'
==> ERROR: module not found: `nvidia_drm'

Strange issue after last update i see this error when launch mkinitcpio command..
building nvidia 470.239.06

Last edited by geopardo (2024-06-11 19:38:53)


Some 'security people are f*cking morons' says Linus Torvalds..

Offline

#2 2024-06-01 16:41:56

dimalmfao
Member
From: Uranus, 42 Phosphate Factory
Registered: 2024-06-01
Posts: 6
Website

Re: [SOLVED] nvidia modules not found.

Did you follow all the steps of the nvidia installation guide?
All of them are very important.

If you did, everything should go fine.
Could you please send the output of:

$ dmesg | grep nvidia
$ journalctl -xe | grep nvidia

Offline

#3 2024-06-01 20:31:30

geopardo
Member
From: Europe
Registered: 2021-03-23
Posts: 125

Re: [SOLVED] nvidia modules not found.

$ journalctl -xe | grep nvidia

this command do nothing..

$ sudo dmesg | grep nvidia
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-linux-hardened root=UUID=a28f0267-276c-4a55-a2aa-261007d61aed rw audit=1 loglevel=3 quiet nvidia_drm.modeset=1 nvidia-drm.fbdev=1 module_blacklist=nouveau lsm=apparmor,bpf,landlock,lockdown,yama,integrity
[    0.118703] Kernel command line: pti=on page_alloc.shuffle=1 BOOT_IMAGE=/boot/vmlinuz-linux-hardened root=UUID=a28f0267-276c-4a55-a2aa-261007d61aed rw audit=1 loglevel=3 quiet nvidia_drm.modeset=1 nvidia-drm.fbdev=1 module_blacklist=nouveau lsm=apparmor,bpf,landlock,lockdown,yama,integrity

Some 'security people are f*cking morons' says Linus Torvalds..

Offline

#4 2024-06-01 21:25:06

dimalmfao
Member
From: Uranus, 42 Phosphate Factory
Registered: 2024-06-01
Posts: 6
Website

Re: [SOLVED] nvidia modules not found.

I assume you followed all the steps then.
Have you tried to reinstall the nvidia drivers?

Also, as you mentioned, you launched the mkinitcpio
command. Did you include the -P flag?

Offline

#5 2024-06-01 21:31:02

geopardo
Member
From: Europe
Registered: 2021-03-23
Posts: 125

Re: [SOLVED] nvidia modules not found.

Yes use -P flag.
Drivers working, first to reinstall I need to know the issue.


Some 'security people are f*cking morons' says Linus Torvalds..

Offline

#6 2024-06-01 21:42:11

dimalmfao
Member
From: Uranus, 42 Phosphate Factory
Registered: 2024-06-01
Posts: 6
Website

Re: [SOLVED] nvidia modules not found.

I don't understand, are they working?
What's the issue?

It's pretty straight forward, the module
its trying to load, is not found.

Last edited by dimalmfao (2024-06-01 21:43:59)

Offline

#7 2024-06-01 22:11:36

loqs
Member
Registered: 2014-03-06
Posts: 17,714

Re: [SOLVED] nvidia modules not found.

What nvidia and kernel packages are installed?  What is the running kernel version?

pacman -Qo /usr/lib/modules
pacman -Qs nvidia
uname -a

Please also post the mkinitcpio command you used and its full output.

Last edited by loqs (2024-06-01 22:13:25)

Offline

#8 2024-06-02 08:50:33

geopardo
Member
From: Europe
Registered: 2021-03-23
Posts: 125

Re: [SOLVED] nvidia modules not found.

loqs wrote:

What nvidia and kernel packages are installed?  What is the running kernel version?

pacman -Qo /usr/lib/modules
pacman -Qs nvidia
uname -a

Please also post the mkinitcpio command you used and its full output.

[greenman@greenhub ~]$ pacman -Qo /usr/lib/modules
/usr/lib/modules/ è contenuto in linux-hardened 6.9.3.hardened1-1
/usr/lib/modules/ è contenuto in linux-hardened-headers 6.9.3.hardened1-1
[greenman@greenhub ~]$ pacman -Qs nvidia
local/egl-wayland 2:1.1.13-2
    EGLStream-based Wayland external platform
local/lib32-nvidia-470xx-utils 470.239.06-1
    NVIDIA drivers utilities (32-bit)
local/lib32-opencl-nvidia-470xx 470.239.06-1
    OpenCL implemention for NVIDIA (32-bit)
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/libxnvctrl 550.78-1
    NVIDIA NV-CONTROL X extension
local/nvidia-470xx-dkms 470.239.06-1
    NVIDIA drivers - module sources
local/nvidia-470xx-utils 470.239.06-1
    NVIDIA drivers utilities
local/nvidia-settings 550.78-1
    Tool for configuring the NVIDIA graphics driver
local/opencl-nvidia-470xx 470.239.06-1
    OpenCL implemention for NVIDIA
[greenman@greenhub ~]$ uname -a
Linux greenhub 6.9.3-hardened1-1-hardened #1 SMP PREEMPT_DYNAMIC Sat, 01 Jun 2024 00:25:24 +0000 x86_64 GNU/Linux
[greenman@greenhub ~]$ sudo mkinitcpio -P
[sudo] password di greenman: 
==> Building image from preset: /etc/mkinitcpio.d/linux-hardened.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-linux-hardened -g /boot/initramfs-linux-hardened.img
==> Starting build: '6.9.3-hardened1-1-hardened'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [keyboard]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> ERROR: module not found: 'nvidia'
==> ERROR: module not found: 'nvidia_modeset'
==> ERROR: module not found: 'nvidia_uvm'
==> ERROR: module not found: 'nvidia_drm'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-linux-hardened.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux-hardened.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-linux-hardened -g /boot/initramfs-linux-hardened-fallback.img -S autodetect
==> Starting build: '6.9.3-hardened1-1-hardened'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [keyboard]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'wd719x'
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> ERROR: module not found: 'nvidia'
==> ERROR: module not found: 'nvidia_modeset'
==> ERROR: module not found: 'nvidia_uvm'
==> ERROR: module not found: 'nvidia_drm'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-linux-hardened-fallback.img'
==> WARNING: errors were encountered during the build. The image may not be complete.

Some 'security people are f*cking morons' says Linus Torvalds..

Offline

#9 2024-06-02 11:03:16

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,093

Re: [SOLVED] nvidia modules not found.

You need to update your nvidia-470xx packages to nvidia-470xx-dkms 470.239.06-2 because they include a fix for compiling with the new GCC version.

Also your fallback image generation fails,likely due to lack of space, but the more immediate issue will be that the DKMS rebuild will have failed because you don't have the fixed nvidia-470xx-dkms module.

Offline

#10 2024-06-11 19:25:43

geopardo
Member
From: Europe
Registered: 2021-03-23
Posts: 125

Re: [SOLVED] nvidia modules not found.

V1del wrote:

You need to update your nvidia-470xx packages to nvidia-470xx-dkms 470.239.06-2 because they include a fix for compiling with the new GCC version.

Also your fallback image generation fails,likely due to lack of space, but the more immediate issue will be that the DKMS rebuild will have failed because you don't have the fixed nvidia-470xx-dkms module.

This fix and working.. tnx! I mark solved smile


Some 'security people are f*cking morons' says Linus Torvalds..

Offline

#11 2024-06-11 19:37:08

geopardo
Member
From: Europe
Registered: 2021-03-23
Posts: 125

Re: [SOLVED] nvidia modules not found.

loqs wrote:

What nvidia and kernel packages are installed?  What is the running kernel version?

pacman -Qo /usr/lib/modules
pacman -Qs nvidia
uname -a

Please also post the mkinitcpio command you used and its full output.

Recent NVIDIA drivers they continue to work.. there is no longer the archaic error in starx of no input, after login X.
And even the desktop no longer has wrong resolution with outdated drivers, I say expired for the kernel smile

Maybe there are problems with the games.. I'll try to test why some games stopped loading.

Progress has finally been made..


Now I have another problem on Radeon, as soon as I finish the machine if it arises I'll open the topic. RGB radeon would be a green startup screen that appears on the UEFI BIOS screen.. the setting on windows 10 in the radeon application is rgb control. Another curious story to solve. Sorry for the off topic, but it's interesting.

AMD-Radeon-Software-Pixel-Format.webp

Last edited by geopardo (2024-06-11 19:37:39)


Some 'security people are f*cking morons' says Linus Torvalds..

Offline

Board footer

Powered by FluxBB