You are not logged in.

#1 2024-06-14 19:51:16

js-384
Member
Registered: 2024-06-14
Posts: 3

[SOLVED] "Invalid kernel specified: '/boot/vmlinuz-linux'"

[EDIT]: I saw that when installing linux through pacman, it mentions not being able to write certain things on /boot (ESP) because there's not enough space. I believe that's causing my issue.
I can't see an obvious way to resize ESP with Windows installed right next to it, but i believe that might work

Good afternoon Arch-ians smile

I'm trying to install Arch alongside my current Windows 11 install. I have used other distros before on this PC
I've followed the steps in the Installation guide.
I then ran into issues setting up EFISTUB. The option to boot into Arch was there but it kicks me back to BIOS.
I deleted both the partitions I made for Arch (/ and swap) and tried all of the steps in the installation guide again to make sure I didn't do anything wrong there, but it still wasn't fixed.
I saw that initramfs-linux.img was not on my ESP, which i believe is important. I saw on the installation guide that pacstrap automatically runs mkinitcpio for it.
I ran "mkinitcpio -v -P" in chroot and got an error (I've also run "dir /boot" and "lsblk" to show my ESP and where everything is mounted in case that could be a cause):
"ERROR: invalid kernel specified: '/boot/vmlinuz-linux'". ESP mounted to /boot

I've looked on the internet and Google for any help but couldn't find anything for my scenario
I'm using an ROG Strix G713RC laptop. I've been using it for only about a year now
Help would be very much appreciated

Last edited by js-384 (2024-06-18 00:52:32)

Offline

#2 2024-06-15 07:22:05

Funny0facer
Member
From: Germany
Registered: 2022-12-03
Posts: 95

Re: [SOLVED] "Invalid kernel specified: '/boot/vmlinuz-linux'"

I would suggest you use a different & bigger partition for your /boot partition. According to the Installation guide, 1 GiB is a recommendable size.

If nvme0n1p1 is used by windows, just let it be and create a new one for your /boot. But I do not have any experience in dual boot...

Offline

#3 2024-06-15 13:06:52

seth
Member
Registered: 2012-09-03
Posts: 54,169

Re: [SOLVED] "Invalid kernel specified: '/boot/vmlinuz-linux'"

You could keep nvme0n1p1 as ESP and boot from the root partition (provided you're using some bootloader and not UKIs) which probably has plenty of space.
Growing the boot partition in this constellation is kinda dicy esp. since it'll involve shrinking the NTFS partition and you NEED to have backups.

100MB will never be enough for a dual boot and even on  a single boot system can get tight.

Offline

#4 2024-06-15 15:28:33

js-384
Member
Registered: 2024-06-14
Posts: 3

Re: [SOLVED] "Invalid kernel specified: '/boot/vmlinuz-linux'"

Can I still have a UKI with a separate /boot partition?

[EDIT] I made and used a separate boot partition this time, and it was all fine then. Issue is that my BIOS doesn't see Arch despite it showing up in efibootmgr. Trying to add it back myself only lets me look in the first partition of my drives. I'm thinking either my BIOS is looking only at the first partitions assuming it's ESP or I somehow messed something up

[EDIT 2] It was my fault; was using the ESP uuid for root on efibootmgr. It appears but it gets stuck on a job for a disk that doesnt exist?? (img below)
20240615-183006.jpg

[EDIT 3] I was fucking around with partitions after I installed because I had the new ESP formatted with ext4. UEFI spec i read requires FAT32. Reinstalled properly and everything is finally working as it should be. Marking as solved smile

Solution: My existing ESP was too small, so resizing it or using a separate partition works

Last edited by js-384 (2024-06-15 23:13:23)

Offline

Board footer

Powered by FluxBB