You are not logged in.

#1 2024-06-24 10:16:43

breadegg4
Member
Registered: 2023-12-28
Posts: 9

inbuild AUDIO not working [AMD] Family 17h/19h HD Audio Controller

I using a latest update arch (6.9.6-arch1-1)

I follow the guide from https://wiki.archlinux.org/title/PipeWire and try all solution from other who have similiar audio problem but none of it work:
https://bbs.archlinux.org/viewtopic.php?id=292080
https://bbs.archlinux.org/viewtopic.php?id=286495
https://bbs.archlinux.org/viewtopic.php … 7#p2058087

need help about this problem been trying everything I can.

$ sudo lspci -kv | grep Audio
01:00.1 Audio device: NVIDIA Corporation Device 22be (rev a1)
05:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Rembrandt Radeon High Definition Audio Controller
	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Rembrandt Radeon High Definition Audio Controller
05:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] ACP/ACP3X/ACP6x Audio Coprocessor (rev 60)
05:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller
	DeviceName: HD Audio Controller
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 435
Tile Size: 65472
User Name: shat
Host Name: arch
Server Name: PulseAudio (on PipeWire 1.0.7)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_05_00.6.HiFi__hw_Generic_1__sink
Default Source: alsa_input.pci-0000_05_00.6.HiFi__hw_Generic_1__source
Cookie: 5ded:52q1
$ wpctl status | more

PipeWire 'pipewire-0' [1.0.7, shat@arch, cookie:1032913449]
 └─ Clients:
        32. pipewire                            [1.0.7, shat@arch, pid:888]
        44. WirePlumber                         [1.0.7, shat@arch, pid:3482]
        54. GNOME Volume Control Media Keys     [1.0.7, shat@arch, pid:1006]
        56. WirePlumber [export]                [1.0.7, shat@arch, pid:3482]
        67. Budgie Volume Control               [1.0.7, shat@arch, pid:1189]
        68. Budgie Volume Control               [1.0.7, shat@arch, pid:1189]
        69. Budgie Volume Control               [1.0.7, shat@arch, pid:1189]
        70. xdg-desktop-portal                  [1.0.7, shat@arch, pid:1410]
        71. Firefox                             [1.0.7, shat@arch, pid:1595]
        72. Firefox                             [1.0.7, shat@arch, pid:1595]
        78. libcanberra                         [1.0.7, shat@arch, pid:3389]
        79. WEBRTC VoiceEngine                  [1.0.7, shat@arch, pid:4851]
        80. Chromium input                      [1.0.7, shat@arch, pid:4894]
        82. WEBRTC VoiceEngine                  [1.0.7, shat@arch, pid:4851]
        99. wpctl                               [1.0.7, shat@arch, pid:6136]
       107. GNOME Settings                      [1.0.7, shat@arch, pid:5331]

Audio
 ├─ Devices:
 │      53. Family 17h/19h HD Audio Controller  [alsa]
 │      55. Rembrandt Radeon High Definition Audio Controller [alsa]
 │      59. HDA NVidia                          [alsa]
 │  
 ├─ Sinks:
 │  *  108. Family 17h/19h HD Audio Controller Speaker + Headphones [vol: 0.00]
 │  
 ├─ Sources:
 │  *  112. Family 17h/19h HD Audio Controller Headphones Stereo Microphone [vol: 1.00 MUTED]
 │     114. Family 17h/19h HD Audio Controller Digital Microphone [vol: 1.00 MUTED]
 │  
 ├─ Filters:
 │  
 └─ Streams:
        74. Firefox                                                     
             73. output_FR       > ALC256 Analog:playback_FR	[active]
             76. output_FL       > ALC256 Analog:playback_FL	[active]
        93. GNOME Settings                                              
             58. monitor_FR     
             61. monitor_FL     
             94. input_FL        < ALC256 Analog:capture_FL	[active]
            111. input_FR        < ALC256 Analog:capture_FR	[active]
       101. GNOME Settings                                              
             39. input_FL        < ALC256 Analog:capture_FL	[active]
             48. input_FR        < ALC256 Analog:capture_FR	[active]
             50. monitor_FR     
            105. monitor_FL     
       116. GNOME Settings                                              
             89. monitor_FR     
             97. input_FL        < ALC256 Analog:monitor_FL	[active]
            100. input_FR        < ALC256 Analog:monitor_FR	[active]
            102. monitor_FL     

Video
 ├─ Devices:
 │      35. Integrated Camera                   [v4l2]
 │      36. Integrated Camera                   [v4l2]
 │      63. Integrated Camera: Integrated C     [libcamera]
 │  
 ├─ Sinks:
 │  
 ├─ Sources:
 │  *   46. Integrated Camera (V4L2)           
 │  
 ├─ Filters:
 │  
 └─ Streams:

Settings
 └─ Default Configured Devices:
         0. Audio/Sink    alsa_output.pci-0000_05_00.6.HiFi__hw_Generic_1__sink
         1. Audio/Source  alsa_input.pci-0000_05_00.6.HiFi__hw_Generic_1__source
$ pactl list sinks
Sink #359
	State: RUNNING
	Name: alsa_output.pci-0000_05_00.6.HiFi__hw_Generic_1__sink
	Description: Family 17h/19h HD Audio Controller Speaker + Headphones
	Driver: PipeWire
	Sample Specification: s32le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 4294967295
	Mute: no
	Volume: front-left: 0 /   0% / -inf dB,   front-right: 26214 /  40% / -23.88 dB
	       balance 1.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.pci-0000_05_00.6.HiFi__hw_Generic_1__sink.monitor
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.card = "2"
		alsa.card_name = "HD-Audio Generic"
		alsa.class = "generic"
		alsa.components = "HDA:10ec0256,146213dd,00100002"
		alsa.device = "0"
		alsa.driver_name = "snd_hda_intel"
		alsa.id = "Generic_1"
		alsa.long_card_name = "HD-Audio Generic at 0xfc5c0000 irq 82"
		alsa.mixer_device = "_ucm0004.hw:Generic_1"
		alsa.mixer_name = "Realtek ALC256"
		alsa.name = "ALC256 Analog"
		alsa.resolution_bits = "16"
		alsa.subclass = "generic-mix"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		api.alsa.card.longname = "HD-Audio Generic at 0xfc5c0000 irq 82"
		api.alsa.card.name = "HD-Audio Generic"
		api.alsa.open.ucm = "true"
		api.alsa.path = "hw:Generic_1"
		api.alsa.pcm.card = "2"
		api.alsa.pcm.stream = "playback"
		audio.channels = "2"
		audio.position = "FL,FR"
		card.profile.device = "0"
		device.api = "alsa"
		device.class = "sound"
		device.id = "53"
		device.profile.description = "Speaker + Headphones"
		device.profile.name = "HiFi: hw:Generic_1: sink"
		device.routes = "2"
		factory.name = "api.alsa.pcm.sink"
		media.class = "Audio/Sink"
		device.description = "Family 17h/19h HD Audio Controller"
		node.name = "alsa_output.pci-0000_05_00.6.HiFi__hw_Generic_1__sink"
		node.nick = "ALC256 Analog"
		node.pause-on-idle = "false"
		object.path = "alsa:pcm:2:hw:Generic_1:playback"
		priority.driver = "1000"
		priority.session = "1000"
		factory.id = "18"
		clock.quantum-limit = "8192"
		client.id = "56"
		node.driver = "true"
		factory.mode = "merge"
		audio.adapt.follower = ""
		library.name = "audioconvert/libspa-audioconvert"
		object.id = "108"
		object.serial = "359"
		node.max-latency = "16384/48000"
		api.alsa.period-size = "1024"
		api.alsa.period-num = "32"
		api.alsa.headroom = "0"
		api.acp.auto-port = "false"
		api.alsa.card = "2"
		api.alsa.use-acp = "true"
		api.dbus.ReserveDevice1 = "Audio2"
		api.dbus.ReserveDevice1.Priority = "-20"
		device.bus = "pci"
		device.bus_path = "pci-0000:05:00.6"
		device.enum.api = "udev"
		device.icon_name = "audio-card-analog-pci"
		device.name = "alsa_card.pci-0000_05_00.6"
		device.nick = "HD-Audio Generic"
		device.plugged.usec = "4204621"
		device.product.id = "0x15e3"
		device.product.name = "Family 17h/19h HD Audio Controller"
		device.subsystem = "sound"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:05:00.6/sound/card2"
		device.vendor.id = "0x1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.string = "2"
	Ports:
		[Out] Speaker: Speaker (type: Speaker, priority: 100, availability unknown)
		[Out] Headphones: Headphones (type: Headphones, priority: 200, availability group: Headphone, available)
	Active Port: [Out] Headphones
	Formats:
		pcm
$ systemctl --user status pipewire-pulse pipewire wireplumber
● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; enabled; preset: enabled)
     Active: active (running) since Mon 2024-06-24 17:11:16 CST; 54min ago
 Invocation: 20b46e239eca48f9a1a7dff08c7448f7
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 888 (pipewire-pulse)
      Tasks: 3 (limit: 76177)
     Memory: 38.2M (peak: 39.2M)
        CPU: 20.369s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─888 /usr/bin/pipewire-pulse

Jun 24 17:11:16 h systemd[877]: Started PipeWire PulseAudio.
Jun 24 17:11:16 h pipewire-pulse[888]: default: can't run command load-module module-always-sink: File exists

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; preset: enabled)
     Active: active (running) since Mon 2024-06-24 17:11:16 CST; 54min ago
 Invocation: ebac70e533f84bed9d90a1429f54a9d5
TriggeredBy: ● pipewire.socket
   Main PID: 886 (pipewire)
      Tasks: 3 (limit: 76177)
     Memory: 26.9M (peak: 42.4M)
        CPU: 11.284s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─886 /usr/bin/pipewire

Jun 24 17:11:16 h systemd[877]: Started PipeWire Multimedia Service.

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
     Active: active (running) since Mon 2024-06-24 17:14:23 CST; 51min ago
 Invocation: 4ecade8038bc41249587e62ceb9967a5
   Main PID: 3482 (wireplumber)
      Tasks: 7 (limit: 76177)
     Memory: 7.4M (peak: 7.9M)
        CPU: 1.168s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─3482 /usr/bin/wireplumber

Jun 24 17:14:23 h systemd[877]: Started Multimedia Service Session Manager.
Jun 24 17:14:23 h wireplumber[3482]: wp-device: SPA handle 'api.alsa.acp.device' could not be loaded; is it installed?
Jun 24 17:14:23 h wireplumber[3482]: s-monitors: Failed to create 'api.alsa.acp.device' device
Jun 24 17:14:23 h wireplumber[3482]: spa.bluez5: BlueZ system service is not available
Jun 24 17:14:23 h wireplumber[3482]: [0:03:17.982183323] [3482] ERROR IPAModule ipa_module.cpp:172 Symbol ipaModuleInfo not found
Jun 24 17:14:23 h wireplumber[3482]: [0:03:17.982192370] [3482] ERROR IPAModule ipa_module.cpp:292 v4l2-compat.so: IPA module has no valid info
Jun 24 17:14:23 h wireplumber[3482]: [0:03:17.982211837] [3482]  INFO Camera camera_manager.cpp:313 libcamera v0.3.0
Jun 24 17:47:36 h wireplumber[3482]: spa.alsa: Failed to enable ucm device Mic1
Jun 24 17:47:36 h wireplumber[3482]: spa.alsa: Failed to enable ucm device Mic2

Offline

#2 2024-07-07 13:32:43

svenf
Member
Registered: 2024-07-07
Posts: 1

Re: inbuild AUDIO not working [AMD] Family 17h/19h HD Audio Controller

I have a similar problem (no audio through the HD Audio Controller after booting or (un)plugging headphones), though the command

$ alsactl init

temporarily fixes it for me.

Offline

Board footer

Powered by FluxBB