You are not logged in.

#1 2024-06-22 17:08:56

JRay
Member
From: Mississippi
Registered: 2024-06-22
Posts: 6

[SOLVED] PC gives pure black screen on everything.

This is an issue that has escalated since yesterday afternoon.

I have an ASUS TUF A17 laptop (Model name: FA707XI) with AMD Ryzen 9-7940HS CPU and Nvidia GeForce RTX 4070 GPU. I have been using Arch with 6.9.5 kernel with systemd-boot for the past three weeks. I was running it with i3 and GNOME on X11 with the latest version of the proprietary drivers (550). Unfortunately, I cannot provide any log information as you will see shortly why.

I used my PC last time yesterday at 6 PM. I did not do any manual update on my system at that time, and I assume Arch is not supposed to have any automatic update either.

However, at 8 PM, the next time I turned my PC on, I started to get black screen on the boot menu. I restarted my PC a couple of times after seeing this. It managed to boot fine after the timeout, but the PC displayed black screen consistently during the boot and on the BIOS menu. GDM and GNOME were displaying fine, along with tty, while i3 was showing black screen just like the boot and the BIOS menu.

I first uninstalled TLP since it was the most recent program I installed that might have affected my system, even though the PC was fine since I installed it two days ago. After seeing that uninstalling TLP did not solve the issue, I decided to switch to Nouveau drivers following the instructions on the ArchWiki page. Once I did that and rebooted, the PC displayed black screen on everything; GNOME, tty, and all the other things that were already showing nothing.

Today, I brought my PC to my office to connect it to an external monitor. It worked at first; I could get tty and GNOME on the external monitor, even though I still could not see the boot menu or the BIOS menu. I tried to switch back to the proprietary drivers again. Once I have done it, I probably doomed any chance to recover my PC. Now, the external monitor cannot detect my computer.

I don't even have the option to install anything from scratch, since I cannot get any display on the BIOS menu. I did a couple of tests to see if the PC actually works. I can log in to my user and shut down the PC from tty, so I am sure the PC is working fine. I am pretty sure the problem has to do with the drivers, but I cannot figure a way out of it. Now, I only hope there is somebody here who could help me with this issue.

Edit: The issue relates to the UEFI and was solved after a CMOS reset.

Last edited by JRay (2024-07-02 15:43:34)

Offline

#2 2024-06-22 20:42:48

cryptearth
Member
Registered: 2024-02-03
Posts: 394

Re: [SOLVED] PC gives pure black screen on everything.

the uefi not showing up sounds somewhat "uhm, strange as unlikely": usually an OS can't harm the systems firmware - so at any time you should be able to get into the bios
this "no output" is quite suspicious - as I won't see any reason for why this could happen suddenly out of the blue

Offline

#3 2024-06-22 21:03:21

JRay
Member
From: Mississippi
Registered: 2024-06-22
Posts: 6

Re: [SOLVED] PC gives pure black screen on everything.

cryptearth wrote:

the uefi not showing up sounds somewhat "uhm, strange as unlikely": usually an OS can't harm the systems firmware

I assume the problem has to do with the graphics driver. I looked for the same issue on the internet and the majority of the answers say that the problem should be caused by the driver. It makes sense to me because my problem became worse as I messed with the driver.

I cannot say for certain that the BIOS menu is working, as I could never get a graphic output on the display. However, I assume it should work fine. Currently, I cannot get output on GDM or on tty either, but I logged into tty and shut the machine down/restarted it a couple of times.

Offline

#4 2024-06-22 21:39:26

cryptearth
Member
Registered: 2024-02-03
Posts: 394

Re: [SOLVED] PC gives pure black screen on everything.

do you currently get ANY output to the integrated display? if not: do you get any output to any of the external ports?

Offline

#5 2024-06-22 21:58:45

seth
Member
Registered: 2012-09-03
Posts: 54,432

Re: [SOLVED] PC gives pure black screen on everything.

And if not, can you ssh into the system?
Can you boot some live distro (the install iso or eg. grml)?

Online

#6 2024-06-22 22:00:57

JRay
Member
From: Mississippi
Registered: 2024-06-22
Posts: 6

Re: [SOLVED] PC gives pure black screen on everything.

cryptearth wrote:

do you currently get ANY output to the integrated display? if not: do you get any output to any of the external ports?

I get no output to the integral display. When I connect the machine to the external monitor (Dell P2419H) via HDMI, the monitor does not get any signal, saying that there is no HDMI signal coming from my device. I was getting output this morning on the external monitor before I tried to switch back to the proprietary kernels.

seth wrote:

And if not, can you ssh into the system?
Can you boot some live distro (the install iso or eg. grml)?

I don't know much about remote connection and networking. How can I do that if I cannot get the IP address of my PC?
Is there a way to get the IP address from a local connection?

Last edited by JRay (2024-06-22 22:03:03)

Offline

#7 2024-06-22 22:13:09

seth
Member
Registered: 2012-09-03
Posts: 54,432

Re: [SOLVED] PC gives pure black screen on everything.

In order to ssh into the system, you first and foremost have to have sshd running on it.
You could nmap the network segment to find open ssh ports,

ip r | awk '!/default via/{print $1}' # make sure this prints sth .like 192.168.0.0/24
sudo nmap -p 22 $(ip r | awk '!/default via/{print $1}')

Edit: highlight and clarification that otherwise you'll have to try a live distro.

Last edited by seth (2024-06-22 22:13:49)

Online

#8 2024-06-22 22:13:25

cryptearth
Member
Registered: 2024-02-03
Posts: 394

Re: [SOLVED] PC gives pure black screen on everything.

I still don't see how fuzzing around with some drivers could be related to such symptoms - as even if you may encounter issues at the OS level the firmware shouldn't be affected by it and at least after a cold start should revert to some pre-defined state where the integrated display is selected as primary and hence should be available for interacting with the uefi setup.

Offline

#9 2024-06-24 15:14:45

JRay
Member
From: Mississippi
Registered: 2024-06-22
Posts: 6

Re: [SOLVED] PC gives pure black screen on everything.

Hello again!

I was not available to look into this problem yesterday. I attempted to follow seth's instructions today. So far I tried to make sure that sshd is active on my PC (I cannot say anything since it is not showing any visual output).

seth wrote:

You could nmap the network segment to find open ssh ports,

I used the nmap command from the desktop computer in my office. It has Windows 11 with a Debian instance in WSL.

nmap seems to have returned one output;

Starting Nmap 7.93 ( https://nmap.org ) at 2024-06-24 10:05 CDT
Nmap scan report for ECE-D2PDZC3.mshome.net (192.168.112.1)
Host is up (0.00066s latency).

PORT   STATE    SERVICE
22/tcp filtered ssh
MAC Address: 00:15:5D:8C:19:E1 (Microsoft)

Nmap scan report for 192.168.113.69
Host is up (0.000079s latency).

PORT   STATE  SERVICE
22/tcp closed ssh

Nmap done: 4096 IP addresses (2 hosts up) scanned in 9.90 seconds

Edit: Ok, so the IP address I am getting is definitely not my PC's one. I get the same output when my PC is turned off, and also I tried to connect to it with my username and it failed.

Last edited by JRay (2024-06-24 15:50:39)

Offline

#10 2024-06-24 21:08:06

seth
Member
Registered: 2012-09-03
Posts: 54,432

Re: [SOLVED] PC gives pure black screen on everything.

seth wrote:

Can you boot some live distro (the install iso or eg. grml)?

Online

#11 2024-06-24 21:42:41

JRay
Member
From: Mississippi
Registered: 2024-06-22
Posts: 6

Re: [SOLVED] PC gives pure black screen on everything.

Update: I solved the issue by a hard reset on the BIOS.

I basically opened up the laptop frame, unplugged the battery, and applied CMOS reset by pressing the power key for 60 seconds. After then I plugged the battery back and recharged the PC. Now I can get an output to my integrated display again.

Right now the PC is using the integrated AMD GPU. Below is the output to the command

glxinfo | grep OpenGL
OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon 780M (radeonsi, gfx1103_r1, LLVM 17.0.6, DRM 3.57, 6.9.5-arch1-1)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 24.1.1-arch1.1
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 24.1.1-arch1.1
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 24.1.1-arch1.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
seth wrote:

Can you boot some live distro (the install iso or eg. grml)?

I have a bootable USB stick with Arch, but I do not know how I could get to the live media while getting only black screen. I tried to use that USB stick and I got no different result.

Thank you all so much for the feedback. I will mark this issue as solved if you think it is appropriate. I will also set up my PC for remote connection in case I encounter this problem again in the future.

Offline

#12 2024-06-24 21:55:57

seth
Member
Registered: 2012-09-03
Posts: 54,432

Re: [SOLVED] PC gives pure black screen on everything.

If you had the same issues w/ a completely different SW stack (live usb) and fixed it by resetting the CMOS, it was a firmware issue all along.

Online

Board footer

Powered by FluxBB