You are not logged in.

#1 2024-05-02 07:04:33

archuser38013
Member
Registered: 2024-01-27
Posts: 67

Touchpad occasionally reactivates itself dispite disabling in .xinitrc

.Xinirc:

[[ -f ~/.Xresources ]] && xrdb -merge -I$HOME ~/.Xresources
xinput disable "SIGMACHIP USB Keyboard Mouse"
exec ratpoison

I disabled it originally because it would act weird and do randomly movement and clicks sometimes and also using a real mouse on the few occasions where a pointer is required preferring keyboard navigation mostly.

Despite being in the .xinitrc and working most of the time, on rare occasions it will be activated again and I have to run the xinput line again from the command line.

Offline

#2 2024-05-02 16:55:15

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,387

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

Are "rare occasions" a system update/waking up from suspend? Both conditions lead to a logical "reconnect" of the device.

Configure and disable it with a xorg configlet that will make xorg reapply the disablement each time (or flat out blacklist the responsible kernel module), e.g. a /etc/X11/xorg.conf.d/99-disableTouchpad.conf

Section "InputClass"
   MatchProduct "SIGMACHIP USB Keyboard Mouse"
   Option "Ignore" "true"
EndSection

you might want have some other conditions as detailed in: https://man.archlinux.org/man/xorg.conf … SS_SECTION

Also, your .xinitrc is incomplete and will very likely run you into problems sooner or later, fix it and make sure you include the relevant if statements and includes mentioned in the blue notes: https://wiki.archlinux.org/title/Xinit#xinitrc

Offline

#3 2024-05-20 11:22:46

archuser38013
Member
Registered: 2024-01-27
Posts: 67

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

V1del wrote:

Are "rare occasions" a system update/waking up from suspend? Both conditions lead to a logical "reconnect" of the device.

Configure and disable it with a xorg configlet that will make xorg reapply the disablement each time (or flat out blacklist the responsible kernel module), e.g. a /etc/X11/xorg.conf.d/99-disableTouchpad.conf

Section "InputClass"
   MatchProduct "SIGMACHIP USB Keyboard Mouse"
   Option "Ignore" "true"
EndSection

you might want have some other conditions as detailed in: https://man.archlinux.org/man/xorg.conf … SS_SECTION

Also, your .xinitrc is incomplete and will very likely run you into problems sooner or later, fix it and make sure you include the relevant if statements and includes mentioned in the blue notes: https://wiki.archlinux.org/title/Xinit#xinitrc

Oops, late reply, mainly because I hadn't noticed it for a while however it has been occurring again recently. Will have to monitor too see if it follows the behavior you mention.

Can the touchpad also responsible for random 's' keypresses? When then touchpad is playing up if I move to the terminal s will be pressed repeatedly but seems to stop when I manually disable the touchpad again via xinput script.

I don't think it happens after sleeps, actually not sure as I didn't shut the lid this time, so maybe that was just the screen off energy saving thing linux had and not sleep.

Seems to happen, from memory, more often in the morning soon after having turned the machine on and logged in.

Ok, I have added the conf file instead as you suggest. Btw how could I also remove the cursor too? I do use and external mouse too though sometimes but try and stay keyboard based much of the time. There are times though that a mouse just makes more sense and not practical to do by kb only so would want the cursor back when real mouse is used. I am not too bothered whether it goes or not though if not easy to do.

Last edited by archuser38013 (2024-05-20 11:27:40)

Offline

#4 2024-05-20 16:01:41

seth
Member
Registered: 2012-09-03
Posts: 54,484

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

how could I also remove the cursor too … kb only so would want the cursor back when real mouse is used

https://archlinux.org/packages/extra/x86_64/unclutter/

Online

#5 2024-05-23 05:44:49

archuser38013
Member
Registered: 2024-01-27
Posts: 67

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

seth wrote:

how could I also remove the cursor too … kb only so would want the cursor back when real mouse is used

https://archlinux.org/packages/extra/x86_64/unclutter/

Just the ticket! Thanks.

Offline

#6 2024-05-23 06:04:52

seth
Member
Registered: 2012-09-03
Posts: 54,484

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

\o/
Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Online

#7 2024-06-25 02:42:58

archuser38013
Member
Registered: 2024-01-27
Posts: 67

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

seth wrote:

how could I also remove the cursor too … kb only so would want the cursor back when real mouse is used

https://archlinux.org/packages/extra/x86_64/unclutter/

Hi, I tried this and caused me a lot of issues after installing with scroll not working on the keyboard on youtube and other sites with scrollbar.

When the mouse pointer disappeared it caused scroll functionality to go as well.

Just uninstalled it as I prefer scroll and a pointer to no scrolling! Maybe fixable but really not worth it as the pointer is not a big deal. KISS.

Offline

#8 2024-06-25 06:32:46

seth
Member
Registered: 2012-09-03
Posts: 54,484

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

Does scrolling work if you "export GDK_CORE_DEVICE_EVENTS=1" to the affected clients (or your session)?

Online

#9 2024-07-20 08:28:06

archuser38013
Member
Registered: 2024-01-27
Posts: 67

Re: Touchpad occasionally reactivates itself dispite disabling in .xinitrc

V1del wrote:

Are "rare occasions" a system update/waking up from suspend? Both conditions lead to a logical "reconnect" of the device.

Configure and disable it with a xorg configlet that will make xorg reapply the disablement each time (or flat out blacklist the responsible kernel module), e.g. a /etc/X11/xorg.conf.d/99-disableTouchpad.conf

Section "InputClass"
   MatchProduct "SIGMACHIP USB Keyboard Mouse"
   Option "Ignore" "true"
EndSection

you might want have some other conditions as detailed in: https://man.archlinux.org/man/xorg.conf … SS_SECTION

Also, your .xinitrc is incomplete and will very likely run you into problems sooner or later, fix it and make sure you include the relevant if statements and includes mentioned in the blue notes: https://wiki.archlinux.org/title/Xinit#xinitrc

I only just got around to this as I realized it is, as you said, the issue seems to arise after waking from sleep or similar cases.

You missed the line about Identifier class though, as startx would not work with your code. Added identifier class and looks to be working now. They don't even show up on 'xinput list' now rather than just showing as floating as was the case when I was using the '.xinitrc' code from OP.

Last edited by archuser38013 (2024-07-20 09:57:19)

Offline

Board footer

Powered by FluxBB