You are not logged in.

#1 2024-07-05 20:00:30

ireibot
Member
Registered: 2024-07-05
Posts: 3

Wifi not working on Asus Vivobook 14 X1404

[rei@reib ~]$ lspci -k
00:00.0 Host bridge: Intel Corporation Raptor Lake-P/U 2p+8e cores Host Bridge/DRAM Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: igen6_edac
        Kernel modules: igen6_edac
00:02.0 VGA compatible controller: Intel Corporation Raptor Lake-P [Iris Xe Graphics] (rev 04)
        DeviceName: VGA
        Subsystem: ASUSTeK Computer Inc. Device 284d
        Kernel driver in use: i915
        Kernel modules: i915, xe
00:04.0 Signal processing controller: Intel Corporation Raptor Lake Dynamic Platform and Thermal Framework Processor Participant (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: proc_thermal_pci
        Kernel modules: processor_thermal_device_pci
00:06.0 PCI bridge: Intel Corporation Raptor Lake PCIe 4.0 Graphics Port (rev 01)
        Kernel driver in use: pcieport
00:08.0 System peripheral: Intel Corporation GNA Scoring Accelerator module (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
00:0a.0 Signal processing controller: Intel Corporation Raptor Lake Crashlog and Telemetry (rev 01)
        Kernel driver in use: intel_vsec
        Kernel modules: intel_vsec
00:14.0 USB controller: Intel Corporation Alder Lake PCH USB 3.2 xHCI Host Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 201f
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci
00:14.2 RAM memory: Intel Corporation Alder Lake PCH Shared SRAM (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
00:15.0 Serial bus controller: Intel Corporation Alder Lake PCH Serial IO I2C Controller #0 (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: intel-lpss
        Kernel modules: intel_lpss_pci
00:15.1 Serial bus controller: Intel Corporation Alder Lake PCH Serial IO I2C Controller #1 (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: intel-lpss
        Kernel modules: intel_lpss_pci
00:16.0 Communication controller: Intel Corporation Alder Lake PCH HECI Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: mei_me
        Kernel modules: mei_me
00:1c.0 PCI bridge: Intel Corporation Device 51b8 (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: pcieport
00:1c.6 PCI bridge: Intel Corporation Device 51be (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Raptor Lake LPC/eSPI Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
00:1f.3 Audio device: Intel Corporation Raptor Lake-P/U/H cAVS (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel, snd_soc_avs, snd_sof_pci_intel_tgl
00:1f.4 SMBus: Intel Corporation Alder Lake PCH-P SMBus Host Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: i801_smbus
        Kernel modules: i2c_i801
00:1f.5 Serial bus controller: Intel Corporation Alder Lake-P PCH SPI Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc. Device 1623
        Kernel driver in use: intel-spi
        Kernel modules: spi_intel_pci
01:00.0 Non-Volatile memory controller: Micron Technology Inc 2400 NVMe SSD (DRAM-less) (rev 03)
        Subsystem: Micron Technology Inc Device 1100
        Kernel driver in use: nvme
        Kernel modules: nvme
03:00.0 Network controller: MEDIATEK Corp. Device 7902
        DeviceName: WLAN
        Subsystem: AzureWave Device 5520

When trying to run `$ iwctl` it just say: `Waiting for IWD to start...`

Last edited by ireibot (2024-07-05 20:01:45)

Offline

#2 2024-07-05 20:08:05

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 20,008

Re: Wifi not working on Asus Vivobook 14 X1404

Please forgive the obvious question, have you started iwd?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2024-07-05 20:10:58

ireibot
Member
Registered: 2024-07-05
Posts: 3

Re: Wifi not working on Asus Vivobook 14 X1404

opss had to reinstall linux and forgot to enable it but it doesn't show any network card

rei@reib ~]$ iwctl
NetworkConfigurationEnabled: disabled
StateDirectory: /var/lib/iwd
Version: 2.18
[iwd]# device list
                                    Devices                                   
--------------------------------------------------------------------------------
  Name                  Address               Powered     Adapter     Mode     
--------------------------------------------------------------------------------

Terminate

Offline

#4 2024-07-05 20:18:42

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 20,008

Re: Wifi not working on Asus Vivobook 14 X1404

I'm not familiar with the MediaTek 7902; my Vivobook uses the Intel AX201.

Does iw list show anything interesting?   Does the device show up in ip link  ?

Last edited by ewaller (2024-07-05 21:41:41)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#5 2024-07-05 20:22:06

ireibot
Member
Registered: 2024-07-05
Posts: 3

Re: Wifi not working on Asus Vivobook 14 X1404

ip link just show my loopback and cable Ethernet cable wdym
iw list return nothing

any other ideas? more info you need?

Last edited by ireibot (2024-07-05 20:36:55)

Offline

#6 2024-07-05 21:41:12

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 20,008

Re: Wifi not working on Asus Vivobook 14 X1404

I hate to say it, but I am not finding support for the mt7902 in the kernel.

You may want to try mt7610u_wifi_sta from the AUR.  Absolutely no guarantee.

Edit:  This thread is talking of a driver that might be a closer match:  https://bbs.archlinux.org/viewtopic.php?id=297251

Last edited by ewaller (2024-07-05 21:55:51)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB