You are not logged in.

#1 2024-01-31 21:07:39

Registered: 2016-11-09
Posts: 41

Shutdown Failure for MinisForum UM590

Greetings all,

Another shutdown issue here.  I installed Arch next to the Windows 11 that came already installed on a Minisforum UM590.  Arch fails to shutdown completely about one-third to half of the time.  I should note that this never happens either with Windows 11 or if booted from a USB flash drive.  When Arch shuts down properly shutdown takes no more than a few seconds and typically no text appears on the screen.  When Arch fails to shutdown properly relevant messages appear on the screen and progress slowly over half an hour or so to the final shutdown message.  However, the unit doesn't really ever shutdown.  I have to hold the power button for a number of seconds for complete shutdown to occur.  Similarly, when reboot fails, again around a third to half of the time, after quite a number of minutes the final text I see on the screen is "rebooting" but in fact no reboot ever happens, even if the computer is left alone for a couple of hours.  I have to again hold the power button to shutdown.

Unit specifics:

$ inxi -Fz
  Kernel: 6.7.2-zen1-1-zen arch: x86_64 bits: 64 Desktop: LXQt v: 1.4.0
    Distro: Arch Linux
  Type: Desktop System: Micro (HK) Tech product: UM590 v: N/A
    serial: <superuser required>
  Mobo: Shenzhen Meigao Equipment model: F6BFC serial: <superuser required>
    UEFI: American Megatrends LLC. v: 5.07 date: 02/01/2023
  Info: 8-core model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 636 min/max: 400/4680 cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 3183 8: 400 9: 400 10: 1396 11: 400 12: 400 13: 400 14: 400
    15: 400 16: 400
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-2: Razer USA Kiyo Pro driver: snd-usb-audio,uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4 driver: X:
    loaded: modesetting unloaded: vesa dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.4-arch1.2
    renderer: AMD Radeon Graphics (radeonsi renoir LLVM 16.0.6 DRM 3.56
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Device-4: Razer USA Kiyo Pro driver: snd-usb-audio,uvcvideo type: USB
  API: ALSA v: k6.7.2-zen1-1-zen status: kernel-api
  Server-1: PipeWire v: 1.0.1 status: active
  Device-1: Intel Ethernet I225-V driver: igc
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e
  IF: wlan0 state: up mac: <filter>
  Device-1: MediaTek Wireless_Device driver: btusb type: USB
  Report: btmgmt ID: hci0 state: up address: <filter> bt-v: 5.2
  Local Storage: total: 715.24 GiB used: 150.67 GiB (21.1%)
  ID-1: /dev/nvme0n1 vendor: LITE-ON model: ESO512GYLCT-EP3-2L
    size: 476.94 GiB
  ID-2: /dev/sdb vendor: Generic model: MassStorageClass size: 238.3 GiB
    type: USB
  ID-1: / size: 325.19 GiB used: 27.07 GiB (8.3%) fs: ext4 dev: /dev/nvme0n1p6
  ID-1: swap-1 type: partition size: 38 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p5
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: amdgpu temp: 33.0 C
  Fan Speeds (rpm): fan-1: 0 fan-2: 1834 fan-3: 0 fan-4: 0 fan-5: 0 fan-7: 0
  Processes: 325 Uptime: 54m Memory: total: 32 GiB note: est.
  available: 30.77 GiB used: 4.1 GiB (13.3%) Shell: Bash inxi: 3.3.31

Some links to a few pastebins that should be good for a week of three cases of

journalctl -r -b 1

.  I thought because of the amount of code pastebins might work better than trying to put in the message body.

Recent failed reboot attempt
Failed shutdown attempt
An example of a normal shutdown

If anyone has any clue as to what is going on I'd be most appreciative as I'd like to start using this computer without worries about whether it will shutdown or not.


#2 2024-03-09 02:11:20

Registered: 2016-11-09
Posts: 41

Re: Shutdown Failure for MinisForum UM590

No one came forth to help me on this but I did come up with a sort of fix, so thought I'd post it in case anyone else has this particular problem. 


to the line in /etc/default/grub beginning with GRUB_CMDLINE_LINUX_DEFAULT as in

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet acpi=noirq"

and then executing

grub-mkconfig -o /boot/grub/grub.cfg

in the terminal has eliminated the shutdown problem.
It's been a month and so far the shutdown problem has not repeated.  I'm not happy enough to call this a solution so I won't mark this as solved.  In fact I'm concerned there may be some adverse effects from doing it this way, but I haven't noticed anything so far.  If anyone has any insights on this I'm all ears.
A BIOS upgrade would be a happier fix for me, but on researching I'm advised not to upgrade the bios on Minisforum computers unless instructed to by Minisforum support.
So for now this is how the issue stands.


#3 2024-07-08 11:15:06

Registered: 2022-04-16
Posts: 10

Re: Shutdown Failure for MinisForum UM590

Really, really thank for for the tip.

I have a UM560 and it worked very fine all the months before, till the new lts kernel kicked in. Then I had shutdown and reboot problems. I was so desperate by thinking just to setup whole installation again. You saved my day.


Board footer

Powered by FluxBB