You are not logged in.

#1 2024-07-08 11:53:58

Registered: 2019-07-23
Posts: 1

ASUS TUF Gaming F16 (FX607JV) Laptop cannot wake up from suspend

F16 is the newest version of ASUS TUF series now, and it just cannot wake up from suspend state. When the system enters suspend-to-RAM state, the power button LED and the keyboard backlight will blink. Then the system seems don't respond to any operation. Pressing the keyboard or power button, touching the trackpad, everything just cannot make it resume from the suspend state. The only method is force poweroff by pressing the power button for several seconds.

I have searched it on Google. The problem also appears on many other distributions (so it might be a kernel problem, I think). This ArchWiki page says ASUS TUF Gaming A16 has the same problem and downgrading to BIOS 309 version can solve it, but for my device, the oldest BIOS version is 302 released on 2023/11/27, which is later than the release date of 309 version of A16. So I think downgrade my BIOS to 302 won't fix this problem. I actually tried to downgrade BIOS to the oldest version, but it didn't work.

I use the latest kernel, nvidia GPU driver (I have tried the open and the proprietary driver), hybrid graphics mode (managed by supergfxctl), KDE Plasma, and secure boot is disabled.

Here is the system log when suspend.

And here is the full system log, from booting to suspend.

I have been trying to fix it for several days but nothing works. Any useful information would be greatly appreciated.

Last edited by wait1210day (2024-07-08 11:55:59)


Board footer

Powered by FluxBB