You are not logged in.

#1 2024-07-09 11:43:17

theRedCyclops
Member
Registered: 2022-06-17
Posts: 23

Plasma crashes after every resume

Every time the computer suspends I find that plasma has crashed and the crash handler has crashed, this sometime closes apps and almost always messes up the distribution (I use Polonium). Does anyone else have this issue and has anyone managed to fix it, or is it a bug?

Offline

#2 2024-07-09 13:20:42

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,386

Re: Plasma crashes after every resume

What hardware? Generally speaking systemd recently introduced a feature to support freezing user sessions, that's apparently not quite as bug free as they thought it'd be (it's definitely broken with nvidia, but the nvidia package from the repos should include fixes) but to check whether that's the issue you can setup some override files https://bbs.archlinux.org/viewtopic.php … 7#p2181817 (note the linked post and the last post, because you'll have to create some additional files to cover everything)

Offline

#3 2024-07-09 17:48:06

theRedCyclops
Member
Registered: 2022-06-17
Posts: 23

Re: Plasma crashes after every resume

OS: Arch Linux x86_64
Kernel: Linux 6.9.7-arch1-1
Uptime: 20 hours, 44 mins
Packages: 1366 (pacman), 5 (flatpak)
Shell: bash 5.2.26
Display (L24i-30): 1920x1080 @ 60Hz [External]
Display (L24q-35): 2560x1440 @ 60Hz
DE: KDE Plasma 6.1.2
WM: KWin (Wayland)
WM Theme: Breeze
Theme: Breeze (Dark) [Qt], Breeze-Dark [GTK2/3]
Icons: breeze-dark [Qt], breeze-dark [GTK2/3/4]
Font: Noto Sans (10pt) [Qt], Noto Sans (10pt) [GTK2/3/4]
Cursor: breeze (24px)
Terminal: konsole 24.5.2
CPU: AMD Ryzen 5 7600X (12) @ 5.45 GHz
GPU 1: AMD Radeon RX 6750 XT @ 0.50 GHz [Discrete]
GPU 2: AMD Raphael @ 0.60 GHz [Integrated]
Memory: 7.81 GiB / 61.96 GiB (13%)
Swap: 30.05 GiB / 32.00 GiB (94%)
Disk (/): 70.83 GiB / 273.44 GiB (26%) - ext4
Disk (/home): 1.31 TiB / 1.52 TiB (86%) - ext4
Local IP (eno1): 192.168.100.4/24 *
Locale: en_US.UTF8

Last edited by theRedCyclops (2024-07-09 22:12:59)

Offline

#4 2024-07-09 17:56:37

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,386

Re: Plasma crashes after every resume

I could definitely see dual GPUs leading to a tripup here. Try the fix I linked, reboot after creating those files, if things still crash post a

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Offline

#5 2024-07-09 20:37:02

theRedCyclops
Member
Registered: 2022-06-17
Posts: 23

Re: Plasma crashes after every resume

The second "GPU" is just the integrated graphics

Offline

#6 2024-07-09 20:57:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,386

Re: Plasma crashes after every resume

it still might lead to weird interactions, do you have the possibility in the UEFI to limit to a single GPU?

Offline

#7 2024-07-09 21:35:48

seth
Member
Registered: 2012-09-03
Posts: 54,422

Re: Plasma crashes after every resume

Please use [code][/code] tags. Edit your post in this regard.
Also please post the journal V1del asked for - we'll need some qunatification of the "crash".

Offline

#8 2024-07-09 22:14:29

theRedCyclops
Member
Registered: 2022-06-17
Posts: 23

Re: Plasma crashes after every resume

journal: http://0x0.st/XMZe.txt
applied the fix, reloaded daemon, still broken
will attempt to disable integrated graphics (not using them)

Offline

#9 2024-07-10 12:21:27

seth
Member
Registered: 2012-09-03
Posts: 54,422

Re: Plasma crashes after every resume

jul 09 23:40:15 kheprix kded6[1915]: org.kde.pulseaudio: No object for name "alsa_output.pci-0000_03_00.1.hdmi-stereo-extra4"
jul 09 23:40:15 kheprix kdeconnectd[2238]: 2024-07-09T23:40:15 org.kde.pulseaudio: No object for name "alsa_output.pci-0000_03_00.1.hdmi-stereo-extra4"
jul 09 23:40:15 kheprix plasmashell[1995]: org.kde.pulseaudio: No object for name "alsa_output.pci-0000_03_00.1.hdmi-stereo-extra4"
jul 09 23:40:15 kheprix org_kde_powerdevil[2032]: Sleep event. connector=card1-HDMI-A-1, dref not set
jul 09 23:40:17 kheprix org_kde_powerdevil[2032]: Emitting DDCA_Display_Status_Event( 8513.086:  DDCA_EVENT_DPMS_ASLEEP, card1-DP-3, dref: Display_Ref[bus /dev/i2c-9], io_path:/dev/i2c-9]
jul 09 23:40:17 kheprix org_kde_powerdevil[2032]: Executed 1 registered callbacks.
jul 09 23:40:17 kheprix org_kde_powerdevil[2032]: Emitting DDCA_Display_Status_Event( 8513.086:  DDCA_EVENT_DPMS_ASLEEP, card1-HDMI-A-1, dref: Display_Ref[NULL], io_path:/dev/i2c-6]
jul 09 23:40:17 kheprix org_kde_powerdevil[2032]: Executed 1 registered callbacks.
jul 09 23:40:21 kheprix kwin_wayland[1770]: kwin_core: XCB error: 148 (BadCrtc), sequence: 5655, resource id: 32, major code: 140 (RANDR), minor code: 20 (GetCrtcInfo)
jul 09 23:40:21 kheprix plasmashell[1995]: kf.plasma.quick: Exposed with no visual parent. Window positioning broken.
jul 09 23:40:21 kheprix plasmashell[1995]: kf.plasma.quick: Exposed with no visual parent. Window positioning broken.
…
jul 09 23:40:29 kheprix systemd-coredump[17252]: Process 1995 (plasmashell) of user 1000 dumped core.
                                                 
                                                 Stack trace of thread 17212:
                                                 #0  0x00007df9318a8e44 n/a (libc.so.6 + 0x94e44)
                                                 #1  0x00007df931850a30 raise (libc.so.6 + 0x3ca30)
                                                 #2  0x00007df9347ec643 _ZN6KCrash19defaultCrashHandlerEi (libKF6Crash.so.6 + 0x6643)
                                                 #3  0x00007df931850ae0 n/a (libc.so.6 + 0x3cae0)
                                                 #4  0x00007df932da540b _ZNK15QtWaylandClient14QWaylandWindow16devicePixelRatioEv (libQt6WaylandClient.so.6 + 0x9140b)
                                                 #5  0x00007df92b4ccf0c _ZN15QtWaylandClient17QWaylandEglWindow13updateSurfaceEb (libQt6WaylandEglClientHwIntegration.so.6 + 0x8f0c)
                                                 #6  0x00007df92b4cd905 _ZN15QtWaylandClient17QWaylandGLContext11makeCurrentEP16QPlatformSurface (libQt6WaylandEglClientHwIntegration.so.6 + 0x9905)
                                                 #7  0x00007df9328adc28 _ZN14QOpenGLContext11makeCurrentEP8QSurface (libQt6Gui.so.6 + 0x4adc28)
                                                 #8  0x00007df932a6f112 n/a (libQt6Gui.so.6 + 0x66f112)
                                                 #9  0x00007df933818647 n/a (libQt6Quick.so.6 + 0x418647)
                                                 #10 0x00007df933819f9a n/a (libQt6Quick.so.6 + 0x419f9a)
                                                 #11 0x00007df9320c9747 n/a (libQt6Core.so.6 + 0x2c9747)
                                                 #12 0x00007df9318a6ded n/a (libc.so.6 + 0x92ded)
                                                 #13 0x00007df93192a0dc n/a (libc.so.6 + 0x1160dc)

smells like kscreen removing all outputs, resp. because the output unregisters on dpms.
=> try to disable the kscreen service in "kcmshell6 kded"

Offline

#10 2024-07-10 15:44:26

theRedCyclops
Member
Registered: 2022-06-17
Posts: 23

Re: Plasma crashes after every resume

Disabling integrated graphics didn't fix it
I submitted a bug upstream and apparently it is an issue with qt6 that is being worked on
Will try disabling kscreen

Offline

#11 2024-07-10 15:52:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,386

Re: Plasma crashes after every resume

I doubt you can trivially/safely disable kscreen on wayland. FWIW there have been some patch backports in the very latest qt6-wayland packages (i.e. 6.7.2-2) are you running that already? FWIW can you link to the bug?

Last edited by V1del (2024-07-10 15:52:36)

Offline

#12 2024-07-10 16:30:27

theRedCyclops
Member
Registered: 2022-06-17
Posts: 23

Re: Plasma crashes after every resume

Disabling kscreen did not fix the problem. I have not tried the very latest qt6-wayland packages, do I need to enable kde-testing? Sure, here is the bug I was linked to: https://bugs.kde.org/show_bug.cgi?id=489180

Last edited by theRedCyclops (2024-07-10 16:31:34)

Offline

#13 2024-07-10 17:21:59

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,386

Re: Plasma crashes after every resume

No these are in the stable repos since yesterday, a normal system update should get you these.

Offline

#14 2024-07-13 15:58:29

theRedCyclops
Member
Registered: 2022-06-17
Posts: 23

Re: Plasma crashes after every resume

It still crashes

Offline

#15 2024-07-15 23:46:32

snakes0l1d
Member
Registered: 2024-07-03
Posts: 1

Re: Plasma crashes after every resume

I had the same issue, so I rebuilt the qt6-wayland package using the patches mentioned at https://bugs.kde.org/show_bug.cgi?id=489072#c22, and the crash stopped for me.

Offline

Board footer

Powered by FluxBB