You are not logged in.

#1 2004-04-09 19:11:29

Registered: 2004-02-12
Posts: 50

Slow down

I just installed Arch on a Dual P III 800s, 128 mb RAM.  I had Fedora on it, but it's to fat for me.  The problem I have is that it seems as if it has slowed down switching over to Arch.  When I first started Arch it was smoking after I ran pacman -Syu and it just seems like it is getting slower.  Any reason why?


#2 2004-04-09 19:56:45

Registered: 2004-03-04
Posts: 155

Re: Slow down

Hi usedtire.

Something has probably changed, but you shouldn't restrict your investigation to just the updates from pacman -Syu.

You might want to look at what applications and processes you're starting at boot time ... and are taking valuable resources are run time.

Check which modules you've installed; some may not be necessary:


Check what processes you're running in the default environment; some of these may not be necessary:

ps -aux

Given that you don't have a really large amount of RAM, you might want to see if you shouldn't switch to a window manager with lower memory and processing requirements. That tends to make even the memory/processing hogs such as Mozilla run better.

Also, if you're using some applications that require a lot of memory, you might be able to configure them to run with less (e.g., has a memory control option: Tools->Options->Memory).

There are a number of other very useful optimizations you can look to do.  Check out the Arch Linux Wiki for more details.




Board footer

Powered by FluxBB