You are not logged in.

#1 2006-05-28 14:56:30

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

foobillard: ft_load_glyph:error#6

hello!

i never had problems with foobillard. but suddenly it will not start. i start it and it crashes with the following message:

FT_Load_Glyph:error#6

i dont know why i had this problem. plz help. thanks.
mfg iggy


sorry for my bad english smile

Offline

#2 2006-05-29 15:18:04

djscholl
Member
From: Michigan, USA
Registered: 2006-05-24
Posts: 56

Re: foobillard: ft_load_glyph:error#6

I observed this symptom as well. I posted a bug report, 4711, I regret to say on the AUR project, when I should have selected the Arch Linux project. Did you also recently upgrade your freetype2? If your root cause is the same as mine, you might be able to use the workaround of reverting to the earlier version of freetype2. I'm new to Arch but I think the quoted pacman -U command should work for most people; if you're not sure, don't run it without asking a knowledgeable person. Maybe someone who knows will reply to this post.

Edited bug report 4711 content:

After pacman -Syu, which included upgrade to freetype2-2.2.1-2.pkg.tar.gz

foobillard 3.0a-1 started from an xterm crashes immediately at starting, the foobillard window vanishes, and control returns to the xterm, leaving the font-related error message:
"FT_Load_Glyph:error#6"
The crash always happens, in the same way, with the same message.

After "pacman -U /var/cache/pacman/pkg/freetype2-2.1.10-3.pkg.tar.gz", foobillard runs normally again.

I can make the problem appear and disappear by switching between the two versions of freetype2.

I read on
http://freetype.sourceforge.net/freetyp … 2.2.0.html
that some X apps might have problems with this new version of freetype.

The freetype site lists FontConfig 2.3.2 as requiring a patch to work with the new freetype2, and 2.3.2-6 is the latest version of FontConfig for Arch. However, the cvs indicates that the relevant freetype2 patch is applied to the Arch build. The sdl_ttf library is also listed, but sdl_ttf is not required for foobillard. However, libSDL-1.2 is used by foobillard. I'm not an X developer, so it's just speculation on my part that this might be related to the foobillard crashes. The freetype site has instructions for grepping the source code to look for potential problems, but I'm in over my head already.

Offline

#3 2006-05-29 19:28:01

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: foobillard: ft_load_glyph:error#6

hey!

thanks for your reply! i will downgrade to the older freetype2 package and wait for an update.

mfg iggy


sorry for my bad english smile

Offline

#4 2006-06-12 05:54:43

Bysshe
Member
Registered: 2004-12-10
Posts: 268

Re: foobillard: ft_load_glyph:error#6

I had the same problem, and realized the same workaround for installing the old freetype and setting pacman.conf to ignore the package for upgrading.  Definately not alone in the foobillard hall.  big_smile

Offline

#5 2006-06-15 06:42:54

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: foobillard: ft_load_glyph:error#6

I also had the same problem. Now it is solved but I get

Video mode set failed: OpenGL not available

I'm using Nvidia. xorg.conf seems to be fine, other OpenGL games like Cube, Enemy Territory work.
When recompiling foobillard with --enable-glut I get

Cannot open display ''

I'm using [testing].
Any ideas?


to live is to die

Offline

#6 2006-06-24 20:35:16

petebull
Member
Registered: 2006-06-19
Posts: 4

Re: foobillard: ft_load_glyph:error#6

Romashka wrote:

Any ideas?

I installed the new freetype package and foobillard works again.

Offline

#7 2006-10-12 15:23:49

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: foobillard: ft_load_glyph:error#6

The problem with

FT_Load_Glyph:error#6

is here again on Arch Current (12/10/2006).  Freetype2-2.2.1-3. Are there any news about solving the problem?

Offline

#8 2006-10-13 06:51:14

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: foobillard: ft_load_glyph:error#6

Hmm, this is a bug in freetype 2.2.1 which has been fixed in Freetype CVS. The problem is that the only thing I can find about it in their changelogs is a fix for something similiar that fixes Error #10 on bad font files. The issue you're having occurs when you're rendering a space character without anti-aliasing.

Offline

#9 2006-10-13 10:12:49

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: foobillard: ft_load_glyph:error#6

JGC wrote:

Hmm, this is a bug in freetype 2.2.1 which has been fixed in Freetype CVS. The problem is that the only thing I can find about it in their changelogs is a fix for something similiar that fixes Error #10 on bad font files. The issue you're having occurs when you're rendering a space character without anti-aliasing.

Thanks JGC for the answer and clarification, temporarly I downgraded to 2.1.10 version of the freetype2 and put "IgnorePkg freetype2" in pacman.conf. It helped. I'll observe the situation with freetype2.

Best regards smile

Offline

#10 2006-10-28 02:53:36

djscholl
Member
From: Michigan, USA
Registered: 2006-05-24
Posts: 56

Re: foobillard: ft_load_glyph:error#6

The workaround we have been using doesn't workaround for me any more. No more hangin' around the foobillard hall, and I wasn't even smokin' cigarettes or talkin' dirty. I tried to downgrade to freetype2-2.1.10-4, but pacman won't do it any longer. fontconfig now requires freetype2>=2.2.1 since it was upgraded from 2.3.2 to 2.4.1. I tried downgrading both fontconfig and freetype2, but I got this error:

[root@hostname ~]# pacman -U /var/cache/pacman/pkg/freetype2-2.1.10-4.pkg.tar.gz /var/cache/pacman/pkg/fontconfig-2.3.2-6.pkg.tar.gz 
loading package data... done.
checking for file conflicts... 
error: the following file conflicts were found:
  fontconfig: /etc/fonts/local.conf: exists in filesystem

Does anyone know how to workaround this safely? JGC posted that the bug has been fixed in Freetype CVS, so I assume that if I knew what I was doing I could convert the freetype2 PKGBUILD to download from CVS. There is a wiki page covering CVS PKGBUILD's, but it looks non-trivial to me. Would some, or all, of those five patches still be required? If so, would they still apply cleanly to the CVS version?

Offline

#11 2006-10-28 09:49:29

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: foobillard: ft_load_glyph:error#6

You don't want freetype2 CVS at this moment, trust me... fonts look horrible with that, they're experimenting with bytecode hinting all over the place at this moment.

Offline

#12 2006-12-11 21:21:20

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: foobillard: ft_load_glyph:error#6

I'm still waiting for new stable freetype... sad
BTW, foobillard depends on xfree86, should I file Yet Another Bug Report (tm) for this?


to live is to die

Offline

#13 2007-01-21 11:05:38

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: foobillard: ft_load_glyph:error#6

thanks for the fix foobillard works now again smile

Offline

Board footer

Powered by FluxBB