You are not logged in.

#1 2007-01-29 09:54:05

Zmyrgel
Member
From: Finland
Registered: 2006-09-30
Posts: 28

LVM2 won't start at boot [solved]

I just installed Aarch from 0.7.2 CD I had. I used LVM2 partitions as every other partitition except boot,swap and root.
Problem is that the system boots with the 'full' initramfs but it won't start up the lvm partitions at all for some reason.
I enabled the LVM during the installation but what else to do to get it to work?

Last edited by Zmyrgel (2007-01-31 13:42:33)

Offline

#2 2007-01-29 11:09:58

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: LVM2 won't start at boot [solved]

If you don't have root on LVM, you don't need to enable it in initramfs. Just enable USELVM="yes" in /etc/rc.conf. Maybe the cause is the device mapper not being loaded (I think I have to fix this in initscripts), so just add dm_mod to the MODULES=(...) array in /etc/rc.conf.

Offline

#3 2007-01-29 11:18:52

Zmyrgel
Member
From: Finland
Registered: 2006-09-30
Posts: 28

Re: LVM2 won't start at boot [solved]

I did had the USELVM="yes" in rc.conf but I will try to add the dm_mod to MODULES as you said to see if that helps.

Offline

#4 2007-01-29 20:47:57

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: LVM2 won't start at boot [solved]

Next initscripts release fixes this bug, this means that adding dm-mod to MODULES should no longer be necessary.

Offline

#5 2007-01-31 07:23:38

Zmyrgel
Member
From: Finland
Registered: 2006-09-30
Posts: 28

Re: LVM2 won't start at boot [solved]

Ok, I did reinstall from ftp now that my broadband works again and it did work just fine big_smile

Now to re-familirize myself with Arch smile

Offline

Board footer

Powered by FluxBB