You are not logged in.

#1 2007-01-20 11:14:40

nGerrit
Member
From: Aachen [GER]
Registered: 2006-09-27
Posts: 36

vlc 0.8.6a - no video output

Hi,
i've updated to the new vlc version today, but i can't get any video to play. The sound is always playing but there is no video output.
i've tried with old files that the old version had no problem playing.
Here is the console-output.

[mov]

VLC media player 0.8.6a Janus

main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): found Box: 
main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): read box: "
main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): found Box: 
main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): read box: "
main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): found Box: 
main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): read box: "
main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): found Box: 
main warning: can't store message (Ungültiges oder unvollständiges Multi-Byte- oder Wide-Zeichen): read box: "
[00000288] main decoder error: no suitable decoder module for fourcc `avc1'.
VLC probably does not support this sound or video format.


[xvid]
VLC media player 0.8.6a Janus

[00000288] main decoder error: no suitable decoder module for fourcc `XVID'.
VLC probably does not support this sound or video format.

the first one is a quicktime trailer and the second one an xvid file.

did i do somthing wrong or is this a bug?

thx
nGerrit

Offline

#2 2007-01-20 11:34:14

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

Re: vlc 0.8.6a - no video output

same problem here...

streaming is OK however... compiling from source gave the same result...

cheers


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#3 2007-01-20 12:34:22

mwc
Member
From: London, Canada
Registered: 2006-03-17
Posts: 17

Re: vlc 0.8.6a - no video output

I had the same problem. I fixed it by rebuilding the packages for ffmpeg then vlc. I didn't bump the pkgnumbers because I wanted the fixed ones from the arch team to replace my temporary when they're upgraded.

$ cd /var/abs/local
# mkdir ffmpeg;
# chown $YOU:$YOURGROUP ffmpeg
$ cd ffmpeg; cp /var/abs/multimedia/ffmpeg/* .
$ makepkg
# pacman -Rd ffmpeg # remove their package, d causes pacman to ignore dependencies
# pacman -A ffmpeg-20060920-1.pkg.tar.gz

Repeat for vlc. For some reason the package I got from extra didn't have ffmpeg enabled. Do vlc --list | grep ffmpeg. You should get a fair amount of stuff if and only if your VLC is set up correctly:

$ vlc --list | grep ffmpeg
VLC media player 0.8.6a Janus
  ffmpeg                FFmpeg audio/video decoder/encoder ((MS)MPEG4,SVQ1,H263,WMV,WMA)
  ffmpeg                FFmpeg chroma conversion
  ffmpeg                FFmpeg audio/video encoder
  ffmpeg                FFmpeg demuxer
  ffmpeg                FFmpeg muxer
  ffmpeg                FFmpeg video filter
  ffmpeg                FFmpeg crop padd filter
  ffmpeg                FFmpeg deinterlace video filter

With the broken package from extra, grep finds no matching lines.

Offline

#4 2007-01-20 13:13:37

nGerrit
Member
From: Aachen [GER]
Registered: 2006-09-27
Posts: 36

Re: vlc 0.8.6a - no video output

yes that worked for me too.
thanks..

nGerrit

Offline

#5 2007-01-21 18:02:46

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: vlc 0.8.6a - no video output

Have VLC problem here as well....no video, audio OK...works well in Larch liveCD.

No video in noatun, kaboodle or codeine.

Result of query below:

     [root@n6re ~]# vlc --list| grep ffmpeg
VLC media player 0.8.6a Janus
starting VLC root wrapper... using UID 0 (root)
***************************************
* Running VLC as root is discouraged. *
***************************************

It is potentially dangerous, and might not even work properly.
[root@n6re ~]#


What is dangerous about running VLC as root?  VLC runs in windows as the equivalent (administrator)....

Only after recent upgrade did VLC fail in root.  It plays well as root in LiveCD right now.

Video is OK in mplayer!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#6 2007-01-21 18:23:01

Insomnolent
Member
From: Manassas, VA
Registered: 2005-07-12
Posts: 9

Re: vlc 0.8.6a - no video output

This worked for me as well, thanks for the solution.

Offline

#7 2007-01-21 18:25:41

mwc
Member
From: London, Canada
Registered: 2006-03-17
Posts: 17

Re: vlc 0.8.6a - no video output

lilsirecho wrote:

Have VLC problem here as well....no video, audio OK...works well in Larch liveCD.

No video in noatun, kaboodle or codeine.

Not sure why those would be broken, but give my above method a try. It fixed it for me.

lilsirecho wrote:

Result of query below:

[root@n6re ~]# vlc --list| grep ffmpeg
VLC media player 0.8.6a Janus
starting VLC root wrapper... using UID 0 (root)
***************************************
* Running VLC as root is discouraged. *
***************************************

 It is potentially dangerous, and might not even work properly.
[root@n6re ~]#

You don't need to run it as root to get the correct information. For some reason the packages that got into extra didn't use ffmpeg correctly. Yours doesn't either.

lilsirecho wrote:

What is dangerous about running VLC as root?  VLC runs in windows as the equivalent (administrator)....

Windows has a terribly broken privilege separation model. Well, the one they have now in 2000/XP/Vista is actually ok, but their legacy support makes it all but useless. Don't run ANYTHING as root unless it's absolutely required. It's not required to run VLC as root. Run it as a user.

lilsirecho wrote:

Only after recent upgrade did VLC fail in root.  It plays well as root in LiveCD right now.

Video is OK in mplayer!

Rebuild ffmpeg and vlc and you'll be fine. I left the PKGREL id the same, that way the arch team's next ffmpeg and vlc packages will replace mine.

Offline

#8 2007-01-21 18:49:18

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: vlc 0.8.6a - no video output

I have never run anything as user in all my arch experience.....


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#9 2007-01-22 13:23:39

Zanton
Member
Registered: 2005-12-06
Posts: 80

Re: vlc 0.8.6a - no video output

mwc wrote:
$ cd ffmpeg; cp /var/abs/multimedia/ffmpeg/* .

I have the same issue but I don't have this folder /var/abs/multimedia (ffmpeg is installed).

Offline

#10 2007-01-22 13:30:07

noriko
Member
From: In My Mind
Registered: 2006-06-09
Posts: 535
Website

Re: vlc 0.8.6a - no video output

u need to run

abs

first


The.Revolution.Is.Coming - - To fight, To hunger, To Resist!

Offline

#11 2007-01-22 15:06:34

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: vlc 0.8.6a - no video output

zanton:noriko

I have run  abs  .  I examined the /var/abs/multimedia file and find no ffmpeg.

I am not certain if your suggestion is a fix for the problem or just a comment. 

I see in the repository that vlc has many dependencies.

Recovering slowly from carotid surgery here and got hit with no vid on top of it.

Perhaps if I just wait it will be fixed in a week or so.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#12 2007-01-22 16:30:56

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: vlc 0.8.6a - no video output

Note:

[root@n6re ~]# cd ffmpeg
bash: cd: ffmpeg: No such file or directory
[root@n6re ~]#


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#13 2007-01-22 17:42:34

BeardedYeti
Member
Registered: 2006-03-26
Posts: 11

Re: vlc 0.8.6a - no video output

Zanton wrote:
mwc wrote:
$ cd ffmpeg; cp /var/abs/multimedia/ffmpeg/* .

I have the same issue but I don't have this folder /var/abs/multimedia (ffmpeg is installed).

On my system I have it in /var/abs/extra/multimedia/ffmpeg.
It don't see why it would be different for the OP. Maybe it's just a typo...

Offline

#14 2007-01-22 20:37:25

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: vlc 0.8.6a - no video output

Confirm that /var/abs/extra/multimedia/ffmpeg exists with a PKGBUILD.

Previous post shows no recognition for .....cd ffmpeg.....


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#15 2007-01-22 20:56:26

mwc
Member
From: London, Canada
Registered: 2006-03-17
Posts: 17

Re: vlc 0.8.6a - no video output

BeardedYeti wrote:

On my system I have it in /var/abs/extra/multimedia/ffmpeg.
It don't see why it would be different for the OP. Maybe it's just a typo...

Yep, it was a typo.

Offline

#16 2007-01-22 22:25:51

Zanton
Member
Registered: 2005-12-06
Posts: 80

Re: vlc 0.8.6a - no video output

BeardedYeti wrote:
Zanton wrote:
mwc wrote:
$ cd ffmpeg; cp /var/abs/multimedia/ffmpeg/* .

I have the same issue but I don't have this folder /var/abs/multimedia (ffmpeg is installed).

On my system I have it in /var/abs/extra/multimedia/ffmpeg.
It don't see why it would be different for the OP. Maybe it's just a typo...

thanks, it worked fine

Offline

#17 2007-02-02 19:42:33

Spider.007
Member
Registered: 2004-06-20
Posts: 1,143
Website

Re: vlc 0.8.6a - no video output

Are developers missing this thread or is something else the reason ffmpeg is not fixed and released? Should this have been posted in the bugtracker instead?

Offline

#18 2007-02-02 20:23:39

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: vlc 0.8.6a - no video output

If the problem is still there, submit a bug report. Some devs don't even come to the forum.

Offline

#19 2007-02-03 06:12:29

gradgrind
Member
From: Germany
Registered: 2005-10-06
Posts: 921

Re: vlc 0.8.6a - no video output

I have just posted a bug report.

Offline

Board footer

Powered by FluxBB