You are not logged in.

#1 2007-02-03 11:43:01

cubo
Member
From: Slovakia
Registered: 2007-02-03
Posts: 25

asus F2Hf

hello,
i have bought new laptop, asus f2hf (http://www.asus.com/products.aspx?l1=5& … odelmenu=2), but i couldn't get sound working.

->hwd:
Audio device
  snd-hda-intel   : Intel Corp.|I/O Controller Hub High Definition Audio

Anybody can help me?

Offline

#2 2007-02-03 13:26:02

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: asus F2Hf

have you tried running
alsaconf
are you in audio group?
is card muted?

Offline

#3 2007-02-03 13:56:36

cubo
Member
From: Slovakia
Registered: 2007-02-03
Posts: 25

Re: asus F2Hf

Alsaconf identified snd-hda-intal correctly /i mean its correct/, and store it in modprobe.conf with no errors. User is in group audio and alsamixer + alsactl store = 100% /unmuted/.
maybe can help:

-> lsmod:
Module                  Size  Used by
isofs                  31168  0
zlib_inflate           14848  1 isofs
usb_storage            77632  0
ipv6                  245824  10
nls_cp437               5888  2
vfat                   10624  2
fat                    46108  1 vfat
snd_seq_oss            29440  0
snd_seq_midi_event      6528  1 snd_seq_oss
snd_seq                47056  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          6796  2 snd_seq_oss,snd_seq
usbhid                 50080  0
ff_memless              5256  1 usbhid
snd_pcm_oss            38944  0
snd_mixer_oss          14464  1 snd_pcm_oss
joydev                  8384  0
tsdev                   6336  0
sg                     26524  0
rtc                    10292  0
snd_hda_intel          15768  1
snd_hda_codec         156800  1 snd_hda_intel
snd_pcm                68612  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              18948  2 snd_seq,snd_pcm
snd                    44004  11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore               6624  1 snd
snd_page_alloc          7816  2 snd_hda_intel,snd_pcm
8139cp                 19712  0
8139too                22912  0
mii                     4992  2 8139cp,8139too
intel_agp              20764  1
i2c_i801                7308  0
evdev                   8192  1
ehci_hcd               29448  0
i2c_core               17920  1 i2c_i801
agpgart                26072  1 intel_agp
psmouse                35336  0
serio_raw               5636  0
pcspkr                  2816  0
uhci_hcd               21260  0
usbcore               116100  5 usb_storage,usbhid,ehci_hcd,uhci_hcd
jfs                   173180  1
sr_mod                 14372  0
cdrom                  34464  1 sr_mod
sd_mod                 16640  5
ata_piix               12296  4
libata                 90772  1 ata_piix
generic                 5380  0 [permanent]
ide_core              108744  2 usb_storage,generic

I mean it could be conflict with another device /or module/ like modem /IRQ channels/

thank you for help me

Offline

#4 2007-02-03 15:22:10

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,546
Website

Re: asus F2Hf

Make sure PCM is also 100%
I had a system once that would play audio through PCM and even with the master at 100% there was no sound until I enabled PCM.

Hope this helps.

R

Offline

#5 2007-02-03 18:01:08

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: asus F2Hf

check the "line jack sense" i had an issue with my sound once that turned out to be the fix
i forget if it needed to be on or off in a terminal run  "alsamixer"  fiddle round in there

Offline

#6 2007-02-06 10:24:16

cubo
Member
From: Slovakia
Registered: 2007-02-03
Posts: 25

Re: asus F2Hf

hello,
still i have no sound,
in alsamixer i have 8 bars: headphon - i can't change /MM/
                                           pcm - 100
                                           front - i can't change /MM/
                                           front Mi - 100 /MM/
                                           cd - 100
                                           mic - 100 /MM/
                                           IEC958 - i can't change
                                           input source - CD /i can choose between mic, front mic and cd/
->maybe can help: hwd -ec
[stody@studo ~]$ sudo hwd -ec
IDE interface
  ata_piix        : Intel Corp.|Mobile I/O Controller Hub SATA cc=IDE
Ethernet controller
  8139too         : Realtek Semiconductor|TTP-Monitoring Card V2.0
Network controller
  ipw3945         : Intel Corporation|PRO/Wireless 3945ABG
VGA compatible controller
  vesa            : Intel Corp.|Mobile Integrated Graphics Controller
Display controller
  vesa            : Intel Corp.|Mobile Integrated Graphics Controller
Audio device
  snd-hda-intel   : Intel Corp.|I/O Controller Hub High Definition Audio
Host bridge
  intel-agp       : Intel Corp.|Mobile Memory Controller Hub
ISA bridge
  i8xx_tco        : Intel Corp.|Mobile I/O Controller Hub LPC
PCI bridge
  unknown         : Intel Corp.|I/O Controller Hub PCI Express Port 1
  unknown         : Intel Corp.|I/O Controller Hub PCI Express Port 2
  hw_random       : Intel Corp.|82801 Hub Interface to PCI Bridge
USB Controller
  unknown         : Intel Corp.|I/O Controller Hub UHCI USB #1
  unknown         : Intel Corp.|I/O Controller Hub UHCI USB #2
  unknown         : Intel Corp.|I/O Controller Hub UHCI USB #3
  unknown         : Intel Corp.|I/O Controller Hub UHCI USB #4
  unknown         : Intel Corp.|I/O Controller Hub EHCI USB
SMBus
  i2c-i801        : Intel Corp.|I/O Controller Hub SMBus
USB Human Interface Devices
  usbhid          : Darfon Electronics Corp.|Benq Mouse [/dev/input/mice]
USB Hub
  hub             : Virtual|Hub
  hub             : Virtual|Hub
  hub             : Virtual|Hub
  hub             : Virtual|Hub
  hub             : Virtual|Hub
USB Vendor Specific Class
  unknown         : Fingerprint Sensor
Mouse
  msintellips/2   : PS/2 Mouse port [/dev/psaux]

Some ideas?

thanks for help

Offline

Board footer

Powered by FluxBB