You are not logged in.

#1 2007-02-21 08:19:18

forestranger
Member
Registered: 2007-02-21
Posts: 8

[SOLVED] makepkg fails because of libqt-mt.so.3

When I attempt to makepkg a pkgbuild or compile (make) from source, it fails.  This is the final error message from my last attempt at a AUR pkgbuild:

...
/opt/qt/bin/uic: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory
make[3]: *** [Alphacubeconfig.h] Error 127
make[3]: Leaving directory `/home/pek/builds/kdedecor-alphacube/src/Alphacube-0.3/kwin/config'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/pek/builds/kdedecor-alphacube/src/Alphacube-0.3/kwin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/pek/builds/kdedecor-alphacube/src/Alphacube-0.3'
make: *** [all] Error 2
==> ERROR: Build Failed.  Aborting...

This seems to happen when I try to install older pkgbuilds or source packages.  I have successfully installed google-earth and some other pkgbuild so I know it can work.  I only learned how to use ABS a few days ago so maybe I'm doing something wrong?  I followed the guide and am using fakeroot.  If it matters, I installed Arch from the Arch-Office cd; it is completely updated except I am using the 2.6.19Beyond kernel. 

Any ideas?  I noticed that in all the failed builds, the following line is always present... *dramatic dunh dunh DUNH sound*

/opt/qt/bin/uic: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

P.S.  I checked and /opt/qt/bin/uic IS indeed there and libqt-mt.so.3 is in /opt/qt/lib   hmm

Last edited by forestranger (2007-02-22 05:17:59)

Offline

#2 2007-02-22 01:58:14

forestranger
Member
Registered: 2007-02-21
Posts: 8

Re: [SOLVED] makepkg fails because of libqt-mt.so.3

I noticed I can't run QT programs.  Starting QCad gives me:

$ qcad
qcad: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

another clue?

Offline

#3 2007-02-22 02:29:04

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [SOLVED] makepkg fails because of libqt-mt.so.3

After installing qt, di you updated your profiles? You can do that for the current terminal by running:
bash /etc/profile
or logout/relogin.

Also, do you have a:
/opt/qt/lib
line in /etc/ld.so.conf ? It should have been done when you installed qt but maybe it didn't installed properly.

Offline

#4 2007-02-22 04:19:24

forestranger
Member
Registered: 2007-02-21
Posts: 8

Re: [SOLVED] makepkg fails because of libqt-mt.so.3

Snowman wrote:

After installing qt, di you updated your profiles? You can do that for the current terminal by running:
bash /etc/profile
or logout/relogin.

Also, do you have a:
/opt/qt/lib
line in /etc/ld.so.conf ? It should have been done when you installed qt but maybe it didn't installed properly.

Yes, I did update my profile.  I've logged out and even ran bash /etc/profile for good measure.

Strangely enough, I did not have "/opt/qt/lib" in my /etc/ld.so.conf.  I added it in manually and rebooted.  It didn't help though.  I get the same errors.  I checked all everything in /var/log and couldn't find any clues there.

Is there some other config file that defines the path for the qt lib's?

Offline

#5 2007-02-22 05:09:50

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [SOLVED] makepkg fails because of libqt-mt.so.3

If you added /opt/qt/lib to your /etc/ld.so.conf, you need to run  'ldconfig' as root to update the cache. 

Alternatively, you can just reinstall qt. The qt post-install script is supposed to do this stuff. That will fix your problem.

Offline

#6 2007-02-22 05:17:33

forestranger
Member
Registered: 2007-02-21
Posts: 8

Re: [SOLVED] makepkg fails because of libqt-mt.so.3

Snowman wrote:

If you added /opt/qt/lib to your /etc/ld.so.conf, you need to run  'ldconfig' as root to update the cache. 

Alternatively, you can just reinstall qt. The qt post-install script is supposed to do this stuff. That will fix your problem.

THANKS SNOWMAN!! You are a genius!

I ran ldconfig and that did the trick.  High five.

Offline

#7 2007-02-22 15:12:15

Phrodo_00
Member
From: Santiago de Chile
Registered: 2006-04-09
Posts: 340
Website

Re: [SOLVED] makepkg fails because of libqt-mt.so.3

Actually... I have kind of a related problem (now that I remember I'll fill it as a bug... although I don't know how it could be solved, a package just for it??). Avahi installs avahi-qt.pc that depends on qt-mt.pc so when using pkg-config --list-all (which does, for example, anjuta) it lists a few packages until it finds that dependence problem.

Offline

Board footer

Powered by FluxBB