You are not logged in.

#1 2007-02-21 11:47:37

otake-tux
Member
Registered: 2006-04-29
Posts: 20

another wireless problems thread-SOLVED

I own an ACER Aspire 5004wlmi.  It uses the broacom wireless card which I have had working under other linux distributions.  I just installed arch and I cannot get my wireless to work.

iwconfig:

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:off/any  Nickname:"Broadcom 4318"
          Mode:Managed  Access Point: Invalid   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=0/100  Signal level=-256 dBm  Noise level=-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

so I do iwlist eth1 scan and I get :

eth1      Interface doesn't support scanning : No such device

I obtained the driver from the acer website and used ndiswrapper.  However, I get the following output:

[root@terra amilcar]# ndiswrapper -l
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_COLLATE = "C",
        LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
bcmwl5 : driver installed
        device (14E4:4318) present (alternate driver: bcm43xx)

so it seems I have the bcm43xx installed but I have added it to blacklist in rc.conf and rebooted yet it still shows up.

I tried following this guide : http://wiki.archlinux.org/index.php/Wireless

used the bcm43xx-fwcutter but in the zip file available for download from acer there is no .0 file.

please help.  I really can't figure this out.  any help would be greatly appreciated.


I'm running voodoo by the way.

Last edited by otake-tux (2007-02-23 00:29:05)

Offline

#2 2007-02-21 11:54:34

cougar
Member
From: France
Registered: 2006-06-24
Posts: 93

Re: another wireless problems thread-SOLVED

Offline

#3 2007-02-21 12:12:39

otake-tux
Member
Registered: 2006-04-29
Posts: 20

Re: another wireless problems thread-SOLVED

cougar wrote:

that got rid of the locale messages but I still can't scan.

Offline

#4 2007-02-22 11:02:16

otake-tux
Member
Registered: 2006-04-29
Posts: 20

Re: another wireless problems thread-SOLVED

I  have thought about it and I think if I get rid of the bcm driver it might work.  but I don't know how to disable it.  can someone tell me?

Offline

#5 2007-02-22 12:27:11

byte
Member
From: Düsseldorf (DE)
Registered: 2006-05-01
Posts: 2,045

Re: another wireless problems thread-SOLVED

You can disable autoloading by putting the module name into MODULES array and prefixing it with ! ... or use MOD_BLACKLIST, it's in /etc/rc.conf.


1000

Offline

#6 2007-02-22 23:41:29

skale
Member
From: Atlanta, GA
Registered: 2006-08-04
Posts: 146

Re: another wireless problems thread-SOLVED

I had a similar problem. 

Blacklist / uninstall the bcm43xx stuff, and use ndiswrapper instead.  I followed the ndiswrapper wiki instead and it worked without a hitch.  I didn't see the Arch one but it looks similar. 

It can work, remember that.

Offline

#7 2007-02-23 00:28:40

otake-tux
Member
Registered: 2006-04-29
Posts: 20

Re: another wireless problems thread-SOLVED

byte wrote:

You can disable autoloading by putting the module name into MODULES array and prefixing it with ! ... or use MOD_BLACKLIST, it's in /etc/rc.conf.

the solution was to do both.  I added the bcmxx driver MOD_BLACKLIST and into modules with ! prefixing it.  set up ndiswrapper and rebooted.  problem solved. 

should I write a detailed how to?

Offline

#8 2007-02-23 07:02:28

zeus
Member
From: Korolev / Russia
Registered: 2006-09-19
Posts: 117
Website

Re: another wireless problems thread-SOLVED

Offline

#9 2007-02-23 18:54:03

Acid7711
Member
From: Chicago, IL
Registered: 2006-08-18
Posts: 300
Website

Re: another wireless problems thread-SOLVED

otake-tux wrote:
byte wrote:

You can disable autoloading by putting the module name into MODULES array and prefixing it with ! ... or use MOD_BLACKLIST, it's in /etc/rc.conf.

the solution was to do both.  I added the bcmxx driver MOD_BLACKLIST and into modules with ! prefixing it.  set up ndiswrapper and rebooted.  problem solved. 

should I write a detailed how to?

I was just going to say that this is how I got mine to work.  I kinda got to the thread a little late to offer much help though.

Offline

Board footer

Powered by FluxBB