You are not logged in.

#1 2007-03-15 04:25:06

Registered: 2006-12-20
Posts: 10


ok so i used to use this zd1211b usb wifi gadget in 2.6.18 without a hitch. then for a while i went hardwired, so no need for the wifi. last week i'm forced to go wifi again, and i've got a fresh install with both kernel26 (20) and kernel26beyond (19) installed, so i pacman'd zd1211-beyond... tried to modprobe zd1211b, and it didnt seem to do anything. nothing showed up in iwconfig. tried the same thing in kernel26 with zd1211(regular)... tried to modprobe zd1211rw, still nothing happens. as a desperate extra attempt i tried ndiswrapper with the XP drivers, and that gave me a scrolling screen of error messages which i dont have on me right now, but i figure at this point that i'm a n00b and i'm totally missing a step. i read somewhere about a zd1211 firmware package, but nothing like that on these forums, so thought i'd ask before i meddle further. any idea(s)?


#2 2007-03-15 06:20:26

From: Germany
Registered: 2005-10-06
Posts: 921

Re: zd1211b

It is a bit confusing, isn't it. I have a zd1211 (not b, though), which does work in Arch. There are two drivers available, the old ones in the zd1211 packages and the new one which comes with the kernel package. I believe the old one doesn't need the firmware, but the new one does. I think you will need to get the firmware yourself from sourceforge (maybe it's a licensing issue?). I removed the zd1211 packages, in case the modules interfere with each other, and settled for zd1211rw, which is recommended, and it worked for me. It doesn't (yet) support many iwconfig commands, but it does allow basic use. I haven't tried WPA, but it does work with WEP.


#3 2007-05-02 03:44:49

Forum Fellow
From: Boston, MA
Registered: 2003-12-24
Posts: 40

Re: zd1211b

I have zd1211rw with the firmware working with WPA. As a data point for you. So far so good!


Board footer

Powered by FluxBB