You are not logged in.

#1 2004-04-16 21:44:22

maor
Member
Registered: 2004-04-12
Posts: 29

kdevelop + codecompeltion

i have a problem with the kdevelop package whenever the code
compeltion is working cause the program to crash.
this an arch specific working well on other computer.

Offline

#2 2004-04-18 01:37:41

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: kdevelop + codecompeltion

do you use the kdevelop or kdevelop-devel?

did you searched for a bug in bugs.kde?

any more info when crashing?


The impossible missions are the only ones which succeed.

Offline

#3 2004-04-22 11:16:18

maor
Member
Registered: 2004-04-12
Posts: 29

Re: kdevelop + codecompeltion

after some investigation i think the problem probably come down to Berkley DB.
here u can see the requirements for kdevelop 3.
http://www.kdevelop.org/index.html?file … ments.html
as u can see the requirement suggest that berkley db version <=3.0 & <=4.1 , while arch have version 4.2.52

Offline

#4 2004-04-22 11:31:25

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: kdevelop + codecompeltion

maor wrote:

after some investigation i think the problem probably come down to Berkley DB.
here u can see the requirements for kdevelop 3.
http://www.kdevelop.org/index.html?file … ments.html
as u can see the requirement suggest that berkley db version <=3.0 & <=4.1 , while arch have version 4.2.52

thanx for the find out of info ... any suggestion how to solve this? i suggest waiting for kdevelop to support db we have


The impossible missions are the only ones which succeed.

Offline

#5 2004-04-22 18:10:33

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: kdevelop + codecompeltion

There might be a way to statically link a specific version of db into the app.  Evolution does the same thing.

Stupid db.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#6 2004-04-22 18:27:44

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: kdevelop + codecompeltion

Xentac wrote:

There might be a way to statically link a specific version of db into the app.

want to try it? feel free - for me it's a little bit to high --- never played around with building statically things into pkgs


The impossible missions are the only ones which succeed.

Offline

#7 2004-04-22 18:31:12

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: kdevelop + codecompeltion

Post a bug to remind me.. I'll see if I can get to it sometime in the next week.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#8 2004-04-23 01:32:48

shen
Member
Registered: 2003-09-05
Posts: 272
Website

Re: kdevelop + codecompeltion

For the db 4.1 you could just make a symlink, now for the db 3.x issue you could make a package that will install right beside db4.x .. I know many other distros use similare tricks to keep db compat issues in check.  Anyways just an idea not sure if it would work in this case.

Offline

Board footer

Powered by FluxBB