You are not logged in.

#1 2007-03-17 17:42:34

Jirka
Member
From: Czech Rep.
Registered: 2007-03-13
Posts: 21

Kernel panic? I'm panic! (solved)

Hi,

I'm already hopeless sad . The second day I'm trying to install Archlinux on my notebook.

I have also downloaded version 0.8 beta as in this thread http://bbs.archlinux.org/viewtopic.php?id=30549 was written, but I still get just:

IP-Config: no devices to configure
kinit: Unable to mount root fs on device dev(0,0)
kinit: init not found!
Kernel panic - not syncing: Attempted to kill init!

I really don't know what to do. sad sad

Please, kick me to the right way!

Last edited by Jirka (2007-03-17 20:03:00)


Linux is like a teepee. No Windows, no Gates, Apache inside!!!

Offline

#2 2007-03-17 19:11:39

newgargamel
Member
From: PL, CZ
Registered: 2005-08-28
Posts: 156

Re: Kernel panic? I'm panic! (solved)

you can try to install 0.7.2 and then upgrade to Voodoo

Offline

#3 2007-03-17 19:54:21

fishonadish
Member
Registered: 2006-11-04
Posts: 121

Re: Kernel panic? I'm panic! (solved)

newgargamel wrote:

you can try to install 0.7.2 and then upgrade to Voodoo

This can be messy because of the change from mkinitrd to mkinitcpio though.  I think 0.8 would require less messing around.

Jirka wrote:

kinit: Unable to mount root fs on device dev(0,0)

Do you perhaps have the wrong syntax in your menu.lst?

Could you post your menu.lst here or in the other thread you have going - http://bbs.archlinux.org/viewtopic.php?id=30928?

Last edited by fishonadish (2007-03-17 19:58:36)

Offline

#4 2007-03-17 20:01:21

Spadearcher
Member
From: Seattle
Registered: 2007-03-03
Posts: 20

Re: Kernel panic? I'm panic! (solved)

Jirka:  Which of the iso's I referred you to did you download to cd?  You should have chosen the current (for two cd's -- 1 and 2).  With those I loaded Voodoo 0.8 and booted it with no problem after installing from the first cd.  (I don't recall that I actually needed the second cd, but I'm not sure.)  Again, good luck.  It is possible for it to work.

Offline

#5 2007-03-17 20:02:29

Jirka
Member
From: Czech Rep.
Registered: 2007-03-13
Posts: 21

Re: Kernel panic? I'm panic! (solved)

After two days of installing I have used the LILO instead GRUB and everything is allright!

So it's solved.

Thank to everybody wink

Last edited by Jirka (2007-03-17 20:02:47)


Linux is like a teepee. No Windows, no Gates, Apache inside!!!

Offline

#6 2007-03-17 20:02:32

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,838

Re: Kernel panic? I'm panic! (solved)

Can you boot with the fallback initrd image?

Offline

#7 2007-03-23 23:52:37

paulr
Member
Registered: 2007-03-23
Posts: 49

Re: Kernel panic? I'm panic! (solved)

As a new Arch user I came across this on the initial post-install upgrade. The problem was fixed by changing the last line of /boot/grub/menu.lst to

initrd /kernel26.img

(was previously initrd26.img, I think)

After that, works like a charm smile

Offline

#8 2007-03-24 10:00:06

Feanor
Member
From: Rome (Italy)
Registered: 2007-03-23
Posts: 2
Website

Re: Kernel panic? I'm panic! (solved)

I've the same problem of the first post of this thread, my menu.lst is this

title Arch Linux
root (hd0,0)
kernel /boot/vmlinuz26 root=/dev/hda1 ro rootfstype=ext3
initrd /boot/kernel26.img

I can't find how to solve this.

Thanks everybody!
smile


"Se sarà così, bene; se fosse stato così, sarebbe stato bene; ma poiché non è così, non lo è. Questa è la logica" (Alice nel paese delle meraviglie)

Offline

#9 2007-03-25 23:53:45

JoxBG
Member
Registered: 2007-03-25
Posts: 2

Re: Kernel panic? I'm panic! (solved)

Feanor wrote:

I've the same problem of the first post of this thread, my menu.lst is this

title Arch Linux
root (hd0,0)
kernel /boot/vmlinuz26 root=/dev/hda1 ro rootfstype=ext3
initrd /boot/kernel26.img

I can't find how to solve this.

Thanks everybody!
smile

Remove the /boot line in kernel and initrd entries:
Should read:
kernel  /vmlinuz26 root=/dev/hda1 ro rootfstype=ext3
initrd   /kernel26.img

Jox

Offline

#10 2007-04-04 05:18:46

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,727

Re: Kernel panic? I'm panic! (solved)

No, the path is correct, if he dosn't have a seperate /boot partion.
As an example, if he did have a seperate /boot, and /boot was hda1 and / was hda2, then the entry woud be like this:

title Arch Linux
root (hd0,0)
kernel /vmlinuz26 root=/dev/hda2 ro
initrd /kernel26.img

The reason for this is that the path to the kernel is relative to the grub root () option.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

Board footer

Powered by FluxBB