You are not logged in.

#1 2007-04-08 12:35:24

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

SOLVED;GRUB woes

I decided to reinstall Arch 0.8, from scratch, just for the sake of doing it. (Keep sharp. tongue )
I have 3 sata drives. When I originally installed Arch, I only had 2 drives.

1- Seagate 80GB recognized as sdb
2- Seagate 160GB recognized as sda w/Windows vista
3- WD 250GB recognized as sdc w/Windows XP

Now I installed Arch to sdb1, grub to sdb and swap to sdb5.

Seagate 80gb is set to first boot device.

I am at work, so I don't have my grub with me, but I recall the root being (hd1,0).
The vmlinuz is directed to sdb1.

When using this configuration (setup by the Arch installer) I get an "unknown files system type" error. The drive names have shifted or something! It is being directed to one of the NTFS drives, apparently!
Now, when I hit "e" to edit the grub arguments, I changed it to root (hd0,0) and sda1, and I get a bit further; it starts to boot, but then I get a kernel panic error, not syncing, after a few moments!
What am I doing wrong, if someone can tell from the information above? Do I need to edit fstab, perhaps?

PS. Many moons ago I ghosted drive 1 (Windows XP) to drive 3, formatted drive 1 and used it for Arch...don't know if that matters.

Last edited by Misfit138 (2007-04-09 12:01:14)

Offline

#2 2007-04-08 13:32:39

Captain Spaulding
Member
Registered: 2006-11-16
Posts: 115
Website

Re: SOLVED;GRUB woes

Typical SATA controller confusion. Check out UUID or other persistent block device IDs. There is a wiki page somewhere in the Arch  wiki that explains how to.

Offline

#3 2007-04-08 16:42:27

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: SOLVED;GRUB woes

Ok, I'd like to use /dev/disk/by-label.


My kernel line will look like this:
kernel /boot/vmlinuz26 root=/dev/disk/by-label/root vga=773

but what about the root(hdx,x) line?
Won't I end up in the same boat with random names haunting me if I keep it as root(hd1,0) ?

Offline

#4 2007-04-08 21:16:51

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: SOLVED;GRUB woes

Well thanks so much for the tip. /dev/disk/by-label works beautifully in grub and fstab.
I suppose since I have 2 SATA controllers, they were fighting it out for supremacy or something, because during the installation the drive I installed Arch on was recognized as sdb, but after rebooting, it changes.....weird....

Offline

#5 2007-04-08 22:03:42

pelle.k
Member
From: Åre, Sweden (EU)
Registered: 2006-04-30
Posts: 667

Re: SOLVED;GRUB woes

Even if you've already solved the problem, this might come in handy for somebody;
http://www.gnu.org/software/grub/manual … e-map.html


"Your beliefs can be like fences that surround you.
You must first see them or you will not even realize that you are not free, simply because you will not see beyond the fences.
They will represent the boundaries of your experience."

SETH / Jane Roberts

Offline

Board footer

Powered by FluxBB