You are not logged in.

#1 2007-04-11 01:44:08

From: NJ, USA
Registered: 2007-04-09
Posts: 183

java and firefox plugin - works only when ipv6 disabled

Just thought I'd post this here in case anyone else runs into the same issue...

In short, the only way I could get java working in Firefox is to disable the ipv6 module from loading.  In /etc/modeprobe.conf :
alias net-pf-10 off
alias ipv6 off

After that, the java plugin works.

Long boring version...
I have a new install of Arch, running pretty much the latest from current ( as of 4/9/2007 ).  I'm still in the process of tweaking thing to my liking, but for the most part things were working.  the one exception was java in Firefox.  the latest jre and firefox ( bon echo ) installed, and I confirmed java was enabled.  But it simply would not load in Firefox.  I tried multiple sites, and all it did was ( eventually ) freeze the browser but never load the applet.
Java worked fine for java apps ( I played with jacman ) and also worked perfectly in Opera and Konqueror.

When starting firefox from a console I would see the following when a java applet attempted to load :
[root@dwight ~]#  dwight Oops: 0000 [#4]
dwight CPU:    0
dwight EIP:    0060:[<c02cefde>]    Not tainted VLI
dwight EFLAGS: 00010202   (2.6.20-ARCH #1)
dwight EIP is at fib_rules_lookup+0x1e/0xd0
dwight eax: d5404000   ebx: 00000000   ecx: 00000000   edx: e8e7f280
dwight esi: 00000000   edi: d5405e40   ebp: e8e7e920   esp: d5405db4
dwight ds: 007b   es: 007b   ss: 0068
dwight Process java_vm (pid: 6493, ti=d5404000 task=d5bdd570 task.ti=d5404000)
dwight Stack: 00000000 00000000 00000000 dacc4514 d5405e40 d5405e9c e8e6de8b d5
dwight e8e51950 00000000 00000000 d5405e4c e8e44d7b 00000000 00000000 00000000
dwight 00000000 d5405e4c dacc4514 dacc4504 dacc4080 e8e664c1 00000000 00000000
dwight Call Trace:
dwight [<e8e6de8b>] fib6_rule_lookup+0x2b/0x90 [ipv6]
dwight [<e8e51950>] ip6_pol_route_output+0x0/0x1c0 [ipv6]
dwight [<e8e44d7b>] ip6_dst_lookup_tail+0x8b/0xc0 [ipv6]
dwight [<e8e664c1>] tcp_v6_connect+0x241/0x700 [ipv6]
dwight [<c02b79f4>] lock_sock_nested+0xa4/0xb0
dwight [<c030770a>] inet_stream_connect+0x1ea/0x270
dwight [<c02b53a2>] sys_connect+0x82/0xd0
dwight [<c02b564f>] sock_attach_fd+0x6f/0xd0
dwight [<c01716ef>] get_empty_filp+0x6f/0x170
dwight [<c016e6a1>] fd_install+0x21/0x50
dwight [<c02b621c>] sock_map_fd+0x3c/0x60
dwight [<c02b6c08>] sys_socketcall+0x98/0x280
dwight [<c011d380>] do_page_fault+0x0/0x630
dwight [<c0103242>] sysenter_past_esp+0x5f/0x85
dwight =======================
dwight Code: e9 61 fe ff ff 90 8d b4 26 00 00 00 00 55 89 c5 57 89 d7 56 53 83                              ec 08 89 e0 89 4c 24 04 25 00 e0 ff ff ff 40 14 8b 55 34 8b 32 <8b> 06 0f 18 00                              90 39 f2 74 35 90 8d b4 26 00 00 00 00 8b 46 0c
dwight EIP: [<c02cefde>] fib_rules_lookup+0x1e/0xd0 SS:ESP 0068:d5405db4

Note the ip6_XXX stuff.  Also, immediately after this a lsmod showed ipv6 module loaded.  Now, I have *no* idea why java wantes to use ipv6 ( but only in Firefox + Epiphany ), but as a guess I modified modprobe.conf as listed above, and it worked. 
Prior to that I tried numerous things including running a generic version of firefox ( downloaded from Mozilla ) a generic version of java ( downloaded from Sun ), replacing nvidia drivers with the gpl nv, various updates ( including at least 3 different kernels ).  Nothing else worked.  Also, i was very careful to test each change individually, even rebooting ( just in case ), then when it didn't fix the issue, change things back ( except for the kernel updates ).

So, for anyone that may be having trouble with java applets for no apparent reason, and who doesn't need/want IPV6, give it a shot...
Also, yes I was running stuff as root, and I do know that you shouldn't do that.  But I wanted to rule out any possible permissions issues.

Finally, greetings...I'm new to Arch, and haven't had the opportunity to post before :-)


#2 2007-04-11 03:41:07

From: Canada
Registered: 2005-12-06
Posts: 1,595

Re: java and firefox plugin - works only when ipv6 disabled

If I understand what you are saying the answer is: No, IPV6 does not interfere with Java in FF.
I administer a WebCT server (a LMS system) and my preferred browser is FF. The LMS  relies on Java for a number of its tools and all of them work fine with FF.
Also I have 20K plus students in the system and have received no complaints at all to that effect.



#3 2007-04-11 12:25:31

From: NJ, USA
Registered: 2007-04-09
Posts: 183

Re: java and firefox plugin - works only when ipv6 disabled

If I understand what you are saying the answer is: No, IPV6 does not interfere with Java in FF.

In my case, it does.  I have tested this multiple times, and can reproduce it *every* time.  If I remove the alias/off for net-pf-10 and ipv6 ( I.E allow it to load ) + reboot, and make no other changes, java in Firefox stops working.  I add the aliases back  ( keep module from loading ), and Firefox/java plugin works.
Regardless of the contents of modprobe.conf or any other changes, java works in Opera, konqueror and for stand-alone java apps, and Firefox works in every other way.

This wasn't really a question, it was more info in case someone else runs into the same situation.  I don't doubt that there is something else as the root cause, or that it's unique to my one machine and no-one alse will every run into it. 
But in this case, keeping the ipv6 kernel module from loading is the only thing I need to change to get the Firefox java plugin to work.  Since I don't need/want IPV6 at this time, it's all I need to know.

Anyway, that's all.  I am curious if anyone's seen anything similar, but like I said, this was more of a FYI in the off chance someone does run into it.


Board footer

Powered by FluxBB