You are not logged in.

#1 2007-04-11 12:19:46

drum
Member
From: Australia
Registered: 2007-04-06
Posts: 128

great install but on second reboot....

I just installed Arch 0.8 with my favourite Gnome and it's wonderful. Just what I've been looking for.
I got everything working-network-sound-videoplayer-printer-nvidia-streaming audio etc etc.
When I reboot it only takes 30 secs to get me to the Gnome login screen. After I log in it hangs and nothing happens. Just a blank screen with the timer. Sometimes I can get as far as the desktop but it's frozen and there is nothing in the top and bottom panels.
I hit ctrl-alt-F5 and login there and reboot and it takes a few reboots like this and if I''m lucky it will boot up correctly, like this time :-)
Sorry for the newby explanation but I would be happy to send any more info which you think might help solve the problem as I really want to keep Arch.
I'm running a Pentium4 with 1gig of ram and an Nvidia 5200 card.
Thanks
regards
smile


bebop lives

Offline

#2 2007-04-11 12:26:05

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: great install but on second reboot....

Check your logs for errors - paste anything that looks suspicious.

Offline

#3 2007-04-11 12:58:00

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: great install but on second reboot....

I've had this start happening.  I deleted the ~/.gconf/desktop/gnome/sound/%gconf.xml and things wen back to normal.  It seems to me that enabling ESD in the sound options causes a problem.  I don't know what the problem is as I've only started investigating it.

If you go to System -> Preferences -> Sound and click on the "Test" button, you hear sound.  But since I cannot check ESD without the problem you describe, I can't hear any Gnome sounds.  Does anyone have a clue?

Also, what log file should I be looking in?  I see no errors being reported, but I may be looking in the wrong place.

HP DV8000, Intel Centrino Duo, nVidia GeForce 7400 Go, some sound card...

Last edited by mrunion (2007-04-11 13:06:05)


Matt

"It is very difficult to educate the educated."

Offline

#4 2007-04-11 14:08:18

drum
Member
From: Australia
Registered: 2007-04-06
Posts: 128

Re: great install but on second reboot....

Thanks for your input guys but I'm new and don't know where or how to check my log files for errors yet. I thought I was smart to get Arch running and looking so good. big_smile hehe
I'm sorry but glad someone else is having a similar problem.
We'll get to the bottom of it I'm sure.


bebop lives

Offline

#5 2007-04-11 14:18:38

Ramses de Norre
Member
From: Leuven - Belgium
Registered: 2007-03-27
Posts: 1,289

Re: great install but on second reboot....

After such a failed login check ~/.xsession-errors and /var/log/Xorg.0.log.old (.old if you're now in a working X session, if you haven't started X since the crash, drop the .old).

Offline

#6 2007-04-11 14:35:39

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: great install but on second reboot....

More to report:

I have been "playing" with this and here are some things I found:

1)  You DON'T have to remove the %gconf.xml file.  Just change the "true" statement to "false" in the event_sounds and enable_esd section.  you'll have to reboot, but Gnome will come back.
2)  ESD is NOT loaded in the Daemons=() line in rc.conf.  Should it be?  I don't recall this having to be there (and putting it there doesn't fix anything!)
3)  This is a laptop and I DON'T have hardware sound mixing.  But in the %gconf.xml file in the "sounds" folder, this is present: alsamixer:hw:0.  I can change this to ossmixer... using the System -> Preferences -> Sound panel and changing the Device in the "Default mixer Tracks" area.  It has made no difference.

Is this because I am on a laptop?  This arch is a FRESH INSTALL just done LAST NIGHT.  I installed the BASE, got wireless working and installed Gnome from pacman -- downloaded off the net, not from the CD.  It seems something with ESD/Gnome is boogered up, but I don't know what.

Help?

Also, here is the last error log from the failure *I think*.  I can recreate the failure, though and get the log.

/opt/gnome/etc/gdm/PreSession/Default: line 34: gdmflexiserver: command not found
/opt/gnome/etc/gdm/PreSession/Default: line 48: gdmflexiserver: command not found
/opt/gnome/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/opt/gnome/etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/opt/gnome/var/gdm/:0.Xservers" -h "" $
/opt/gnome/etc/gdm/Xsession: Beginning session setup...
/opt/gnome/etc/gdm/Xsession: ssh-agent not found!
/opt/gnome/etc/gdm/Xsession: Setup done, will execute: /opt/gnome/bin/gnome-session
SESSION_MANAGER=local/plunkerbunkey:/tmp/.ICE-unix/4969
Initializing gnome-mount extension

(process:5044): GStreamer-WARNING **: The GStreamer function gst_init_get_option_group() was
        called, but the GLib threading system has not been initialised
        yet, something that must happen before any other GLib function
        is called. The application needs to be fixed so that it calls
           if (!g_thread_supported ()) g_thread_init(NULL);
        as very first thing in its main() function. Please file a bug
        against this application.
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!

Matt

"It is very difficult to educate the educated."

Offline

#7 2007-04-11 16:32:50

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: great install but on second reboot....

Try this!  It worked for me!

Well, I hadn't been using dbus-launch because the Wiki I followed said it was for "old" (previous to 2.14, I think) Gnome.  BUT following linfan's post (from the Bug Reporting Section) I DID get sound and it DOESN'T lock up.  Here is what I did:

1)  Took "dbus" out of the DAEMONS=() line in /etc/rc.conf.
2)  Moved the "alsa" text to AFTER "... fam, hal, ..." (but this may have made NO difference) ANd added "esd".
3)  Changed "exec gnome-session" to "exec dbus-launch --exit-with-session gnome-session" in ~/.xinitrc
4)  I then went to System -> Preferences -> Sound and made sure all options were "Auto" (that had that option) and Device was HDA Intel (Alsa Mixer) on the first tab.  Then on the second tab I enabled ESD and System Sounds.

The system is working fine and there are no lockups!

Last edited by mrunion (2007-04-11 16:49:38)


Matt

"It is very difficult to educate the educated."

Offline

#8 2007-04-11 16:50:15

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: great install but on second reboot....

WRONG!  It doesn't work.  I just logged out of one user and on to another -- lockup!  Oh well.


Matt

"It is very difficult to educate the educated."

Offline

Board footer

Powered by FluxBB