You are not logged in.

#1 2007-04-10 14:37:40

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Pypanel / python xlib issue

Hi,

After upgrading python-xlib pypanel has stopped working

pypanel 
Traceback (most recent call last):
  File "/usr/bin/pypanel", line 893, in <module>
    from Xlib import X, display, error, Xatom, Xutil
ImportError: Bad magic number in /usr/lib/python2.4/site-packages/Xlib/__init__.pyo

Not sure whats wrong ......?

Last edited by Mr Green (2007-04-13 15:25:53)


Mr Green

Offline

#2 2007-04-10 15:10:54

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 603

Re: Pypanel / python xlib issue

Usually, that happens when a pyc file was compiled with a different python version than current python version available.

Kind regards,
STi


Ability is nothing without opportunity.

Offline

#3 2007-04-12 22:01:25

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Pypanel / python xlib issue

Offline

#4 2007-04-12 22:19:04

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 603

Re: Pypanel / python xlib issue

Good there is a comment... i just wanted to start doing a patch tongue


Ability is nothing without opportunity.

Offline

#5 2007-04-15 19:18:05

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: Pypanel / python xlib issue

Ok now if I run python2.5 /usr/bin/pypanel it works ;-S

Can I remove 2.4 now or do I have a paths problem?

Now getting it running from .xinitrc is another story even made a script to call it but will not start from log on ;-(

Last edited by Mr Green (2007-04-15 19:26:15)


Mr Green

Offline

Board footer

Powered by FluxBB