You are not logged in.

#1 2004-04-27 22:08:05

Pajaro
Member
Registered: 2004-04-21
Posts: 876

No Windows key in x.ork

Hi,

I have installed the x.org package from the testing repositories and now windows key doesn't work properly. When I click it the system detects the event, but when I press another key it is released before the second key press event is sent.

For example, when I want to assign a shorcut to the keyboard in KDE I press Windows key, and it shows "Windows +" waiting for the second key, but when I press R key it shows "R" instead of "Windows + R". In the modifier keys tab it shows Windows key as disabled.

Thank you in advance

Offline

#2 2004-04-29 15:59:51

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: No Windows key in x.ork

I have just installed X.org and I found out that it is missing the xkb rule files. I hope they will be part of the release X.org package.

This is the error message I get when running xorgconfig:

XKB rules file '/usr/X11R6/lib/X11/xkb/rules/' not found
Keyboard XKB options will be set to default values.

It might work with older files though... haven't tried it though.

Offline

#3 2004-04-30 03:10:58

ganlu
Member
From: ChongQing, China
Registered: 2004-01-04
Posts: 335

Re: No Windows key in x.ork

this is a compatible problem, Work-around is :
cd /usr/X11R6/lib/X11/xkb/rules/
ln -s xorg.xml xfree86.xml
ln -s xorg.lst xfree86.lst

Offline

#4 2004-04-30 09:54:30

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: No Windows key in x.ork

Yep, that solved it. At least I can change kbd layouts in KDE.
I still have to modify the xorg.conf file...

Anyhow, this should be fixed somehow in the release version.

Offline

#5 2004-04-30 12:18:38

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: No Windows key in x.ork

Hmm, although I can change mappings, I still can't use the Win key.
xorgconfig still doesn't see the keyboard types.
I changed manually the kbd type in the xorg.conf (pc101 to pc104) and still no change. I can press the Win key in KDE, but it doesn't work in combination with others. (the pc104 layout is loaded ok, I've checked the log file)

Offline

#6 2004-05-02 00:45:24

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: No Windows key in x.ork

Ok, so.. maybe xOrg forgot to map the Win Key.
Can somebody tell me what does
KDE Control Panel > Regional Settings & Accessibility > Keyboard Shortcuts > Modifier keys
say in the last column, called X11-Mod?

In my configuration, the last entry (corresponding to "Win" from the first column), is empty, making me believe that X11 does not know it has to map a "mod?" key for it.

Can somebody tell me how does the settings look for xfree86... the one which I'm not running. Or better, does anyone know how to make it look like it knows the Win modifier?

Offline

#7 2004-05-02 03:40:02

trey
Member
From: Alpharetta, GA
Registered: 2003-10-18
Posts: 73

Re: No Windows key in x.ork

I noticed this in mine as well.  It appears that during the install I chose a keyboard layout that did not have a 'Win' key when I should have chosen one that did.  I don't know which keyboard that is.  I assue it can be changed in XF86Config, but I'm not sure what layout to use.  I've got a MS natural keyboard (PS/2).

Offline

#8 2004-05-02 15:30:12

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: No Windows key in x.ork

Reported also in KDE Buglist and xkb patched
http://bugs.kde.org/show_bug.cgi?id=78467

(something seems to be wrong with XFree86 4.4.0 & X.org... a patch is available there for xkb - I don't know if it got to the X developers)

Offline

#9 2004-05-28 19:56:41

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: No Windows key in x.ork

It has been a long time since this has been reported... but now we've got a fix, a very simple one (it appeared on the X.org buglist after I reported it (Bug #587):

Solution: add a "XkbOptions" line to the Xorg's configuration file, inside the "InputDevice" section, as follows:

Section "InputDevice" 
        Identifier  "Keyboard0" 
        . 
        . 
        . 
        Option      "XkbOptions" "altwin:meta_win" 
EndSection

Offline

Board footer

Powered by FluxBB