You are not logged in.

#1 2007-04-25 07:08:15

p_schott
Member
Registered: 2006-11-23
Posts: 54

[SOLVED] No more USB auto mount

Hello,

A few weeks ago, USB automounting stopped working and so far I am unable to bring it back  :
- nothing happens when I insert a USB stick
- some partitions on a external USB disk are in fstab and correctly mounted, but volumes don't appear on the desktop
- but automatic CD and DVD mounting is ok

I am using hal, dbus and gnome-volume-manager, and I am a member of "storage" group.

My rc.conf (without comments)  is :

LOCALE="fr_FR.utf8"
HARDWARECLOCK="UTC"
TIMEZONE=Europe/Paris
KEYMAP="fr-latin9"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

MOD_AUTOLOAD="yes"
MOD_BLACKLIST=()
MODULES=(usblp raw1394)
USELVM="no"

HOSTNAME="arch"
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo !eth0)
ROUTES=(!gateway)

DAEMONS=(syslog-ng !hotplug !pcmcia !network netfs hal crond alsa cups dhcdbd networkmanager gdm)

dbus is started automatically by hal, I checked in gnome-system-monitor that it is running.

So far as I know, gnome desktop options are correctly set (in menu Preferences--->Removable devices and in gconf-editor), but perhaps there is something I have missed ?

Thank you very much if you have any idea of what I could do.

Last edited by p_schott (2007-05-06 12:35:15)

Offline

#2 2007-04-25 11:25:07

Firmicus
Forum Fellow
From: Germany
Registered: 2006-02-28
Posts: 168

Re: [SOLVED] No more USB auto mount

same problem here! And my configuration is similar to yours.

when running hald --verbose=true --daemon=no
and plug a usb stick afterwards I get error messages like this

12:11:28.195 [E] util.c:190: Cannot open '/sys/block/sde/sde1/range'

12:11:28.292 [E] device_info.c:272: Could not resolve keypath '@block.storage_device:storage.hotpluggable' on udi 'true'

12:11:28.294 [E] hald_dbus.c:4461: Cannot get caller info for org.freedesktop.DBus

Offline

#3 2007-04-26 06:54:04

p_schott
Member
Registered: 2006-11-23
Posts: 54

Re: [SOLVED] No more USB auto mount

One more point : I use "kernel26-fallback.img", as "kernel26.img" stopped working a couple of months ago (kernel panic).

Offline

#4 2007-05-05 20:25:12

p_schott
Member
Registered: 2006-11-23
Posts: 54

Re: [SOLVED] No more USB auto mount

No more kernel panic for kernel26.img since update to 2.6.21, but still no usb automount sad

Offline

#5 2007-05-05 23:28:49

ravster
Member
From: Queen's U, Kingston, Canada
Registered: 2004-05-02
Posts: 285
Website

Re: [SOLVED] No more USB auto mount

Just curious, can you mount it manually?

Offline

#6 2007-05-06 07:57:39

p_schott
Member
Registered: 2006-11-23
Posts: 54

Re: [SOLVED] No more USB auto mount

Yes. 

mount -t vfat /dev/sdh1 /media/usbdisk

works and I can browse the stick. But no icon appears on the desktop. Only partitions on internal hard drive seem to have a icon on the desktop.

Offline

#7 2007-05-06 10:01:03

Zap
Member
Registered: 2006-07-21
Posts: 41

Re: [SOLVED] No more USB auto mount

try to create a file "preferences.fdi" in /etc/hal/fdi/policy and write inside this

 <merge key="volume.ignore" type="bool">false</merge>

Offline

#8 2007-05-06 12:34:47

p_schott
Member
Registered: 2006-11-23
Posts: 54

Re: [SOLVED] No more USB auto mount

It works big_smile
Thank you very much Zap !

Offline

#9 2007-05-06 22:53:09

ravster
Member
From: Queen's U, Kingston, Canada
Registered: 2004-05-02
Posts: 285
Website

Re: [SOLVED] No more USB auto mount

Fix added to the Arch HAL wikipage.
Thanks for the fix, Zap.

Offline

#10 2007-05-07 14:52:11

p_schott
Member
Registered: 2006-11-23
Posts: 54

Re: [SOLVED] No more USB auto mount

One more detail : I have some partition on a external usb drive that are declared in /etc/fstab. It seems that they are mounted as expected, but they are also mounted a second time by hal. So, is there a way to prevent hal from mounting partitions that are already declared in fstab ?

Offline

#11 2007-11-15 20:12:00

Grenshad
Member
Registered: 2007-02-19
Posts: 22

Re: [SOLVED] No more USB auto mount

thanks a lot for the <merge key="volume.ignore" type="bool">false</merge> hint, and adding it in the wiki, i love you all \o/

Offline

#12 2009-04-07 23:33:25

col. panic
Member
Registered: 2009-01-18
Posts: 15

Re: [SOLVED] No more USB auto mount

Sorry for the noob question, how do I make a file?

Offline

#13 2009-04-07 23:43:54

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: [SOLVED] No more USB auto mount

col. panic wrote:

Sorry for the noob question, how do I make a file?

This thread is 2 years old, and your inquiry is offtopic, so I will close it. You may want to start a new thread and post your question there.
However, one way to make a file is to use /usr/bin/touch:

$ touch filename

Will create a file in the current directory named filename.

Offline

Board footer

Powered by FluxBB