You are not logged in.

#1 2004-04-29 19:21:00

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Sound module won't load after kernel upgrade

I just upgraded to kernel 2.4.26 along with xfree, perl, gaim and alsa-drivers with pacman.  After I restarted, I got the following message while loading modules:

snd.o couldn't find the kernel version the modules was compiled for

The modules I load for sound at boot are snd-via82xx and snd-pcm-oss
Anyone have any ideas for getting my sound back?

Thanks

Offline

#2 2004-04-29 19:22:20

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Re: Sound module won't load after kernel upgrade

here's the full modules load failure:

[root@archbox corneldm]# modprobe snd-via82xx
/lib/modules/2.4.26/kernel/sound/acore/snd.o: couldn't find the kernel version the module was compiled for
/lib/modules/2.4.26/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.26/kernel/sound/acore/snd.o failed
/lib/modules/2.4.26/kernel/sound/acore/snd.o: insmod snd-via82xx failed

Offline

#3 2004-04-29 19:51:56

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Sound module won't load after kernel upgrade

Check here
http://www.alsa-project.org/alsa-doc/in … VIA#matrix
if you don't know your soundcard

lspci

You are not saying what you upgraded from.


arch + gentoo + initng + python = enlisy

Offline

#4 2004-04-29 20:56:12

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Re: Sound module won't load after kernel upgrade

I have a VIA chipset and onboard AC'97 sound:

00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio (rev 02)

Everything was working last night with kernel 2.4.24.  Do I have to recompile the alsa driver for my sound card with kernel 2.4.26?  If so, how is that done?

Offline

#5 2004-04-29 21:35:46

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Sound module won't load after kernel upgrade

Check if kernel is alsa ready

modinfo soundcore

if it is try

modprobe snd-intel8x0

arch + gentoo + initng + python = enlisy

Offline

#6 2004-04-29 22:35:23

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Re: Sound module won't load after kernel upgrade

[root@archbox corneldm]# modinfo soundcore
modinfo: soundcore: no module by that name found

I didn't have to modify 2.4.24 to get alsa working, is this a different case?

Thanks for helping me out with this xerxes2.  I just got into arch earlier this week, so I'm still learning the ropes.

Offline

#7 2004-04-29 23:10:11

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Sound module won't load after kernel upgrade

I only used Arch for a couple of days myself.

I use kernel 2.6.5 and that one was alsa ready.
I don't know with 2..4.26 though but it seems that it is not.
Someone who is more in to Arch must answer that question.

Maybe it's a mistake of that person who compiled the kernel.

I can't help you out anymore here I'm afraid.


arch + gentoo + initng + python = enlisy

Offline

#8 2004-04-30 07:01:57

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Sound module won't load after kernel upgrade

You're running lilo right?  And you didn't run 'lilo' after installing the new kernel, like it told you to...


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#9 2004-04-30 07:13:46

kpiche
Forum Fellow
From: Ottawa, ON, Canada
Registered: 2004-03-30
Posts: 246
Website

Re: Sound module won't load after kernel upgrade

I use grub actually.  Thanks for the reply tho.

Offline

#10 2004-04-30 16:11:27

neocephas
Member
From: orange, ca
Registered: 2004-02-14
Posts: 30

Re: Sound module won't load after kernel upgrade

I am having a similar problem with my cs46xx sound card.  I was just syncing from kernel 2.4.26 to the newer 2.4.26 and then my sound modules stopped working.  Any ideas?

Offline

#11 2004-04-30 16:53:47

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Re: Sound module won't load after kernel upgrade

No, I'm using grub as well.

I even tried installing arch from scratch since I just set up the system a few days ago.  Now my video and sound modules won't load with the same kernal version error as before.  Something must have been missed when compiling 2.4.6-2, because 2.4.6-1 worked fine.

Oh, and I'm using powervr drivers for my Kyro II graphics card, so I compiled them on my own with the kernel I'm trying to use them for.  So that error makes even less sense to me than before.

Thanks for any suggestions you guys may have.

Offline

#12 2004-04-30 16:59:03

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Sound module won't load after kernel upgrade

I think that Xentac should sit down on his big butt and make a new kernel that is Alsa ready! :evil:


arch + gentoo + initng + python = enlisy

Offline

#13 2004-04-30 17:51:30

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Re: Sound module won't load after kernel upgrade

xerxes2 wrote:

I think that Xentac should sit down on his big butt and make a new kernel that is Alsa ready! :evil:

Module ready in general.  VESA is ugly  :cry:

wink

Offline

#14 2004-04-30 22:58:21

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Sound module won't load after kernel upgrade

Oddly enough.  I have the same error.  pacman updated alsa-driver yesterday and, since I have a custom kernel 2.4.26, I recompiled using makepkg and installe alsa-driver.  I get the folowing when I try to load the modules:

deadface root # modprobe  snd-maestro3 snd-pcm-oss
/lib/modules/2.4.26/kernel/sound/acore/snd.o: couldn't find the kernel version the module was compiled for
/lib/modules/2.4.26/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.26/kernel/sound/acore/snd.o failed
/lib/modules/2.4.26/kernel/sound/acore/snd.o: couldn't find the kernel version the module was compiled for
/lib/modules/2.4.26/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.26/kernel/sound/acore/snd.o failed
/lib/modules/2.4.26/kernel/sound/acore/snd.o: insmod snd-pcm-oss failed

I'll try to figure this out this weekend.

Kev

Offline

#15 2004-04-30 23:05:13

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Sound module won't load after kernel upgrade

I think that there is no alsa-soundcore in the kernel source.


arch + gentoo + initng + python = enlisy

Offline

#16 2004-05-01 02:35:46

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Sound module won't load after kernel upgrade

If you compile a kernel with gcc 3.3 and compile modules with gcc 3.4, they won't work together.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#17 2004-05-01 11:29:54

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Sound module won't load after kernel upgrade

Thanks, that is what I was thinking but I am having trouble with getting that kernel to compile with 3.4.

Offline

#18 2004-05-01 12:42:17

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Sound module won't load after kernel upgrade

I recompiled the kernel and alsa-driver with gcc3.4 and I am still getting the same error when trying to load the modules.  I'll try to snoop around a bit more with google.

Thanks
Kevin

Offline

#19 2004-05-02 11:38:39

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Sound module won't load after kernel upgrade

Hello

I was able to successfully downgrade gcc to 3.3.3 and recompile the kernel and alsa-driver.  After do so, I was able to load the modules without troubles.  I find it odd that gcc 3.4 kernel and gcc 3.4 alsa-driver gave that error yet gcc 3.3.3 versions failed.

Good luck
Kev

Offline

#20 2004-05-02 13:35:33

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Sound module won't load after kernel upgrade

Just a final update.

I downgraded built the kernels and modules that I want with gcc 3.3.3 and then upgraded back to gcc 3.4.  This way I have working kernels and sound and I can keep up with the rest of the arch world.  It also addresses my separate need for a gcc 3.3 compiled kernel due to a vendor supplied module.

Kev

Offline

#21 2004-05-02 18:44:38

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Re: Sound module won't load after kernel upgrade

Where can I download the gcc3.3.3 package? I don't have it in my cache, but I need to rebuild my kernel and modules with it.

Thanks

Offline

#22 2004-05-02 18:52:20

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Sound module won't load after kernel upgrade

Offline

#23 2004-05-02 20:27:02

Corneliax
Member
From: Indianapolis, IN
Registered: 2004-04-27
Posts: 43
Website

Re: Sound module won't load after kernel upgrade

sound and video working again!  big_smile

thanks for the help

Offline

Board footer

Powered by FluxBB