You are not logged in.

#1 2007-06-01 02:29:01

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

xorg-server 1.3.0.0

hello!

i just installed it. xorg starts, but with english keyboard, no synaptics enabled, no integration of the nvidia-module, resolution is only 1024x768. my laptop has a res of 1280x800. so i think, i still have to configure the xserver in a file?!

what is the improvement of the new server?

mfg iggy

Last edited by iggy (2007-06-01 02:29:31)


sorry for my bad english smile

Offline

#2 2007-06-01 03:30:41

aRcHaTe
Member
Registered: 2006-10-24
Posts: 645

Re: xorg-server 1.3.0.0

seem it sucks for now tongue


Its a sick world we live in....

Offline

#3 2007-06-01 04:46:16

faken
Member
From: Delmenhorst, Germany
Registered: 2007-06-01
Posts: 6

Re: xorg-server 1.3.0.0

Same here, no chance to get the Nvidia modul working...

How can i revert to the stable xorg version ?

Offline

#4 2007-06-01 05:09:28

baze
Member
Registered: 2005-10-30
Posts: 393

Re: xorg-server 1.3.0.0

to get the new resolution goodness, you need a driver that supports xrandr 1.2. the nvidia driver doesn't atm. the intel driver for example does support it.

Offline

#5 2007-06-01 07:41:26

bboozzoo
Member
From: Poland
Registered: 2006-08-01
Posts: 124

Re: xorg-server 1.3.0.0

funny think though, you're left with unuseable X.org just because nvidia doesn't support xrandr and unless you have a backup, there is no way to fall back to 1.2.0

Offline

#6 2007-06-01 07:48:16

samlt
Member
Registered: 2007-05-20
Posts: 18

Re: xorg-server 1.3.0.0

if you haven't cleaned it already you should fine the old xorg-server in /var/cache/pacman/pkg

Offline

#7 2007-06-01 07:51:24

Linteg
Member
From: Sweden
Registered: 2006-03-11
Posts: 54

Re: xorg-server 1.3.0.0

Please learn how to revert packages before you start using the "testing"-repo, packages from it might break your system from time to time, in order to revert to an older version you could either do what the previous poster said or, if you don't have a backup there, install it from the current repo with: pacman -S current/xorg-server

Last edited by Linteg (2007-06-01 07:55:04)

Offline

#8 2007-06-01 09:54:35

Bogart
Member
From: Madrid, Spain
Registered: 2005-06-22
Posts: 265

Re: xorg-server 1.3.0.0

To bypass the xrandr, I think you can just make a few modifications in /etc/X11/xorg.conf. I have an intel card, so can't test it with nVidia, but in case it works:

For example, I want to use a resolution of 1024x768 at 78HZ, so I use the command:

gtf 1024 768 78

This gives you a modeline like this one (with your own values):

Modeline "1024x768_78.00" 86.18 1024 1088 1200 1376 768 769 772 803 -HSync +Vsync

Now, in your /etc/X11/xorg.conf add that modeline to your Monitor section, and also add the line (with your values):

Option "PreferredMode" "1024x768_78.00"

Finally, in your screen section make sure you edit your modes to match the new name of the resolution (in my case, I had to change "1024x768" to "1024x768_78.00").

Last edited by Bogart (2007-06-01 09:56:01)

Offline

#9 2007-06-01 10:08:32

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: xorg-server 1.3.0.0

what is about the other problems (keyboard layout, synaptics)?


sorry for my bad english smile

Offline

#10 2007-06-01 10:19:03

netes
Member
From: Poland
Registered: 2007-02-01
Posts: 10

Re: xorg-server 1.3.0.0

Xorg-server 1.3.0 works fine with new nvidia-beta drivers.

Offline

#11 2007-06-01 10:24:29

Bogart
Member
From: Madrid, Spain
Registered: 2005-06-22
Posts: 265

Re: xorg-server 1.3.0.0

iggy wrote:

what is about the other problems (keyboard layout, synaptics)?

I think you might need an updated xf86-input-keyboard, xf86-input-mouse, etc... compiled against xorg-server-1.3. I got mine from this repo:

http://kth5.telekommunisten.net/xorg/

Try updating just xf86-input-keyboard from that repo and if that solves the keyboard problem file a bug so that they update all those drivers in the testing repo.

Offline

#12 2007-06-01 15:20:16

damjan
Member
Registered: 2006-05-30
Posts: 416

Re: xorg-server 1.3.0.0

iggy wrote:

what is about the other problems (keyboard layout, synaptics)?

You can always use 'setxkbmap' to set the layout at runtime... it was never needed to configure this in the xorg.conf file.

The synaptics driver should just work like it worked in xorg-server 1.2.0 .. but it requires the config file for sure.

BTW
I compiled my own xorg-server 1.3.0 (and xf86-video-intel 2.0) some time ago, and used everything else from the current/extra repositories in ArchLinux .. never had any problems ... and Randr 1.2 works great smile

Offline

#13 2007-06-01 16:15:22

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: xorg-server 1.3.0.0

I have Ati Radeon 9000 (250 chip) and there are problems with the opensource drivers from testing still - computer freezing when you log off from KDE. It works without DRI.
Xorg 1.3 found resolution which I never had in my life: it was size for three monitors smile. For ten minutes which I had 1.3 was not other  problems.

Offline

#14 2007-06-01 17:19:47

Bogart
Member
From: Madrid, Spain
Registered: 2005-06-22
Posts: 265

Re: xorg-server 1.3.0.0

lumiwa wrote:

It works without DRI.

For me this problem was solved by adding an Option "CacheLines" "768" to my device section in xorg.conf

lumiwa wrote:

Xorg 1.3 found resolution which I never had in my life: it was size for three monitors smile. For ten minutes which I had 1.3 was not other  problems.

You must add a "PreferredMode" option to solve this.

I posted about this two things here:

http://bbs.archlinux.org/viewtopic.php?id=33211

Offline

#15 2007-06-01 17:24:34

linfan
Member
From: Stockholm, Sweden
Registered: 2004-04-23
Posts: 135

Re: xorg-server 1.3.0.0

I couldn't resist trying - hehe. Enabled testing in pacman.conf and installed all testing stuff in there.

I have athlon 64 running 32 bits and nvidia.

No problems whatsoever. I never noticed any difference.

God job!

Offline

#16 2007-06-01 17:32:05

Xilon
Member
Registered: 2007-01-01
Posts: 243

Re: xorg-server 1.3.0.0

I installed it, moved the xorg.conf and restarted... AMAZING. Same resolution, everything werked... except it was set to QWERTY not Dvorak, and Synaptics wasn't set up (all to be expected). No crashes so far, looks great...

Offline

#17 2007-06-01 17:47:21

linfan
Member
From: Stockholm, Sweden
Registered: 2004-04-23
Posts: 135

Re: xorg-server 1.3.0.0

Got it all wrong sad Removed the xorg.conf and then it just could not find the frequencies for the monitor - I just got a black screen. Seems it doesn't work without the xorg.conf.

So, I will downgrade back to stable. Tried it out, but it did not work without xorg.conf, which was supposed to be the great thing with it. Sorry.

linfan

Last edited by linfan (2007-06-01 17:47:50)

Offline

#18 2007-06-01 18:20:06

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: xorg-server 1.3.0.0

Bogart wrote:
lumiwa wrote:

It works without DRI.

For me this problem was solved by adding an Option "CacheLines" "768" to my device section in xorg.conf

lumiwa wrote:

Xorg 1.3 found resolution which I never had in my life: it was size for three monitors smile. For ten minutes which I had 1.3 was not other  problems.

You must add a "PreferredMode" option to solve this.

I posted about this two things here:

http://bbs.archlinux.org/viewtopic.php?id=33211

I have ATI graphics card and when I asked in xorg cforum they told me that I need to disable DRI loading in the xorg.conf. If doesn't works okay but when I logout from KDE computer freezing and just reset button help. This happened with drivers from testing.

Offline

#19 2007-06-01 19:25:03

linfan
Member
From: Stockholm, Sweden
Registered: 2004-04-23
Posts: 135

Re: xorg-server 1.3.0.0

I don't quite get it. You people keep talking about adding stuff to xorg.conf. This experiment is supposed to work without any xorg.conf.

linfan

Offline

#20 2007-06-01 19:55:56

JGC
Developer
Registered: 2003-12-03
Posts: 1,664

Re: xorg-server 1.3.0.0

It should work without any xorg.conf on most systems, but when having problems, it's useful to tune xorg a bit by dumping a config with Xorg -configure, editing that one to suite your needs and place it into /etc/X11/xorg.conf.

One example is that it will always use the mouse and kbd drivers in combination with your videodriver. What if you use synaptics? Wacom? evdev? It doesn't use it by default, you have to configure it. The big improvement here is that you can enable/disable/change outputs using the xrandr command from X without restarting X.

Offline

#21 2007-06-01 20:30:38

linfan
Member
From: Stockholm, Sweden
Registered: 2004-04-23
Posts: 135

Re: xorg-server 1.3.0.0

So, i just type 'xrandr' and everything is fixed automagically? Is there any wiki or is this only for super-advanced users?

Besides, it is quite impossible to type xrandr, when you can't startx. In the black it just states that it cannot open the display, and using the old xorg.conf - xrandr is quite unnessesary, as the xorg is already configured with xorg -configure.

This is very hard to grasp. Any way I need 1280x1024 - but xorg-server gives me 1600??? How come a live CD can configure xorg, but not this new thing?

I just hate stuff that isn't documented and explained. But maybe that is coz I am stupid smile

Last edited by linfan (2007-06-01 21:16:12)

Offline

#22 2007-06-02 12:38:08

linfan
Member
From: Stockholm, Sweden
Registered: 2004-04-23
Posts: 135

Re: xorg-server 1.3.0.0

Finally got it to work without xorg.conf

Had to install xf86-video-nv - as nvidia  did not work. It was complaining it could not find nv

Hope I did not do anything stupid

linfan

Offline

#23 2007-06-02 13:01:16

kastor
Member
From: Mendoza - Argentina
Registered: 2006-06-18
Posts: 59
Website

Re: xorg-server 1.3.0.0

didn't work here with fglrx ati driver.. rollback to 1.2   sad

Offline

#24 2007-06-02 14:11:34

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: xorg-server 1.3.0.0

netes wrote:

Xorg-server 1.3.0 works fine with new nvidia-beta drivers.

can you post please your PKGBUILD for the new beta-drivers? because mine doesn't work. i use the kernel26suspend2 kernel.

thx, mfg
iggy


sorry for my bad english smile

Offline

#25 2007-06-02 19:14:33

linfan
Member
From: Stockholm, Sweden
Registered: 2004-04-23
Posts: 135

Re: xorg-server 1.3.0.0

I was told as I posted a bug report that xorg-server-1.3.0.0 is never going to work with nvidia drivers. It is supposed to work only with the xf86-video-nv. If you want to have the nvidia-driver, you will have to configure  Xorg, which is fair enough as the proprietary nvidia taints the kernel and is not in conformity with GPL.

After some reflection this answer is satisfactory and logic, but it is a bit annoying that nobody bothered to explain it. I would have been spared some frustrating hours of trying to install an impossible project, if I had known.

I have removed all testing stuff now, and when this new xorg-server hits current, I won't even notice it, as I already have a working xorg.conf.

As for me, this harass is now over.

Last edited by linfan (2007-06-02 19:16:21)

Offline

Board footer

Powered by FluxBB