You are not logged in.

#1 2007-06-07 15:38:41

LighthouseKeeper
Member
From: New Jersey
Registered: 2007-06-07
Posts: 25

wlan card support not enabled in kernel

Hello Arch. I'm a Linux novice coming over from Ubuntu. Right now, I am trying to set up wireless support for a RaLink|RT2561/RT61 802.11g PCI (copied from lshwd) card. I've been following the Wiki, which tells me to download a CVS snapshot of the driver. After unpacking it and going to make the driver, I run into this error:

# make
  CC [M]  /home/rael/rt2x00-cvs-2007060709/eeprom_93cx6/eeprom_93cx6.o
In file included from <command-line>:0:
/home/rael/rt2x00-cvs-2007060709/rt2x00_compat.h:23:2: error: #error mac80211 support not enabled in kernel!
/home/rael/rt2x00-cvs-2007060709/rt2x00_compat.h:27:2: error: #error 802.11 wlan card support not enabled in kernel!
/home/rael/rt2x00-cvs-2007060709/rt2x00_compat.h:56:2: error: #error mac80211 debugfs support has been disabled in your kernel!
make[2]: *** [/home/rael/rt2x00-cvs-2007060709/eeprom_93cx6/eeprom_93cx6.o] Error 1
make[1]: *** [_module_/home/rael/rt2x00-cvs-2007060709] Error 2
make: *** [default] Error 2

The error is pretty straightforward; support for the device is not enabled in the kernel.
However, I must confess, I don't know much about messing with kernels. I'd be very grateful if somebody here could provide me with some instructions, or at least some helpful resources. I've been searching for a while now, but I haven't found anything helpful yet. Google doesn't show anything concerning my errors. Thanks in advance.

On another note, Arch is wonderful. It's nice and light. I can't wait to have my machine running to its full potential.


I am almost lost.

Offline

#2 2007-06-07 16:49:37

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: wlan card support not enabled in kernel

Rt2x00 only runs with the dscape stack, which will be replacing the traditional 802.11 stack in 2.6.22.

The release candidates of 2.6.22 are your best bet, otherwise you have to patch stable kernels with the dscape stack, then apply the rt2x00 patches on top of them smile.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#3 2007-06-07 17:43:03

LighthouseKeeper
Member
From: New Jersey
Registered: 2007-06-07
Posts: 25

Re: wlan card support not enabled in kernel

So, you are saying that if I install kernel 2.6.22, then the driver should make properly?
Sorry, I am new to this sort of thing.


I am almost lost.

Offline

#4 2007-06-07 17:51:57

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: wlan card support not enabled in kernel

Try kernel26mm from the unstable repo - the current package is version 2.6.22-rc2-mm1. This not only has the dscape stack, it also provides the rt2x00 drivers, so you won't have to compile anything. smile

However, please note that the -mm kernels can be unstable, as they are used for experimental code that may or may not make it into the stable kernel tree. Keep the default kernel26 package on your system in case you run into trouble.

Last edited by tomk (2007-06-07 17:52:24)

Offline

#5 2007-06-07 19:14:42

klixon
Member
From: Nederland
Registered: 2007-01-17
Posts: 525

Re: wlan card support not enabled in kernel

Or you could try this one
It's the legacy rt61 driver from serialmonkey... works like a charm for me, but then, i created the PKGBUILD wink

edit: this one works for the current arch-kernel...

Last edited by klixon (2007-06-07 19:15:33)


Stand back, intruder, or i'll blast you out of space! I am Klixon and I don't want any dealings with you human lifeforms. I'm a cyborg!

Offline

#6 2007-06-07 19:56:34

LighthouseKeeper
Member
From: New Jersey
Registered: 2007-06-07
Posts: 25

Re: wlan card support not enabled in kernel

klixon wrote:

Or you could try this one
It's the legacy rt61 driver from serialmonkey... works like a charm for me, but then, i created the PKGBUILD wink

edit: this one works for the current arch-kernel...

Hmm. I untarred the package, cd'd to the directory and then did "makepkg". It said that it could not resolve all of the dependencies and said that I was missing "kernel26" and "module-init-tools" even though pacman says that both of them are there and updated. Am I doing it wrong somehow? I don't fully understand PKGBUILDs, but I read the Wiki and I think this is how it is meant to be done.

EDIT: Since I know that I have these packages, would I be able to edit the PKGBUILD and remove them from the dependencies, or would that seriously screw things up?

EDIT EDIT: I followed the advice of http://bbs.archlinux.org/viewtopic.php?id=30457 and downloaded a different tar. wlan0 with "RT61 Wireless" now shows up in iwconfig. It seems that the device is finally recognized. I hope I can set things up from here. Thanks for the help.

Last edited by LighthouseKeeper (2007-06-07 20:27:10)


I am almost lost.

Offline

#7 2007-06-23 17:12:35

foudebassan
Member
From: France, Bretagne
Registered: 2007-06-20
Posts: 3

Re: wlan card support not enabled in kernel

Hy everyone,
I 'm a new arch user , i tested debian, gentoo, ubuntu, and now arch :)

I had the same  problem,
with the same rt61 card.


i had to rebuild my self the kernel-2.6.22 source and patching with -mm patch
for getting the kernel build with rt61 card in hard, and i managed to install the nvidia-beta drivers, and getting my xorg as a rock :).

The kernel26-mm package is build witgh gcc-4.1.0,and on my systeme gcc-4.2.0 is allready installed.
The nvidia installed does not support building anything is this the kernel wasn't build with the same gcc version system.

Rebuild a kernel from    kernel-2.6.22 source and -mm patch made the trick.
i discovered mkinitcpio :

mkinitcpio -g /boot/kernel26mm-custom.img -k

i went through wpa encryption, using:
/usr/src/linux is my new compiled kernel:

ls -al

ls -al /usr/src/
total 53040
drwxr-xr-x  6 root root      4096 jun 24  2007 .
drwxr-xr-x 10 root root      4096 jan 20 18:23 ..
lrwxrwxrwx  1 root root        19 jun 24  2007 linux -> linux-2.6.22-rc4-mm
drwxr-xr-x 18 root root      4096 jun 21 08:30 linux-2.6.21-ARCH
drwxr-xr-x 19 root root      4096 jun 23  2007 linux-2.6.22-mm
drwxr-xr-x  2 fou  users     4096 jun 23  2007 linux-2.6.22-rc4
drwxr-xr-x 20 root root      4096 jun 23 17:14 linux-2.6.22-rc4-mm
-rw-r--r--  1 root root  54231040 jun 23  2007 linux-2.6.22-rc4.tar

Creating the .img initrd files made with this script:

#cat mk_img.sh

#!/bin/bash
Kernel_Release=`cat /usr/src/linux/include/linux/autoconf.h | grep CONFIG_UNAME_RELEASE | awk '{print $3}' | sed -e "s/\"//g"`
echo "##################"
echo "#"
echo $Kernel_Release
echo "#"
echo "##################"
echo "##################"
echo "#"
echo "#"
echo "Making new kernel22mm-custom-img"
if [ -f /sbin/mkinitcpio ]
then
       command_location=`whereis mkinitcpio | awk '{print $2}'`
       echo "executing $command_location -g /boot/kernel26mm-custom.img -k $Kernel_Release"
       $command_location -g /boot/kernel26mm-custom.img -k $Kernel_Release
       echo "New Kernel INITRD Img created successfully!"
       echo "using $Kernel_Release for kernel build release"
else
       echo "mkinitcpio not installed on current system" 
       echo "you should execute this to go through"       
       echo "Pacman -Sy && Pacman -Su && Pacman -S mkinitcpio" 
fi

#chmod +x mk_img.sh
#./mk_inig.sh   

##################
#
2.6.22-rc4-mm2-mm
#
##################
##################
#
#
Making new kernel22mm-custom-img
executing /sbin/mkinitcpio -g /boot/kernel26mm-custom.img -k 2.6.22-rc4-mm2-mm
:: Begin build
ERROR: module 'pata[-_]jmicron' not found
ERROR: module 'ata[-_]generic' not found
ERROR: module 'ahci' not found
ERROR: module 'ata[-_]piix' not found
:: Parsing hook [base]
:: Parsing hook [udev]
:: Parsing hook [autodetect]
:: Parsing hook [pata]
:: Parsing hook [scsi]
:: Parsing hook [sata]
:: Parsing hook [usbinput]
:: Parsing hook [keymap]
:: Parsing hook [filesystems]
:: Generating image '/boot/kernel26mm-custom.img'...SUCCESS
New Kernel INITRD Img created successfully!
using 2.6.22-rc4-mm2-mm for kernel build release

#cat /etc/rc.local

#!/bin/bash
wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
/sbin/dhcpcd wlan0

cat /etc/wpa_supplicant.conf


ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
fast_reauth=1
network={
        ssid="myESSID"
        mode=1
        proto=WPA
        key_mgmt=WPA-PSK
        group=TKIP
        psk="mypassphrase"
}

now, everything is working grate :)

my ndivia seems ok :

[fou@Rea ~]$ glxgears 
90131 frames in 5.0 seconds = 18026.067 FPS
90007 frames in 5.0 seconds = 18001.220 FPS

[fou@Rea ~]$ glxinfo 
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4

Last edited by foudebassan (2007-06-23 18:54:48)

Offline

Board footer

Powered by FluxBB