You are not logged in.

#1 2007-06-20 19:26:10

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

X freezes (UNSOLVED)

i am using "wmii" on Arch Duke and i see my screen was just got frozen when i was working. even "C-A-F2(3,4...)" was not working. strange thing was, mouse was working without any problem but as i said nothing else was working. i was not even able to kill X as "C-M-backspace" was not working :-(

any idea why it froze like heaven :-)

(or it was "wmii" problem ?)

Last edited by geek.arnuld (2007-06-24 17:02:50)

Offline

#2 2007-06-24 17:02:34

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Re: X freezes (UNSOLVED)

well, i see some people also have the same problem, EXACTLY  like i have:

http://bbs.archlinux.org/viewtopic.php?id=34124  (UNSOLVED)
http://bbs.archlinux.org/viewtopic.php?id=34113  (UNSOLVED)

an Xorg bug ?

Offline

#3 2007-06-24 17:47:24

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Re: X freezes (UNSOLVED)

ok ..... Gentoo users also have the same problem: http://forums.gentoo.org/viewtopic-t-19 … art-0.html

but for me these are 2 kinds of problems:

# 1)  when running "X" EVERYTHING just freezes. C-M-F2(3,4 rtc) does not work, my computer gets locked up. the only option is to use "restart" button on Cabinet.

#2)  exactly same as #1 but this time mouse moved, i mean mouse pointer does not freeze. but again, the solution is same as the #1.

on Arch, this problems occur 3 times day and on Gentoo it occurs 2-3 times a week. aaarghhh... my friends say that "Linux is same as Windows, it hangs and then you need reboot" :-(


EDIT: wanted to mention that i have used both 32 bit and 64 bit *fresh* installs and problem i same on both of them, got frustrated now mad .....so  i removed Arch and installed CRUX

Last edited by geek.arnuld (2007-06-24 20:29:58)

Offline

#4 2007-06-24 18:01:33

billy
Member
From: Slovenia
Registered: 2006-09-13
Posts: 164

Re: X freezes (UNSOLVED)

same thing happening here for a month, but still haven't found a solution. i sort of got used to it tongue. you can read about same problems here: http://bbs.archlinux.org/viewtopic.php?id=33470 . maybe you'll find something that can help you

Last edited by billy (2007-06-24 18:02:00)

Offline

#5 2007-06-24 20:16:44

karsten
Member
Registered: 2006-07-14
Posts: 261

Re: X freezes (UNSOLVED)

hm wow i just started having crashes too http://bbs.archlinux.org/viewtopic.php?id=34526
kind sucks i lost a few hours of work.

Last edited by karsten (2007-06-24 20:17:14)

Offline

#6 2007-06-25 11:11:30

uwolfer
Member
Registered: 2006-02-27
Posts: 46

Re: X freezes (UNSOLVED)

Same problem here. When I'm away from computer, the computer freezes (probably after some minutes, but not everytime). I have found out that X increases the CPU load within some minutes up to 100%. When the load is 100%, sometimes I get again down when I move the window and sometimes I have to do a hard reset...

I have written now a "tool" what changes to focus between two textinput lines. When I have running this tool, I have no more such freezes...

Offline

#7 2007-06-25 11:24:40

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 605

Re: X freezes (UNSOLVED)

Get decent hardware which does not overheat in summer.

Seriously, i also have those problems with nvidia / ati drivers. It's wonderful stable running intel i810 drivers here...

Yours,
Georg


Ability is nothing without opportunity.

Offline

#8 2007-06-25 14:39:13

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: X freezes (UNSOLVED)

what graphics?

file a bug at bugs.archlinux.org, you'll get much more attention, and more quickly.

James

Offline

#9 2007-06-25 14:48:08

uwolfer
Member
Registered: 2006-02-27
Posts: 46

Re: X freezes (UNSOLVED)

Bug reported:
http://bugs.archlinux.org/task/7513

Please add there your problems wink

Offline

#10 2007-06-26 04:28:38

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Re: X freezes (UNSOLVED)

i have posted this on "Arch general mailing list", where i also posted output of "lspci" and this is what i got from there:

-----------------------------------------------------
> 01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome
> Pro VGA Adapter (rev 01)
> [arnuld@arch ~]$

With this card I would expect some compatibility issues on any system, I had
S3 in my old laptop - and its crap.

"Peter Mykytyn"
---------------------------------------------

can all of you people post your "lspci" ?    i  want to churn out every possibility to solve this problem

Offline

#11 2007-06-26 11:52:45

uwolfer
Member
Registered: 2006-02-27
Posts: 46

Re: X freezes (UNSOLVED)

My lspci output, using the nvidia drivers:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation NV41.8 [GeForce Go 6800] (rev a2)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
03:01.2 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

Offline

#12 2007-06-26 17:07:41

emmybear
Member
Registered: 2007-04-20
Posts: 38

Re: X freezes (UNSOLVED)

Is everyone in this thread using wmii?

I myself use KDE, and have not had an issue like this, but it still might be some weird extension or something that is being loaded in X. Anyway, please post your xorg.conf files to some place such as pastebin.ca and post the link here. I will give them a look over and look for anything odd or whatnot. Cheers.

Offline

#13 2007-06-26 18:59:51

billy
Member
From: Slovenia
Registered: 2006-09-13
Posts: 164

Re: X freezes (UNSOLVED)

i'm using xfce and here's my xorg.conf: http://pastebin.ca/590712. yeah i know, it needs a little bit of cleaning roll.

Offline

#14 2007-06-26 19:07:00

somairotevoli
Member
Registered: 2006-05-23
Posts: 335

Re: X freezes (UNSOLVED)

I have the same issues using kde w/ nvidia-71xx. It usalyl happens while I am away from the pc, sometimes not. Everything locks except mouse.

bash-3.2$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0f.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
# X Server Configuration file generated by kX Generator 0.3.7
# (c) 2006 Tomasz Salacinski

  Section "ServerLayout"
      Identifier     "Xorg Configured"
      Screen         "Screen0"
      InputDevice    "Keyboard0" "CoreKeyboard"
      InputDevice    "PS/2 Mouse" "CorePointer"
  EndSection

  Section "ServerFlags"
      Option         "AllowMouseOpenFail" "true"
      Option         "DefaultServerLayout" "Xorg Configured"
  EndSection

  Section "Files"
RgbPath "/usr/share/X11/rgb"
      ModulePath     "/usr/lib/xorg/modules"
      FontPath     "/usr/share/fonts/misc:unscaled"
    FontPath     "/usr/local/share/fonts"
EndSection

  Section "Module"
      Load           "ddc"
      Load           "dbe"
      Load           "extmod"
      Load           "glx"
      Load           "bitmap"
      Load           "type1"
      Load           "freetype"
      Load           "record"
  EndSection

  Section "InputDevice"
      Identifier     "Keyboard0"
      Driver         "keyboard"
      Option         "CoreKeyboard"
      Option         "XkbRules" "xorg"
      Option         "XkbModel" "pc105"
      Option         "XkbLayout" "en_US"
      Option         "XkbVariant" ""
  EndSection

  Section "InputDevice"
      Identifier     "PS/2 Mouse"
      Driver         "mouse"
      Option         "Protocol" "auto"
      Option         "ZAxisMapping" "4 5"
      Option         "Device" "/dev/psaux"
      Option         "Emulate3Buttons" "true"
      Option         "Emulate3Timeout" "70"
      Option         "SendCoreEvents" "true"
  EndSection

  Section "Device"
      Identifier     "Card0"
      Driver         "nvidia"
      VendorName     "nVidia Corporation"
      BoardName      "NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
      Option         "RenderAccel" "True"
      Option         "NoLogo" "True"
      Option         "NvAGP" "2"
  EndSection

  Section "Monitor"
      Identifier     "Monitor0"
      HorizSync      30.0 - 85.0
      VertRefresh    48.0 - 150.0
Gamma 1
  EndSection

  Section "Screen"
      Identifier     "Screen0"
      Device         "Card0"
      Monitor        "Monitor0"
      DefaultDepth 16

         SubSection "Display"
            Depth           16
            Modes           "1280x1024" "1024x768" "800x600" "640x480"
         EndSubSection
  EndSection

Offline

#15 2007-06-26 20:03:01

insane
Member
Registered: 2006-06-04
Posts: 106

Re: X freezes (UNSOLVED)

I had the same problem as geek.arnuld. I am using KDE and NVIDIA driver. I downloaded and installed manually version 9631 of the driver from NVIDIA. No freezes since yesterday.

Offline

#16 2007-06-26 20:20:36

arvster
Member
From: Riga, Latvia
Registered: 2007-01-08
Posts: 37
Website

Re: X freezes (UNSOLVED)

I too had some very similar problems. The symptoms were the same- mouse working, keyboard not responding at all. Though, all this didn't happen when using the computer normally, but rather when booting and starting up Gnome. When I booted in KDE, everything worked fine.  A quick look in my logs didn't show anything interesting. At first I suspected Compiz-fusion, as I had installed it just recently, but it worked all ok in KDE. For me the NVIDIA's latest binary drivers were the cause- nvidia-100.14.11-1. When I downgraded back to 9755 drivers, all problems disappeared. From what I read, people with not only Nvidia cards are having something similar, so maybe that is really a Xorg problem instead?

Offline

#17 2007-06-27 03:28:31

oggb4mp3
Member
Registered: 2005-06-17
Posts: 77

Re: X freezes (UNSOLVED)

I am experiencing two distinct X freezing issues that it seems people are describing here, and I am not sure which one this thread ended up being about, so I will post both experiences.  I have also posted this info to the bug report on this issue.

I also had hard freezes begin to appear when I upgraded to nvidia 100.14.11.  The machine completely freezes with no log message.  I can't even ssh into the box.  I rolled back to 100.14.09 and they appear to have stopped.

I will also say that I am experiencing the other X freezing that people are complaining about.  The mouse still moves, but does appear to interact with any elements on the screen.  This problem seems to present itself after the computer has been idle for some time.  I have a dual-core proc and I can ssh in to the box and look at the CPU stats in htop while this is going on, the two cores sitch back and forth on high cpu usage.  Core0 will show the x process at 90+% cpu for a couple of seconds, then core1 will take on the load, then core0, etc.  If you wait long enough, it seems that the system actually is responding to mouse clicks, just very slowly.  One time I left the machine alone for about fifteen minutes and it appeared to have stopped, although I have not been able to recreate this.

I have tried to look for a pattern based on which apps were left open, whether beryl was running or not, etc. and I can't seem to find a common denominator other than it usually is occurring when I sit down at the machine after being away for some time.

Offline

#18 2007-06-29 06:04:25

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Re: X freezes (UNSOLVED)

emmybear wrote:

Is everyone in this thread using wmii?

of course.... NO.  i have reproduced this freeze on Winodwmaker and Ratpoison too.

emmybear wrote:

I myself use KDE, and have not had an issue like this, but it still might be some weird extension or something that is being loaded in X. Anyway, please post your xorg.conf files to some place such as pastebin.ca and post the link here. I will give them a look over and look for anything odd or whatnot. Cheers.

ok, 1st i will learn how to do this "pastebin.ca". BTW, not running Arch ATM.

Offline

#19 2007-06-29 06:06:58

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Re: X freezes (UNSOLVED)

arvster wrote:

I too had some very similar problems. The symptoms were the same- mouse working, keyboard not responding at all. Though, all this didn't happen when using the computer normally, but rather when booting and starting up Gnome. When I booted in KDE, everything worked fine.  A quick look in my logs didn't show anything interesting. At first I suspected Compiz-fusion, as I had installed it just recently, but it worked all ok in KDE. For me the NVIDIA's latest binary drivers were the cause- nvidia-100.14.11-1. When I downgraded back to 9755 drivers, all problems disappeared. From what I read, people with not only Nvidia cards are having something similar, so maybe that is really a Xorg problem instead?

well, i do not have nvidia. i have VIA but problems are same. BTW, nvidia proprietary driver is known be the cause of some problems, including these freezes. but as i said i have VIA.

Offline

#20 2007-06-29 06:18:26

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Offline

#21 2007-07-11 07:17:54

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Re: X freezes (UNSOLVED)

ok guys,

found a solution proposed by JGC at "Flyspry". i am using "openchrome" drivers rather than VIA of "xf86-video-via" and it has been 3 days, no single lockup smile except that audacious behaved very badly on one occasion only.

you can find the Flyspray entry here:  http://bugs.archlinux.org/task/7513 

enjoy Arch & GNU  smile

{NOTE:  let me check this driver for 10 days to make sure that the VIA driver was the cause of the trouble. then i will change the title to SOLVED. searching Google, lots of mailing lists Archives and Forums of different distros makes one thing sure:  this graphics card i have is a total crap sad }

Last edited by geek.arnuld (2007-07-11 07:20:48)

Offline

#22 2007-07-13 17:47:03

geek.arnuld
Member
From: INDIA
Registered: 2007-05-03
Posts: 135
Website

Re: X freezes (UNSOLVED)

geek.arnuld wrote:

ok guys,

found a solution proposed by JGC at "Flyspry". i am using "openchrome" drivers rather than VIA of "xf86-video-via" and it has been 3 days, no single lockup smile except that audacious behaved very badly on one occasion only.

you can find the Flyspray entry here:  http://bugs.archlinux.org/task/7513 

enjoy Arch & GNU  smile

{NOTE:  let me check this driver for 10 days to make sure that the VIA driver was the cause of the trouble. then i will change the title to SOLVED. searching Google, lots of mailing lists Archives and Forums of different distros makes one thing sure:  this graphics card i have is a total crap sad }

ok guys, i have met 2 X lockups today and 1 lockup yesterday. therefore i am sure neither VIA nor openchorme driver is to blame. this is the hardware problem ... .. crappy ASUS, never buy this one sad

Offline

#23 2007-07-13 20:12:04

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 5,566

Re: X freezes (UNSOLVED)

What processors are you guys using ?

Core2Duo , other intel,  amd ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#24 2007-07-23 11:56:50

necrolin
Member
Registered: 2007-07-09
Posts: 23

Re: X freezes (UNSOLVED)

I was having the same problem. Me computer would randomly freeze and nothing would work except the mouse. This happened more often when I was using beryl.

Solved.

I uninstalled the nvidia driver.
Compiled my own driver from nvidia and the problem is 100% resolved. big_smile Yay!!!!

Offline

#25 2007-07-24 02:01:28

oggb4mp3
Member
Registered: 2005-06-17
Posts: 77

Re: X freezes (UNSOLVED)

necrolin wrote:

I uninstalled the nvidia driver.
Compiled my own driver from nvidia and the problem is 100% resolved. big_smile Yay!!!!

Sadly, this did not work for me  sad

Offline

Board footer

Powered by FluxBB