You are not logged in.

#1 2007-07-10 15:49:11

Registered: 2007-07-10
Posts: 111

Compiling a Kernel for my Laptop - Arch Way

Hi, this is my first post and i apologize for my bad english!
I'm stuck with a problem that i can't solve...i'm trying to compile a vanilla kernel "à la Arch" and i've downloaded the PKGBUILD from the italian Arch site (i'm italian :-) ).
I've tried to configure the kernel with gconfig and after half an hour i've installed my new kernel with pacman.
I've launched mkinitcpio like this : mkinitcpio -g /boot/kernel_26.img -k , in order to have the image.
The problem is that i have an old IDE disk on this laptop and every time i try to boot my system with the new kernel i run into a kernel panic.
It seems that the system can't recognize the filesystem on which the root is mounted...

# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES="ata_generic ata_piix"

# This setting includes, into the CPIO image, and additional
# binaries a given user may wish.  This is run first, so may
# be used to override the actual binaries used in a given hook.
# (Existing files are NOT overwritten is already added)
# BINARIES are dependancy parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in anyway.  This is useful for config files.
# Some users may wish to include modprobe.conf for custom module options,
# like so:
#    FILES="/etc/modprobe.conf"

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'modload' may be used in place of 'udev', but is not recommended
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
#    This setup specifies all modules in the MODULES setting above.
#    No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#    This setup will autodetect all modules for your system and should
#    work as a sane default
#    HOOKS="base udev autodetect ide scsi sata filesystems"
#    This setup will generate a 'full' image which supports most systems.
#    No autodetection is done.
#    HOOKS="base udev ide scsi sata usb filesystems"
#    This setup assembles an ide raid array with an encrypted root FS.
#    Note: See 'mkinitcpio -H raid' for more information on raid devices.
#    HOOKS="base udev ide raid encrypt filesystems"
#    This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev usb lvm2 filesystems"
HOOKS="base udev autodetect pata scsi sata keymap filesystems"

I think that probably i've not selected the correct modules when i was configuring the kernel but i can't say which ones...

Is it a common problem?
Thank you very much


#2 2007-07-10 16:41:54

From: Michigan
Registered: 2007-05-04
Posts: 185

Re: Compiling a Kernel for my Laptop - Arch Way

Can you give us the exact error that its throwing when the kernel panics?

\\ archlinux on a XPS M1530 //


#3 2007-07-10 23:17:27

Registered: 2007-07-10
Posts: 111

Re: Compiling a Kernel for my Laptop - Arch Way

kano wrote:

Can you give us the exact error that its throwing when the kernel panics?

during the boot i read :

hda: unknown partition table

but it goes on..

then :

Loading initramfs
running hook[udev]
loading udev...

and stop!It doesn't even give an error message...

I've noticed that during a normal boot (with the Arch-kernel pre-compiled) after the LOADING UDEV...there's a sort of :

SCSI dev sda,.. message

So i believe that the new kernel fail to load something related to the disk...

Edit: i've recompiled once again the whole kernel and then i've created the image with mkinitcpio..the output oh that seems interesting,i report here the first 2 lines, the only one beginning with ERROR:

ERROR: module 'ata[-_]generic' not found
ERROR: module 'ata[-_]piix' not found

Last edited by Demind (2007-07-10 23:47:05)


#4 2007-07-10 23:56:38

From: Kanuckistan
Registered: 2003-07-28
Posts: 510

Re: Compiling a Kernel for my Laptop - Arch Way


In your kernel config, go to : Device Drivers / Serial ATA (prod), and make sure "Intel ESB, ICH ..." is selected.  That should give you ata_piix.


Board footer

Powered by FluxBB