You are not logged in.

#1 2004-05-10 03:41:34

nkw
Member
Registered: 2004-03-26
Posts: 80

"Activating swap" failed when booting?

My new installed archlinux always show

::Activating Swap       [Failed]

But the system works, any problem with my installation? anyway to get rid of the red error Failed?


I set up the network by:
1) add 'alias eth0 8139too' in /etc/modprobe.conf
2) run 'dhcpcd eth0'
Any better way to set up network?

Thanks,

Offline

#2 2004-05-10 03:52:05

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: "Activating swap" failed when booting?

swap:
do you get something like this with swapon:

[damir@Asteraceae /]$ swapon -s
Filename                                Type            Size    Used    Priority
/dev/ide/host0/bus0/target0/lun0/part4  partition       824032  0       -1

if not, it is not good --- because then it means that you have no swap running

network:
1) is ok
2) is not needed, if you include eth0 in INTERFACES in /etc/rc.conf


The impossible missions are the only ones which succeed.

Offline

#3 2004-05-10 04:59:21

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: "Activating swap" failed when booting?

yes, i have the similar information when run "swapon -s", however, when booting, still

:: Activating Swap       [Failed]

Network problem solved... Thanks

Offline

#4 2004-05-10 05:02:37

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: "Activating swap" failed when booting?

[damir@Asteraceae /]$ more /var/log/kernel | grep swap

gives back something intelligent?

something like this is normal:

Apr  6 19:34:07 Asteraceae kernel: Adding 824032k swap on /dev/discs/disc0/part4.  Priority:-1 extents:1

The impossible missions are the only ones which succeed.

Offline

#5 2004-05-10 05:10:30

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: "Activating swap" failed when booting?

The command return:

bash-2.05b$ more /var/log/kernel | grep swap
May  9 15:33:45 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 15:35:33 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 15:40:10 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 15:55:52 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 15:57:32 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 16:31:40 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 17:13:13 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 17:25:03 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1
May  9 17:37:05 myhost kernel: Adding 385520k swap on /dev/discs/disc0/part5.  Priority:-1 extents:1

Offline

#6 2004-05-10 10:22:16

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: "Activating swap" failed when booting?

then your swap seems to function --- no idea why it says there FAILD, when it works


The impossible missions are the only ones which succeed.

Offline

#7 2004-05-11 00:36:03

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: "Activating swap" failed when booting?

the fdisk return the following message, and my file system is ReiserFS

Disk /dev/hda: 13.6 GB, 13600677888 bytes
255 heads, 63 sectors/track, 1653 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         893     7172991    7  HPFS/NTFS
/dev/hda2             894         906      104422+  83  Linux
/dev/hda3             907        1605     5614717+  83  Linux
/dev/hda4            1606        1653      385560    f  W95 Ext'd (LBA)
/dev/hda5            1606        1653      385528+  82  Linux swap

Offline

#8 2004-05-11 13:40:43

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: "Activating swap" failed when booting?

sounds ok

and free has also normal results?

[damir@Asteraceae /]$ free -lm
             total       used       free     shared    buffers     cached
Mem:           755        513        242          0         79        251
Low:           755        513        242
High:            0          0          0
-/+ buffers/cache:        181        573
Swap:          804          0        804

The impossible missions are the only ones which succeed.

Offline

#9 2004-05-11 17:22:20

kpiche
Forum Fellow
From: Ottawa, ON, Canada
Registered: 2004-03-30
Posts: 246
Website

Re: "Activating swap" failed when booting?

What's your fstab like?  Maybe an erroneous swap partition in there?

Offline

#10 2004-05-11 17:51:13

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: "Activating swap" failed when booting?

/dev/discs/disc0/part4 swap swap defaults 0 0

The impossible missions are the only ones which succeed.

Offline

#11 2004-05-12 02:26:52

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: "Activating swap" failed when booting?

dp wrote:

sounds ok

and free has also normal results?

my freelm:

bash-2.05b$ free lm
             total       used       free     shared    buffers     cached
Mem:        286512     280948       5564          0      67724      78884
-/+ buffers/cache:     134340     152172
Swap:       385520          0     385520

Offline

#12 2004-05-12 02:32:25

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: "Activating swap" failed when booting?

kpiche wrote:

What's your fstab like?  Maybe an erroneous swap partition in there?

My fstab

# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /proc         proc      defaults            0      0
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
sysfs                  /sys          sysfs     defaults            0      0
usbdevfs               /proc/bus/usb usbdevfs  defaults            0      0

/dev/cdroms/cdrom0     /mnt/cd   iso9660   ro,user,noauto,unhide   0      0
/dev/cdroms/cdrom0     /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/floppy/0          /mnt/fl   vfat      user,noauto,unhide      0      0

/dev/discs/disc0/part5 swap swap defaults 0 0
/dev/discs/disc0/part3 / reiserfs defaults 0 0
/dev/discs/disc0/part5 swap swap defaults 0 0
/dev/discs/disc0/part3 / reiserfs defaults 0 0

Offline

#13 2004-05-12 04:06:57

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: "Activating swap" failed when booting?

mmm....maybe the problem is that the line is repeated (or maybe you just made a mistake when you copied/pasted)


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#14 2004-05-12 04:51:11

nkw
Member
Registered: 2004-03-26
Posts: 80

Re: "Activating swap" failed when booting?

kakabaratruskia wrote:

mmm....maybe the problem is that the line is repeated (or maybe you just made a mistake when you copied/pasted)

Thanks, after remove the duplicated lines, problem has gone, don't know if the duplicated lines are caused by me setting the mount point twice (i did when installing).

Offline

#15 2004-05-12 11:16:57

yak8998
Member
Registered: 2004-03-01
Posts: 143

Re: "Activating swap" failed when booting?

yeah, that was it. It would mount the swap the first time, but than the 2nd time it was already mounted so it failed. lol


"Ignorance is bliss, for stupid people."
"open-source is [...] programming Darwinism."
Vaughan-Nichols

Offline

Board footer

Powered by FluxBB