You are not logged in.

#1 2004-05-15 13:21:08

mzruya
Member
Registered: 2004-05-14
Posts: 20

Can't listen sound ....

i can't manage to get sound started under kde ..
i installed all of the alsa packages and i don't get any error when trying to listen to a mp3 it plays but with no sound (like the volume in muted, it isn't) ...
hardware detect gives me : Load sound module       : modprobe snd-intel8x0

when i modeprobe it says it is already loaded ..
what is the problem ??
even root can't listen to sound ..

Offline

#2 2004-05-15 14:38:18

mzruya
Member
Registered: 2004-05-14
Posts: 20

Re: Can't listen sound ....

** WARNING **: alsa_setup(): Failed to open pcm device (default): Device or resource busy

Offline

#3 2004-05-15 14:45:18

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Can't listen sound ....

Check arts configuration in kde control center. I lost sound in kde (arts) after an upgrade to kernel 2.6.6. The only thing I had to do to make it work again was to change arts config in kcontrol back to the automatic recognition, click ok and then again change it to alsa and click ok. I know that's stupid but worked for me :-) (that's probably because kernel 2.6.6 already supports alsa and kde have to notice this change or something like this).

I can see that you have just posted an alsa error - post also lsmod and lspci output. How do you load modules? Check MODULES line in /etc/rc.conf or modules.conf or modprobe.conf depending on what you use to load sound drivers. Are you sure that you are not trying to load oss modules first? That would explain the "device busy" error.

Offline

#4 2004-05-15 16:12:32

mzruya
Member
Registered: 2004-05-14
Posts: 20

Re: Can't listen sound ....

thanks for the reply
lsmod :
ntfs                   97004  1
snd_intel8x0           31272  3
snd_ac97_codec         61444  1 snd_intel8x0
snd_pcm                92192  3 snd_intel8x0
snd_timer              23428  1 snd_pcm
gameport                4224  1 snd_intel8x0
snd_page_alloc          9860  2 snd_intel8x0,snd_pcm
snd_mpu401_uart         7040  1 snd_intel8x0
snd_rawmidi            21280  1 snd_mpu401_uart
snd_seq_device          6920  1 snd_rawmidi
snd                    49124  11 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               8160  1 snd
3c59x                  36136  0
parport_pc             23080  0
parport                38888  1 parport_pc
8139too                22016  0
mii                     4480  1 8139too
crc32                   4352  1 8139too

lspci :
00:00.0 Host bridge: Intel Corp.: Unknown device 2570 (rev 02)
00:01.0 PCI bridge: Intel Corp.: Unknown device 2571 (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp.: Unknown device 24d0 (rev 02)
00:1f.1 IDE interface: Intel Corp.: Unknown device 24db (rev 02)
00:1f.2 IDE interface: Intel Corp.: Unknown device 24d1 (rev 02)
00:1f.3 SMBus: Intel Corp.: Unknown device 24d3 (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp.: Unknown device 24d5 (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0322 (rev a1)
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:02.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)

Offline

#5 2004-05-15 17:09:25

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Can't listen sound ....

I think you should read the manual,I had the same problem myself , it's something in /etc/devfsd or something.
It's in the faq section if I remember correct, also check kmix or if you are running programs that are not using arts you must switch that off in controlcenter..
Good luck!


arch + gentoo + initng + python = enlisy

Offline

#6 2004-05-15 17:59:15

mzruya
Member
Registered: 2004-05-14
Posts: 20

Re: Can't listen sound ....

tried that, didn't really help..
i just noticed of a error i get when starting kde :

Sound server informational message:
Error while initializing the sound driver :
device : default can't be opened for playback (No such file or directory)
The sound server will continue using the null output device

Offline

#7 2004-05-15 18:23:35

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Can't listen sound ....

Have you read the manual ? And changed permission for sound ?
And loaded the right alsa modul, if you only use alsa you only need to load that,skip those OSS drivers,
Check here www.alsa-project.org


arch + gentoo + initng + python = enlisy

Offline

#8 2004-05-15 18:40:37

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Can't listen sound ....

Read set up guide in Wiki ... make sure you unmute sound in alsamixer..

check Arts settings if you use KDE ... maybe try T.O.S.S.

You may get errors I assume you are running 2.4 kernel

HTH

Mr Green...


Mr Green

Offline

#9 2004-05-15 19:00:23

mzruya
Member
Registered: 2004-05-14
Posts: 20

Re: Can't listen sound ....

what is Arts in kde ?
i'm using the 2.6 kernel scsi enabled
when i ./esd i get : audio_alsa: no cards found!

Offline

#10 2004-05-15 19:57:02

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Can't listen sound ....

Arts is KDE native soundsystem..
Listen up now..you must load the right alsa modul..wichone it is you can find out on the alsa site
when you done that you put that driver in /etc/rc.conf  and after that go and read manual!


arch + gentoo + initng + python = enlisy

Offline

Board footer

Powered by FluxBB