You are not logged in.

#1 2007-03-02 00:36:19

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,598
Website

No entry for device-mapper found

After doing a kernel upgrade today (in two of my systems) I noticed this error:

/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.

It would seem as if I'm missing something, however both machines are working fine.
So, the question is: is the "device-mapper" referenced in the error a kernel module? If so, should install it separately or should I just ignore the message? roll
Thanks.

R

Last edited by ralvez (2007-03-02 00:36:53)

Offline

#2 2007-03-02 00:40:24

graphic23
Member
Registered: 2006-11-02
Posts: 18

Re: No entry for device-mapper found

Same error here. I'm trying to find something on google but I am not able to find anything that is relevant.

Offline

#3 2007-03-02 00:48:11

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,598
Website

Re: No entry for device-mapper found

The funny thing is that it could be something missing in our systems or something missing on the kernel we are updating ... tongue
Matter of fact ... I never had the problem before in neither of these systems, which makes me thing that it may be something that did not get added to the kernel because it is not "that important" or some other reason.
Yes, yes ... I admit it, I have no clue how the kernel works cool

R

Offline

#4 2007-03-02 01:08:14

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: No entry for device-mapper found

Are you both using lilo, by any chance? A number of users on IRC have mentioned this issue, all lilo users.

Offline

#5 2007-03-02 01:14:57

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,598
Website

Re: No entry for device-mapper found

tomk,

You hit the nail in the head!
Both of the systems use lilo as a matter of fact.
C'mon now ... do not keep up on pins and needles... what's the "real" problem? Do you know? lol

R.

Offline

#6 2007-03-02 01:39:50

graphic23
Member
Registered: 2006-11-02
Posts: 18

Re: No entry for device-mapper found

Yeah, I'm using Lilo

Offline

#7 2007-03-02 01:44:20

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: No entry for device-mapper found

Sorry ralvez - I don't know what the problem is, and I don't use lilo, so I can't check it out. I'd recommend you post a bug report.

Offline

#8 2007-03-02 02:18:19

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,598
Website

Re: No entry for device-mapper found

tomk,

I did inspect one of the boxes that use lilo and compared it to my system which uses grub and both of them have EXACTLY the same content in /proc/misc.
I also have not seen the problem until now, which makes me think it may be related to the kernel upgrade and not the boxes.
Thanks for your reply!

R

Offline

#9 2007-03-02 03:12:39

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: No entry for device-mapper found

I also have this problem. I might be related to lilo as lilo was also upgraded.

Offline

#10 2007-03-03 00:10:53

sula
Member
Registered: 2005-08-07
Posts: 93

Re: No entry for device-mapper found

Same problem here , using lilo.

Offline

#11 2007-03-03 01:33:29

graphic23
Member
Registered: 2006-11-02
Posts: 18

Re: No entry for device-mapper found

I rebooted and nothing happened - meaning, it worked perfectly. Not sure why the error is showing up.

Last edited by graphic23 (2007-03-03 01:33:42)

Offline

#12 2007-03-03 14:33:54

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,807

Re: No entry for device-mapper found

same here ignored error system still boots fine.....


Mr Green

Offline

#13 2007-03-04 15:22:35

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: No entry for device-mapper found

I've got this error too and i've noticed that now hal is not able to mount automatically usb storage devices anymore...

Offline

#14 2007-03-07 14:35:16

funkmuscle
Member
Registered: 2006-02-09
Posts: 527

Re: No entry for device-mapper found

HAL has not worked for me since forever. I keep having to do a mknod and no one seems to know why.
I am using lilo and got the:
/sbin/lilo
/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.
error.
My Brother MFC210C printer will not print. It shows all is fine, it accepts jobs but no printing. I know it's working because I could scan. Just issues with printing. Tried reinstalling but nothing.
Let's see, new kernel upgrade and lilo and that's when issues started.

Offline

#15 2007-03-07 16:27:38

funkmuscle
Member
Registered: 2006-02-09
Posts: 527

Re: No entry for device-mapper found

lilo is the cause of /proc/misc: No entry for device-mapper found.
downgraded to previous lilo and error fixed.
still can't get usb printer going which looks like it is kernel related now or cups.
Too many upgrades to keep track of.

Offline

#16 2007-03-07 16:39:18

funkmuscle
Member
Registered: 2006-02-09
Posts: 527

Re: No entry for device-mapper found

getting this error now:
A print error occurred. Error message received from system:

cupsdoprint -P 'MFC210C' -J '' -H 'localhost:631' -U 'root' -o ' multiple-document-handling=separate-documents-uncollated-copies orientation-requested=3' '/opt/kde/share/apps/kdeprint/testprint.ps' : execution failed with message:
client-error-not-possible

any help??

Offline

#17 2007-03-07 17:45:33

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: No entry for device-mapper found

If you have the lilo error, solution is here:
http://www.archlinux.org/pipermail/arch … 13739.html

funkmuscle:  Please start a new thread for your printer problem.

Offline

#18 2007-03-28 17:22:29

Mindaugas
Member
From: Ireland
Registered: 2004-03-25
Posts: 95

Re: No entry for device-mapper found

modprobe dm-mod

Offline

#19 2007-08-03 15:07:54

Benedict_White
Member
From: Sussex, UK
Registered: 2004-05-27
Posts: 326
Website

Re: No entry for device-mapper found

Yep modprobe dm-mod worked for me. I did not reboot as i forgot to lilo at all after the last kernel upgrade which killed a production server for an hour sad

Still, did figure out a way of getting up to a stage where I could run lilo, involved symlinks and all sorts! smile


Kind regards

Benedict White

Offline

#20 2008-08-30 17:06:50

ashyanbhog
Member
From: India
Registered: 2008-08-19
Posts: 49

Re: No entry for device-mapper found

modprobe dm-mod worked here! Thanks a ton for the tip

Offline

#21 2008-08-30 18:23:03

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: No entry for device-mapper found

Also have lilo and the device mapper problem  I have tried modprobe dm-mod, have upgraded to kde4.1.1-1 and am unable to log-in as root...not allowed...

What to do?


Prediction...This year will be a very odd year!
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#22 2012-05-03 19:11:46

scothane
Member
Registered: 2012-04-24
Posts: 1

Re: No entry for device-mapper found

Doesn't seem to be just a lilo error, as I'm using grub2.

This occurred after upgrade to kernel 3.3.4-2.

After running sudo modprobe dm-mod, then lsmod, dm-mod is nowhere to be found.

sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
  /dev/mapper/control: open failed: No such device
  Failure to communicate with kernel device-mapper driver.
  Check that device-mapper is available in the kernel.

This is from my desktop machine which I didn't reboot before I updated grub2.
My laptop is fine, as I didn't update grub2 before rebooting, the device mapper module loads correctly.

Reverting to previous kernel to see if I can rebuild my grub.cfg correctly!

Update:
Reverted to kernel 3.3.4-1, rebuilt grub.cfg, reinstalled kernel 3.3.4-2, rebooted, dm_mod is loading correctly!

And, I didn't realize how old this thread was, oops!

Last edited by scothane (2012-05-03 20:04:50)

Offline

#23 2013-05-28 15:59:39

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 392

Re: No entry for device-mapper found

Hi. The update for grub2 today created a new "grub.cfg". I decided to check this by running grub-mkconfig -o test.cfg:

grub-mkconfig -o test_grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
  /dev/mapper/control: open failed: No such device
  Failure to communicate with kernel device-mapper driver.
  Check that device-mapper is available in the kernel.
  No volume groups found
done

The module "dm-mod" is not available under /lib/modules with standard archlinux-kernel.

Offline

#24 2013-05-31 07:29:09

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 392

Re: No entry for device-mapper found

Solved: Reboot
Rationale: This seem to be happen, if grub and kernel are upgraded at same time. In that case, dm-mod can't be loaded.

Anyway I don't need dm-mod.

Offline

#25 2015-09-30 21:25:00

jernst
Member
From: Silicon Valley
Registered: 2014-03-04
Posts: 256
Website

Re: No entry for device-mapper found

This just happened to me: the reason was that I upgraded packages, including the kernel, which removed the dm-mod kernel module from the directory corresponding to the current kernel, and put it into the directory of the newly installed kernel. So the current kernel could not find the module any more.

After reboot, the new kernel looks in the right directory, and everything works.

Offline

Board footer

Powered by FluxBB