You are not logged in.

#1 2007-07-30 18:05:31

opeth115
Member
Registered: 2007-07-19
Posts: 63

X doesn't save setting [SOLVED]

I finally got arch installed and X wont save my session.  I try to add things to startup but once i log out they are gone.  is there anyway for me to save my startup programs for when i log in?

Last edited by opeth115 (2007-08-05 01:14:14)

Offline

#2 2007-07-30 18:20:09

s26c.sayan
Member
From: Kolkata, India
Registered: 2007-02-07
Posts: 176
Website

Re: X doesn't save setting [SOLVED]

Which Desktop environment /window manager are you using? e.g. kde, gnome,fluxbox, etc.
And what settings exactly you want to save?


March Linux : An Arch Linux "distrolet" that I am trying to develop (March = My Arch!)
Please take a look......:)

Offline

#3 2007-07-30 18:48:39

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

hello im using gnome and i want to add fusion-icon to my startup programs but every time i do and log out it just disappears

Offline

#4 2007-07-30 19:08:03

s26c.sayan
Member
From: Kolkata, India
Registered: 2007-02-07
Posts: 176
Website

Re: X doesn't save setting [SOLVED]

If you want to auto-start programs while starting Xserver, see this link : http://gentoo-wiki.com/HOWTO_Autostart_Programs#GNOME

Reading your second post, I think you might just want a program name to appear in your menu list!
Doesn't using the alacarte (?) menu editor  work?


March Linux : An Arch Linux "distrolet" that I am trying to develop (March = My Arch!)
Please take a look......:)

Offline

#5 2007-07-30 19:14:33

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

nou got it right ur link explains what i want to do and what i have been trying to do.  i do exactly that but whenever i log in the items i entered into there to startup are not there anymore... they just dissapear.

Offline

#6 2007-07-30 19:25:43

s26c.sayan
Member
From: Kolkata, India
Registered: 2007-02-07
Posts: 176
Website

Re: X doesn't save setting [SOLVED]

Check if you are the owner of this :
~/Desktop/Autostart/*

Try changing ownership by 'chown -R <username> ~/Desktop/Autostart/' (do it as ROOT).

Last edited by s26c.sayan (2007-07-30 19:26:07)


March Linux : An Arch Linux "distrolet" that I am trying to develop (March = My Arch!)
Please take a look......:)

Offline

#7 2007-07-30 19:27:34

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

it says that the file does not exist and i tried doing it the manual way and it still did not work

Offline

#8 2007-07-30 19:32:53

s26c.sayan
Member
From: Kolkata, India
Registered: 2007-02-07
Posts: 176
Website

Re: X doesn't save setting [SOLVED]

Well I dont use Gnome myself, so can't pinpoint your problem, but I think your problem might be a permissions problem. You should locate the 'startup' file (i.e. the file which starts up things for you when you start Gnome)  and make sure you are the owner of it and have read-write-execute permissions on it for you!

This is what the Arch wiki says about the file(s) : http://wiki.archlinux.org/index.php/Startup_files


March Linux : An Arch Linux "distrolet" that I am trying to develop (March = My Arch!)
Please take a look......:)

Offline

#9 2007-07-31 01:09:31

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: X doesn't save setting [SOLVED]

Does Gnome require the fam daemon like KDE? It sounds like typical behavior in the absence of fam.

Offline

#10 2007-07-31 05:13:12

PCalitrack
Member
Registered: 2007-07-18
Posts: 2

Re: X doesn't save setting [SOLVED]

just go to System->Preferences->Sessions and add a new session with location /usr/bin/fusion-icon to

Offline

#11 2007-08-04 12:39:34

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

fam is in my daemons line of /etc/rc.conf and i decided to do a reinstall and it still does the same thing.  Any ideas?

here i my rc.conf in case it helps any

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.utf8"
HARDWARECLOCK="UTC"
TIMEZONE="US/Eastern"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(e1000 slhc snd-mixer-oss snd-pcm-oss snd-page-alloc snd-pcm snd-timer snd snd-hda-intel soundcore)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="Matt"
#
# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
# interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network netfs crond portmap fam dbus hal avahi-daemon)


# End of file

Last edited by opeth115 (2007-08-04 13:15:11)

Offline

#12 2007-08-04 22:53:43

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

anybody anything?  It just doesn't want to save my settings for things to start up when i log in...

Offline

#13 2007-08-04 23:11:37

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: X doesn't save setting [SOLVED]

Something is stored in /usr/share/gnome/autostart but it's kinda weird, as not all programms that I activate at gnome startup are stored as a *.desktop file there. But maybe it can help you at least a bit. Try adding something using the session menu and have a look at the given directory before exiting gnome.

What happens if you add something using sys->pref->sessions, then close the window and open it again? Is the entry you made still there.

Your 'Deamons' line at least contains everything you need.


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#14 2007-08-04 23:15:15

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

if i add something to sys->pref->sessions then close it and open it again it's already gone without me even logging out...  what could be wrong lol i don't understand...

Offline

#15 2007-08-04 23:17:46

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: X doesn't save setting [SOLVED]

opeth115 wrote:

if i add something to sys->pref->sessions then close it and open it again it's already gone without me even logging out...  what could be wrong lol i don't understand...

Probably he tries to write what you just entered to a location where he doesn't have write access. So writing it down is denied and your entries are in fact never stored.

I'll try to find out what 'session' is actually trying to do.


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#16 2007-08-04 23:32:51

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

saciel wrote:
opeth115 wrote:

if i add something to sys->pref->sessions then close it and open it again it's already gone without me even logging out...  what could be wrong lol i don't understand...

Probably he tries to write what you just entered to a location where he doesn't have write access. So writing it down is denied and your entries are in fact never stored.

I'll try to find out what 'session' is actually trying to do.

thank you very much or this help i've been looking for a while now and still havn't been able to  solve it

Offline

#17 2007-08-04 23:37:20

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: X doesn't save setting [SOLVED]

Ok, here is what I found out:

The session-entries made by specific user are stored as *.desktop in

~/.config/autostart

Entries that gnome makes for all users (for example the Power Manager) are stored in the directory mentioned in my post above. So have a look if you have the .config/ in your home directory and if you have write access.


And here is how I found out:

I ran gnome-session-properties from a console using strace to get informations which files gnome-session-properties is using. I piped standard error - that's where strace is writing to - in a file.

strace gnome-session-properties 2> gsp_log

While in session-properties I made a test entry with a unique name, calling it "Testeintrag" with "CMD" as command. Afterwards I was searching my strace log-file for this unique name and found out where he's trying to write it to: /home/micha/.config/autostart/CMD.desktop

So if you have write access to the directroy mentioned above and it still fails saving your entries, you could try to use strace (there's a package in base repository with that name) to find out what's happening. It'll tell you which files are opened, closed, written to and what kind of errors occured.


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#18 2007-08-04 23:44:42

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: X doesn't save setting [SOLVED]

If all else fails, create ~/.config/autostart and manually add files with a .desktop ending to the directory. These files should look like:

[Desktop Entry]
Name=<general name>
Encoding=UTF-8
Version=1.0
Name[en_US]=<english name>
<names for other languages if desired>
Exec=<command>
X-GNOME-Autostart-enabled=true

Replace the expressions in <> with what you want to start...


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#19 2007-08-05 00:02:01

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

hey thanks for that i don't have that file in my home directory... i don't understand why...  i have reinstalled twice through the ftp install disk..  why is it doing that?

Offline

#20 2007-08-05 00:05:46

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: X doesn't save setting [SOLVED]

I don't know... but one should assume that session-properties should be able to create the directroy if it is not there!

Anyhow, try to create it manually using:

mkdir -p ~/.config/autostart

Then try again using sys->pref->session and see if it works. If not, we'll try the strace method!


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#21 2007-08-05 00:25:51

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: X doesn't save setting [SOLVED]

Well, I tried renaming my .config directory right now and adding an entry. Then a new .config is created and the entry still appears on opening 'sessions' again.

So you should probably install strace and try the command posted above if you want to see what's going on. Open the file created by strace (in the example i called it gsp_log) with your favorite text editor and let it look up the name you've chosen for the entry. In my example above, the relevant lines look like that:

access("/home/micha/.config/autostart/CMD.desktop", F_OK) = -1 ENOENT (No such f
ile or directory)
access("/home", F_OK)                   = 0
stat64("/home", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
access("/home/micha", F_OK)             = 0
stat64("/home/micha", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
access("/home/micha/.config", F_OK)     = 0
stat64("/home/micha/.config", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
access("/home/micha/.config/autostart", F_OK) = 0
stat64("/home/micha/.config/autostart", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
lstat64("/home/micha/.config/autostart/CMD.desktop", 0xbfc8f01c) = -1 ENOENT (No such file or directory)
open("/home/micha/.config/autostart/CMD.desktop", O_WRONLY|O_TRUNC|O_LARGEFILE) = -1 ENOENT (No such file or directory)
open("/home/micha/.config/autostart/CMD.desktop", O_WRONLY|O_CREAT|O_EXCL|O_TRUNC|O_LARGEFILE, 0700) = 14
write(14, "[Desktop Entry]\n", 16)      = 16
write(14, "Name=No name\n", 13)         = 13
write(14, "Encoding=UTF-8\n", 15)       = 15
write(14, "Version=1.0\n", 12)          = 12
write(14, "Name[en_US]=Testeintrag\n", 24) = 24
write(14, "Exec=CMD\n", 9)              = 9
write(14, "X-GNOME-Autostart-enabled=true\n", 31) = 31
close(14)                               = 0

He first checks if the file is there yet - it isn't - then he checks weather directories and subdirectories exist. Then the file is created and the information are written. What does your strace output look like?


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#22 2007-08-05 01:09:00

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

that worked thank you sooooooooooo much.  i appreciate all this help very much. finally i can get it to save my settings lol thank you again!

Offline

#23 2007-08-05 01:11:53

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: X doesn't save setting [SOLVED]

opeth115 wrote:

that worked thank you sooooooooooo much.  i appreciate all this help very much. finally i can get it to save my settings lol thank you again!

No problem... What did you finally do? Was it enough to create the directory? Did you have a look with strace?

And at last, edit the title of the thread, adding a "[solved]" to the beginning!


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#24 2007-08-05 01:14:52

opeth115
Member
Registered: 2007-07-19
Posts: 63

Re: X doesn't save setting [SOLVED]

all i ended up doing was creating that file and everything works  i appreciate ur help so much

Offline

Board footer

Powered by FluxBB