You are not logged in.

#1 2006-11-05 19:39:00

adax
Member
Registered: 2006-10-28
Posts: 31

ipw3945 slow transfer speed

Hi all.
I have installed the ipw3945 drivers on my fujitsu amilo and they are working.
However, the connection speed is terrible, with a maximum of 40k a second.

I am using it to connect to my linksys ap which uses the 80211b protocol.
when running windows on the same laptop i can achieve over 500k a second transfer rates.

I tried switching channels on the ap, setting the essid to broadcast etc. but that didnt help.
I am using WEP encryption and static ip addresses.

can anybody give me a clue as to what is going on?
How to get this thing working better or how to diagnose the fault.

Thanks,
ad.

Offline

#2 2006-11-05 20:47:55

tardo
Member
Registered: 2006-07-15
Posts: 526

Re: ipw3945 slow transfer speed

Have you tried speed tests? or downloading from another source/mirror?

Offline

#3 2006-11-05 21:37:39

adax
Member
Registered: 2006-10-28
Posts: 31

Re: ipw3945 slow transfer speed

i tested the speed by downloading a large file from a local webserver i set up on my desktop machine.
Windows will download the file to my laptop over the wireless connection at over 500k a second. The same laptop running arch will only transfer at 40k a second.

I have a zaurus PDA which runs linux, and that will download the file at over 400k a second too. So I think that there must be something wrong with the driver or my configuration.
sad

Offline

#4 2006-11-08 10:03:27

adax
Member
Registered: 2006-10-28
Posts: 31

Re: ipw3945 slow transfer speed

just wondering if anyone has experienced anything similar to this?
i still can't get the machine to connect quickly.

someone suggested i install ethereal and try to find out what is going on, but it doesnt seem to be in the repository.
sad

Offline

#5 2006-11-08 10:16:26

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: ipw3945 slow transfer speed


Have you tried to turn it off and on again?

Offline

#6 2006-11-08 14:12:46

marteus
Member
From: Denmark
Registered: 2006-01-24
Posts: 30

Re: ipw3945 slow transfer speed

It did happen to me, with the exception of being capped at ~100kb/s.

Try to update the drivers (may involve some manual pkgbuild tweaking), last time I checked they were out of date.

Offline

#7 2006-11-12 16:00:36

adax
Member
Registered: 2006-10-28
Posts: 31

Re: ipw3945 slow transfer speed

Hi.
Thanks for the help, but i'm still not getting anything like the performance i get using windows.

my /etc/conf.d/wireless file looks like this:

WLAN_INTERFACES=(eth2)

wlan_eth2="eth2 mode Managed essid 'bluethunder' ap 00:12:17:C1:F8:58 key 507014dc529b6129a22ae8ecc8"

i think i have updated the ipw3945 drivers to the latest stable version 1.1.0
modinfo gives me this:

[root@laptop ~]# modinfo ieee80211
filename:       /lib/modules/2.6.18-ARCH/net/ieee80211/ieee80211.ko
version:        1.2.15
description:    802.11 data/management/control stack
author:         Copyright (C) 2004-2005 Intel Corporation <jketreno>
license:        GPL
vermagic:       2.6.18-ARCH SMP preempt mod_unload 686 REGPARM gcc-4.1
depends:        ieee80211_crypt
srcversion:     7F29B6E25FD4CAC95140E47
parm:           debug:debug output mask (int)

[root@laptop ~]# modinfo ipw3945
filename:       /lib/modules/2.6.18-ARCH/kernel/drivers/net/wireless/ipw3945/ipw3945.ko
description:    Intel(R) PRO/Wireless 3945 Network Connection driver for Linux
version:        1.1.0d
author:         Copyright(c) 2003-2006 Intel Corporation
license:        GPL
vermagic:       2.6.18-ARCH SMP preempt mod_unload 686 REGPARM gcc-4.1
depends:        ieee80211
alias:          pci:v00008086d00004222sv*sd*bc*sc*i*
alias:          pci:v00008086d00004227sv*sd*bc*sc*i*
srcversion:     61D4EFA71C14926D18C39EE
parm:           mode:network mode (0=BSS,1=IBSS) (int)
parm:           channel:channel to limit associate to (default 0 [ANY]) (int)
parm:           debug:debug output mask (int)
parm:           led:enable led control (default 1 on) 
(int)
parm:           auto_create:auto create adhoc network (default 1 on) (int)
parm:           associate:auto associate when scanning (default 0 off) (int)
parm:           disable:manually disable the radio (default 0 [radio on]) (int)
parm:           antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)

iwconfig and ifconfig give me the following:

[root@laptop ~]# iwconfig eth2
eth2      IEEE 802.11b  ESSID:"bluethunder
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:12:17:C1:F8:58
          Bit Rate:5.5 Mb/s   Tx-Power:15 dBm
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:5070-14DC-529B-6129-A22A-E8EC-C8   Security mode:open
          Power Management:off
          Link Quality=80/100  Signal level=-31 dBm  Noise level=-32 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1070   Missed beacon:0

[root@laptop ~]# ifconfig eth2
eth2      Link encap:Ethernet  HWaddr 00:13:02:70:0F:15
          inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::213:2ff:fe70:f15/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:48748 errors:0 dropped:1247 overruns:0 frame:0
          TX packets:2628 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:243174 (237.4 Kb)  TX bytes:214521 (209.4 Kb)
          Interrupt:18 Base address:0x2000 Memory:b0200000-b0200fff

What worries me is the high value of "Invalid misc:" that iwconfig reports.
can anyone think of what else i can try to get the performance i need?
Is there some other forum i should post my problem to?

Arch linux is so much better than my old suse10.1 installaton.
all i need to fix now is the wireless network, (which is a general linux problem) and i'll be very happy.

ad.

Offline

#8 2006-11-16 19:05:55

broch
Banned
From: L.A. California
Registered: 2006-11-13
Posts: 975

Re: ipw3945 slow transfer speed

same card:
dslreport test
down/up
3839 / 82 (Kbps)
(468.6 / 10 KB/sec)

obviously speed will vary depending on the network status (in my case vpn at work), but this card does not have speed problems.

I have installed ipw3945-1.1.2
from
http://ipw3945.sourceforge.net/#downloads
I turned off debugging (and enabled monitor for kismet) in Makefile before compiling

check MTU, and maybe tweak tcp parameters through sysctl.

hope this will help a little.

Offline

#9 2006-11-23 14:42:40

adax
Member
Registered: 2006-10-28
Posts: 31

Re: ipw3945 slow transfer speed

Hi broch, thanks for the advice.

I have downloaded and installed the 1.1.2 drivers but I'm still getting the same results.
I have tried reducing the MTU to 1400 and lower but with no discernible difference to performance.

one thing I did have to do was build the drivers with the make command
make IEEE80211_IGNORE_DUPLICATE=y

do you think this could have something to do with it?
to be honest I don't know much about compiling drivers, so if you could post some instructions as to what you did I could try to emulate that.

thanks again,
ad.

Offline

#10 2006-11-23 19:58:10

broch
Banned
From: L.A. California
Registered: 2006-11-13
Posts: 975

Re: ipw3945 slow transfer speed

one thing I did have to do was build the drivers with the make command
make IEEE80211_IGNORE_DUPLICATE=y

no this flag only ignores not used ieee80211 symbols (usually when installed latest not included in kernel version of ieee80211).
I have to use this flag too.

this is problem you may try to fix(your iwconfig):

Bit Rate:5.5 Mb/s   Tx-Power:15 dBm

this is mine:
Bit Rate:54 Mb/s   Tx-Power:15 dBm

I would take look at your router/AP config too. Not sure what may cause this problem

Offline

#11 2007-01-03 02:45:28

Caboose
Member
Registered: 2006-10-06
Posts: 2

Re: ipw3945 slow transfer speed

Anyone ever find out what's causing this problem?

I have the same problem, and have been trying to fix it for about a week now with no luck. I've used 3 different (arch, gentoo, and ubuntu edgy), installed the ipw3945 driver through the respective package managers, and from source.

When I had windows installed, (No longer installed, and I wiped the recovery partition the day I got the laptop) the wireless worked fine, 400KB/s easily.

It's horrendously slow, 10KB/s down max, texted the same way as the OP with the transfer of a large file from my desktop.

I've used both the stable 1.1.0 version, and the latest 1.1.3 version of the driver, I'd really like to fix this problem.

When I ping an address, say google.com, I get anywhere from 25-60% packet loss as well.

[root@batbook ~]# iwconfig eth2
eth2      IEEE 802.11b  ESSID:"XXXX"  Nickname:"XXXX"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:04:5A:FD:1D:8F   
          Bit Rate:11 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XX   Security mode:open
          Power Management:off
          Link Quality=81/100  Signal level=-53 dBm  Noise level=-54 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4333   Missed beacon:0
[root@batbook ~]# ifconfig eth2
eth2      Link encap:Ethernet  HWaddr 00:18:DE:A3:7B:D1  
          inet addr:192.168.1.110  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::218:deff:fea3:7bd1/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:46 errors:10 dropped:4485 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:74806 (73.0 Kb)  TX bytes:107581 (105.0 Kb)
          Interrupt:16 Memory:d8000000-d8000fff 

Offline

#12 2007-03-28 19:41:28

DeltaXFX
Member
From: USA
Registered: 2006-08-01
Posts: 74

Re: ipw3945 slow transfer speed

I just noticed something, both of you have horrible EbNo's on your wireless cards:

adax:

Link Quality=80/100  Signal level=-31 dBm  Noise level=-32 dB

Caboose:

Link Quality=81/100  Signal level=-53 dBm  Noise level=-54 dBm

Both of you only have a signal level 1dB higher than the noise floor.
I use a rt2500 wireless card but the principals are the same. You should see something more like:

Quality:96/100  Signal level:-32 dBm  Noise level:-192 dBm

Notice how much higher the signal is than the noise? I would say that your card is in some sort of power saving mode. The bad EbNo can easily account for your packet loss.
You could just buy a rt2500 card, I always swap my intel cards for ralink, they are only like $30 US and save all kinds of headache tongue


The Internet...? Is that thing still around?

Offline

#13 2007-03-28 22:27:03

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: ipw3945 slow transfer speed

i also got a ipw3945 wireless card. these are my stats:

 Quality=90/100  Signal level=-42 dBm  Noise level=-42 dBm

my download speed is nearly the maximum for 54mbit wireless lan (ca. 2.8mb/s).

mfg iggy


sorry for my bad english smile

Offline

#14 2007-03-29 00:26:40

broch
Banned
From: L.A. California
Registered: 2006-11-13
Posts: 975

Re: ipw3945 slow transfer speed

actually, no, link quality is not a major factor in terms of speed.
with link quality 60/100 I was getting almost max speed.

Bit Rate:11 Mb/s
or
Bit Rate:5.5 Mb/s

don't expect miracles it this is max. The problem is with wireless config.
for example
wlan should not be configured for ipw3945

Offline

#15 2007-03-29 02:16:56

raymano
Member
Registered: 2006-10-13
Posts: 357
Website

Re: ipw3945 slow transfer speed

Try:
iwconfig eth2 modu 11b

and:
iwconfig eth2 rate 11M auto

I remember having a similar problem with dropped packets with a 802.11b wireless router with my built-in Intel ipw3945 card and I think these commands fixed the problem.

Worth a shot :-)


FaunOS: Live USB/DVD Linux Distro: http://www.faunos.com

Offline

#16 2007-05-08 13:05:08

IsSuE
Member
From: Upper Austria
Registered: 2006-04-29
Posts: 309

Re: ipw3945 slow transfer speed

Is it possible that this behavior is related to the driver?
I searched the web for this issue, and there are a lot of people complaining. Anyone tried iwlwifi yet?

Offline

#17 2007-08-13 08:49:09

somedrew
Member
From: Canada
Registered: 2007-05-14
Posts: 140

Re: ipw3945 slow transfer speed

IsSuE wrote:

Is it possible that this behavior is related to the driver?
I searched the web for this issue, and there are a lot of people complaining. Anyone tried iwlwifi yet?

I've had a similar (?) issue with being intermittently capped at ~100kb/s and just tried iwlwifi.
Using iwlwifi *seems* to have solved the speed issue, and my signal to noise ratio has dramatically increased from ~1:1 to 2:1. Haven't done anything to conclude that it was the ipw3945 driver, but I'm now happily using iwlwifi. Additionally, networkmanager is working properly now.
cheers,

Offline

#18 2007-08-13 14:29:20

shen
Member
Registered: 2003-09-05
Posts: 272
Website

Re: ipw3945 slow transfer speed

with using iwlwifi driver for the ipw3945 cards is it just a matter of removing the 3 ipw3945 packages and then installing the iwlwifi and iwlwifi-3945-ucode packages and modifying rc.conf to load the new driver and not the daemon?

Offline

#19 2007-08-14 12:02:45

somedrew
Member
From: Canada
Registered: 2007-05-14
Posts: 140

Re: ipw3945 slow transfer speed

shen wrote:

with using iwlwifi driver for the ipw3945 cards is it just a matter of removing the 3 ipw3945 packages and then installing the iwlwifi and iwlwifi-3945-ucode packages and modifying rc.conf to load the new driver and not the daemon?

Yup. No need to completely remove the ipw3945 packages if you just want to take the new drivers out for a spin, but you'll at least need to stop the deamon and make sure to unload the ipw3945driver. After that, it's as easy as a modprobe iwl3945. I'm not sure if you need iwl3945 in the modules array in your /etc/rc.conf to get it to load on boot or whether it'll get loaded when needed, but I put it in there anyway.
cheers,

Last edited by somedrew (2007-08-14 12:06:26)

Offline

Board footer

Powered by FluxBB