You are not logged in.

#1 2007-08-22 16:00:06

fwojciec
Member
Registered: 2007-05-20
Posts: 1,411

Problems with suspend2 after hibernate-script/userui update?

It may be because I compile my own kernel with suspend2 patch, but after the latest update of hibernate-script (1.96) suspend2 stopped working for me... "sudo hibernate" would result in the following message:

cat: /sys/power/suspend2/: Is a directory
ABORTING: /sys/power/suspend2/ did not return a valid result.
hibernate: Aborting.

The following fix worked for me: http://forums.gentoo.org/viewtopic-t-57 … tlets.html
Just make sure to add the line to the end of the indicated file rather than the beginning.

Another problem came up because of the update to "userui" package - the user interface would not show up while hibernating.  This is fixed by editing "/etc/hibernate/suspend2.conf" and changing: "ProcSetting user_interface/program /usr/sbin/suspend2ui_text" line to "ProcSetting user_interface/program /usr/sbin/tuxoniceui_text" (if you're using the fbsplash version the filenames will be different - "suspend2ui_fbsplash" becomes "tuxoniceui_fbsplash").

I hope someone will find this helpful.

Last edited by fwojciec (2007-08-22 16:02:49)

Offline

#2 2007-08-23 09:54:50

ise
Developer
From: Karlsruhe / Germany
Registered: 2005-10-06
Posts: 402
Website

Re: Problems with suspend2 after hibernate-script/userui update?

Hi,
thanks for posting....in /etc/hibernate/suspend2.conf.pacnew there were already the change.

Offline

#3 2007-08-23 12:33:12

fwojciec
Member
Registered: 2007-05-20
Posts: 1,411

Re: Problems with suspend2 after hibernate-script/userui update?

ise wrote:

Hi,
thanks for posting....in /etc/hibernate/suspend2.conf.pacnew there were already the change.

The suspend2ui -> tuxoniceui change, right?  Thanks for pointing that out.

Offline

#4 2007-08-25 22:52:11

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: Problems with suspend2 after hibernate-script/userui update?

Confirmed, there is a bug in hibernate-script. Set "VerifyFilewriterResume2 no" in suspend2.conf to work around it until I have it fixed.

Offline

Board footer

Powered by FluxBB